Bug 75275 - courier italic font bigger than normal font
courier italic font bigger than normal font
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xemacs (Show other bugs)
8.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jens Petersen
Jay Turner
: FutureFeature
: 75833 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-06 14:34 EDT by Ville Skyttä
Modified: 2015-01-07 19:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-12 09:44:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xemacs out of the box on RH8 (6.18 KB, image/png)
2002-10-06 14:34 EDT, Ville Skyttä
no flags Details
Fixed situation with try-oblique-before-italic-fonts t (5.85 KB, image/png)
2002-10-06 14:35 EDT, Ville Skyttä
no flags Details

  None (edit)
Description Ville Skyttä 2002-10-06 14:34:04 EDT
Italic fonts look bad on out of the box XEmacs on RH8 and previous versions,
fortunately the solution is simple.  Just add this into the site-start.el in the
XEmacs RPM:

;; Oblique produces often better results than italic with monospace fonts.
(setq-default try-oblique-before-italic-fonts t)

I'll attach a couple of screenshots how this affects the font display here, note
the size of the font.
Comment 1 Ville Skyttä 2002-10-06 14:34:40 EDT
Created attachment 79084 [details]
xemacs out of the box on RH8
Comment 2 Ville Skyttä 2002-10-06 14:35:35 EDT
Created attachment 79085 [details]
Fixed situation with try-oblique-before-italic-fonts t
Comment 3 Jens Petersen 2002-10-06 23:10:38 EDT
Looks reasonable.
Comment 4 Jens Petersen 2002-10-07 01:06:25 EDT
Ok, I tested this a bit, and I agree adding the above line to site-start.el
fixes the italic face size problem with latin-1 default adobe-courier font.

However it doesn't seem to fix the startup splash screen for me like in your
screenshot. Does this require a rebuilt to have effect the startup fonts too?
Well there is one way to find out...
Comment 5 Ville Skyttä 2002-10-07 02:24:31 EDT
You know, it *did* fix the splash screen fonts for me, the screenshots are
there.  However, it (alone) isn't enough any more for me either, dunno why.  And
rebuild is not necessary.

Anyway, this does work for me now:

;; Oblique produces usually better results than italic.
(setq-default try-oblique-before-italic-fonts t)
(custom-set-faces
 '(bold-italic ((t (:bold t :italic t))) t)
 '(italic ((t (:italic t))) t))
Comment 6 Jens Petersen 2002-10-07 04:51:04 EDT
Yeah, that does it or even
(make-face-italic 'italic)
(make-face-italic 'bold-italic)

But this seems like a bit of a hack since clearly the italic fonts are
being initialised somewhere earlier in the startup process.
Comment 7 Ville Skyttä 2002-10-07 12:08:02 EDT
True, it's kinda hacky.  But putting only the (setq-default
try-oblique-before-italic-fonts t) part in fixes the fonts in modes that use
italics, eg. cperl-mode, so I think that should at least be applied.  The splash
screen is not that important anyway.

I'll ask if there's something we could do about this by default in XEmacs (I'm a
dev team member).
Comment 8 Ville Skyttä 2002-10-08 12:47:39 EDT
Well, I asked about it, and got a couple of answers.  I'd say that means the
hack above could be applied to the RH XEmacs package.  If you don't like the
"hackish" part, please at least apply the try-oblique-before-italic-fonts part,
since it seems to be a feature of the Courier font distributed with RH8.

<http://list-archive.xemacs.org/xemacs-beta/200210/msg00179.html>
<http://list-archive.xemacs.org/xemacs-beta/200210/msg00176.html>
Comment 9 Jens Petersen 2002-10-08 22:24:25 EDT
Ok, thanks for looking into it further.

I guess I'm ok, with adding the above in for the time being.
Will try to get that done before too long.

I presume it is the adobe courier font is "broken" in not having
good italic coverage and not a RH specific problem?

[Personally I use gothic, and I haven't had any problems - though normally
I'm in a Japanese locale anyway.]
Comment 10 Jens Petersen 2002-10-14 22:29:10 EDT
*** Bug 75833 has been marked as a duplicate of this bug. ***
Comment 11 Jens Petersen 2002-11-12 02:24:42 EST
Fix will be in forthcoming package update.
Comment 12 Jens Petersen 2002-11-12 09:44:42 EST
Should be fixed in xemacs-21.4.10-1.  Thanks.
Comment 13 Ville Skyttä 2002-12-01 07:25:14 EST
Yep, I see the workaround is in rawhide, thanks.

Note You need to log in before you can comment on or make changes to this bug.