Bug 752836 - Review Request: perl-Class-Field - Class Field Accessor Generator
Summary: Review Request: perl-Class-Field - Class Field Accessor Generator
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Parag AN(पराग)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 752838
TreeView+ depends on / blocked
 
Reported: 2011-11-10 14:45 UTC by Daniel Berrangé
Modified: 2011-11-25 23:27 UTC (History)
3 users (show)

Fixed In Version: perl-Class-Field-0.15-2.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-15 14:21:47 UTC
Type: ---
panemade: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Daniel Berrangé 2011-11-10 14:45:49 UTC
Spec URL: http://berrange.fedorapeople.org/review/perl-Class-Field/perl-Class-Field.spec
SRPM URL: http://berrange.fedorapeople.org/review/perl-Class-Field/perl-Class-Field-0.15-1.fc15.src.rpm
Description: perl-Class-Field is a Perl module for automatically generating class accessors.

It is needed by perl-TAP-Formatter-JUnit

NB: rpmlint generates a warning which is bogus since it refers to a programming language literal, not a normal english word

$ rpmlint  perl-Class-Field-0.15-1.fc15.src.rpm
perl-Class-Field.src: W: spelling-error %description -l en_US const -> cons, cont, cost

Comment 1 Parag AN(पराग) 2011-11-15 07:23:40 UTC
Review:-
+ koji build ->http://koji.fedoraproject.org/koji/taskinfo?taskID=3514609
+ rpmlint on package gave
perl-Class-Field.src: W: spelling-error %description -l en_US const -> cons, cont, cost
perl-Class-Field.noarch: W: spelling-error %description -l en_US const -> cons, cont, cost
+ Source match with upstream as (sha1sum)
908a42ded2f16a5066313a8cd20ed41a6de599b8  Class-Field-0.15.tar.gz
908a42ded2f16a5066313a8cd20ed41a6de599b8  ../SOURCES/Class-Field-0.15.tar.gz
+ Follows packaging guidelines.
+ make test shows
All tests successful.
Files=3, Tests=14,  0 wallclock secs ( 0.02 usr  0.01 sys +  0.08 cusr  0.01 csys =  0.12 CPU)
+ Package  perl-Class-Field-0.15-1.fc17.noarch
  Provides: perl(Class::Field) = 0.15
  Requires: perl >= 0:5.006001 perl(Encode) perl(Exporter) perl(base) perl(strict) perl(utf8) perl(warnings)


Suggestions:
1) you don't need to specify following
BuildRequires:  perl >= 1:5.6.1

2) For the active fedora releases you can remove following from spec
 a) buildroot
 b) cleaning of buildroot in %install
 c) %clean section
 d) %defattr(-,root,root,-)

Comment 2 Daniel Berrangé 2011-11-15 09:56:30 UTC
New Package SCM Request
=======================
Package Name: perl-Class-Field
Short Description: Class Field Accessor Generator
Owners: berrange
Branches: f15 f16
InitialCC: perl-sig

Comment 3 Gwyn Ciesla 2011-11-15 13:02:10 UTC
Git done (by process-git-requests).

Comment 4 Daniel Berrangé 2011-11-15 14:21:35 UTC
Built into rawhide

Comment 5 Fedora Update System 2011-11-16 13:30:16 UTC
perl-Class-Field-0.15-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/perl-Class-Field-0.15-2.fc15

Comment 6 Fedora Update System 2011-11-16 13:31:00 UTC
perl-Class-Field-0.15-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/perl-Class-Field-0.15-2.fc16

Comment 7 Fedora Update System 2011-11-25 23:21:55 UTC
perl-Class-Field-0.15-2.fc15 has been pushed to the Fedora 15 stable repository.

Comment 8 Fedora Update System 2011-11-25 23:27:30 UTC
perl-Class-Field-0.15-2.fc16 has been pushed to the Fedora 16 stable repository.


Note You need to log in before you can comment on or make changes to this bug.