Bug 75285 - Adaptec 1480B PCMCIA CardBus card doesn't work
Adaptec 1480B PCMCIA CardBus card doesn't work
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
: 67893 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-06 16:03 EDT by Csaba Paradi
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-31 17:05:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Csaba Paradi 2002-10-06 16:03:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
When I insert Adaptec 1480B PCMCIA CardBus card I got the attached error
messsage in dmesg.
The error occurs when the cb_alloc tries to assign a PCI bus and resurces to the
card.
My computer is: Toshiba Tecra 8200.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Insert Adaptec SlimSCSI 1480B card
2. See the kernel's dmesg output.
3.
	

Actual Results:  cs: cb_alloc(bus 5): vendor 0x9004, device 0x6075
PCI: Failed to allocate resource 0(e000-dfff) for 05:00.0
PCI: Failed to allocate resource 1(f8000000-f7dfffff) for 05:00.0
PCI: Failed to allocate resource 6(f8000000-f7dfffff) for 05:00.0
PCI: Enabling device 05:00.0 (0000 -> 0003)
SCSI subsystem driver Revision: 1.00
PCI: Setting latency timer of device 05:00.0 to 64
aic7xxx: PCI Device 5:0:0 failed memory mapped test
ahc_pci:5:0:0: No SCB space found


Additional info:

The situation was the same with RedHat 7.3 too.
If I disable the kernel pcmcia driver in a custom kernel, and install
pcmcia-cs from pcmcia-cs.sf.net, the apa1480_cs driver can initialize the card
with the PnP resource checking option.

I tried it with RedHat 7.3.
Comment 1 Need Real Name 2002-10-31 17:05:47 EST
This is a kernel PCI subsystem bug having to do with resource selection for 
devices behind PCI-to-PCI bridges.  I believe that it is fixed in the current 
(2.4.20-pre and 2.5.45) trees.  There is no work-around for older kernels.

-- Dave Hinds
Comment 2 Csaba Paradi 2002-11-05 11:44:11 EST
I tried 2.4.20_rc1 kernel, and it works fine with aic7xxx driver. 
Thanks Dave !
Comment 3 Csaba Paradi 2002-11-05 11:50:13 EST
*** Bug 67893 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.