Bug 752940 - anacoda works poorly behind a proxy
anacoda works poorly behind a proxy
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-10 14:53 EST by Felipe Contreras
Modified: 2011-11-14 16:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 753953 (view as bug list)
Environment:
Last Closed: 2011-11-14 16:43:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felipe Contreras 2011-11-10 14:53:20 EST
Description of problem:
When trying to install Fedora 16 behind a proxy, there are several issues. The most important one is that it takes *several minutes* for NetworkManager.

The second issue is that there is no step to configure a proxy; it's only after repository fetching fails, and if the user happens to click in 'edit repository' (which is unintuitive), that the user might see an option for proxies. Then, it's still not ideal, because it's per repository, so it has to be configured multiple times.

How reproducible:
Always

Steps to Reproduce:
1. Try to install Fedora behind a proxy
  
Actual results:
It's incredibly painful; takes too long, configure has to be typed multiple times.

Expected results:
Smooth; no delays, configuration typed once.
Comment 1 Brian Lane 2011-11-14 14:23:46 EST
You should be able to use the proxy=URL cmdline option to specify the proxy.

https://fedoraproject.org/wiki/Anaconda_Boot_Options#proxy

If this doesn't work, please attach your logs from /tmp/*log as individual plain/text files.
Comment 2 Felipe Contreras 2011-11-14 15:09:17 EST
(In reply to comment #1)
> You should be able to use the proxy=URL cmdline option to specify the proxy.

That's completely unfriendly to the user. There must be an option to set the proxy while setting up the network.
Comment 3 Brian Lane 2011-11-14 15:58:11 EST
I'll assume that works then. If not, please reopen with logs.
Comment 4 Felipe Contreras 2011-11-14 16:13:57 EST
(In reply to comment #3)
> I'll assume that works then. If not, please reopen with logs.

It works *poorly*. Do you want me to open a bug report specifying that it must be specified in UI? Would you like me to change the summary of this bug? How about contacting the design team so that they can point out that it's horrible user interface?
Comment 5 Brian Lane 2011-11-14 16:43:13 EST
logs. or leave it closed. We're not going to add UI elements for the dozens of possible cmdline options we support.

Note You need to log in before you can comment on or make changes to this bug.