Bug 753953 - anacoda works poorly behind a proxy; GUI to configure the networks should include proxy
anacoda works poorly behind a proxy; GUI to configure the networks should inc...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-14 17:38 EST by Felipe Contreras
Modified: 2012-08-03 15:35 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-18.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 752940
Environment:
Last Closed: 2012-08-03 15:35:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Felipe Contreras 2011-11-14 17:38:41 EST
Just like it's unreasonable to ask the users to configure the wifi through anaconda's boot commands, it's unreasonable to ask the users to configure the proxy through anaconda's boot commands.

As described in the original bug:
 1) anaconda takes around 10 minutes to react when setting up the network
 2) anaconda has the proxy configuration available through the UI, but it's per repository, and very hidden

Completely unacceptable.

+++ This bug was initially created as a clone of Bug #752940 +++

Description of problem:
When trying to install Fedora 16 behind a proxy, there are several issues. The most important one is that it takes *several minutes* for NetworkManager.

The second issue is that there is no step to configure a proxy; it's only after repository fetching fails, and if the user happens to click in 'edit repository' (which is unintuitive), that the user might see an option for proxies. Then, it's still not ideal, because it's per repository, so it has to be configured multiple times.

How reproducible:
Always

Steps to Reproduce:
1. Try to install Fedora behind a proxy
  
Actual results:
It's incredibly painful; takes too long, configure has to be typed multiple times.

Expected results:
Smooth; no delays, configuration typed once.

--- Additional comment from bcl@redhat.com on 2011-11-14 14:23:46 EST ---

You should be able to use the proxy=URL cmdline option to specify the proxy.

https://fedoraproject.org/wiki/Anaconda_Boot_Options#proxy

If this doesn't work, please attach your logs from /tmp/*log as individual plain/text files.

--- Additional comment from felipe.contreras@gmail.com on 2011-11-14 15:09:17 EST ---

(In reply to comment #1)
> You should be able to use the proxy=URL cmdline option to specify the proxy.

That's completely unfriendly to the user. There must be an option to set the proxy while setting up the network.

--- Additional comment from bcl@redhat.com on 2011-11-14 15:58:11 EST ---

I'll assume that works then. If not, please reopen with logs.

--- Additional comment from felipe.contreras@gmail.com on 2011-11-14 16:13:57 EST ---

(In reply to comment #3)
> I'll assume that works then. If not, please reopen with logs.

It works *poorly*. Do you want me to open a bug report specifying that it must be specified in UI? Would you like me to change the summary of this bug? How about contacting the design team so that they can point out that it's horrible user interface?

--- Additional comment from bcl@redhat.com on 2011-11-14 16:43:13 EST ---

logs. or leave it closed. We're not going to add UI elements for the dozens of possible cmdline options we support.
Comment 1 Felipe Contreras 2011-11-14 17:41:32 EST
I'm adding Máirín Duffy who seems to know about GUI design, and hopefully would comment about the need for easy proxy configuration.

Keep in mind that many companies and universities *require* a proxy, and without such configuration, nothing from the network is accessible. In these cases the user would just scratch his/her head wonder why is it that Fedora installation hanged.
Comment 2 Máirín Duffy 2011-11-15 14:52:18 EST
Hi Felipe,

So your use case is that you're behind a company or university network, and your internet access requires the use of a proxy to hit points outside of the organization's network. For your use case, you don't need a different proxy per URL... you just need one proxy applied to any URL you try to hit from within anaconda.

We do also have a use case for folks who are within a company network, where they're using an external mirror for their main install source over http but also need to add an add-on repo or two that is hosted internally on a corporate network that requires a proxy. There feasibly could be a situation where routing all network traffic through the proxy would cause issues for one or more of the repos involved depending on where it's routed from. So we can't remove the per-URL proxy configuration. 

However, this bug identified an issue to me - in our current UI redesign mockups, we only have proxy configuration available for http install sources (see http://linuxgrrl.com/fedora-ux/Projects/Anaconda/Prototypes/Previews/hubandspoke-preview6.png). You can configure it without having to error out first, but the configuration as designed right now only applies to the main install source, not to any add-on repos.

Now I'm beginning to think maybe we should move the proxy configuration to the networking screen instead and have it effect all URLs across anaconda, and for folks who need per-URL proxys, add individual optional proxy 'overrides' for individual repos. 

What do you think? Would this change make it easier for you to install?
Comment 3 Felipe Contreras 2011-11-16 11:21:34 EST
(In reply to comment #2)
> So your use case is that you're behind a company or university network, and
> your internet access requires the use of a proxy to hit points outside of the
> organization's network. For your use case, you don't need a different proxy per
> URL... you just need one proxy applied to any URL you try to hit from within
> anaconda.

Exactly.

> We do also have a use case for folks who are within a company network, where
> they're using an external mirror for their main install source over http but
> also need to add an add-on repo or two that is hosted internally on a corporate
> network that requires a proxy. There feasibly could be a situation where
> routing all network traffic through the proxy would cause issues for one or
> more of the repos involved depending on where it's routed from. So we can't
> remove the per-URL proxy configuration.

Nobody is asking to remove the per-URL proxy configuration, but you can have in addition a global one.

Moreover, to *really* make things smooth an ideal configuration would have an entry to avoid the proxy for certain URLs, and also, have proxypac configuration (the institutions usually have this kind of magic configuration, where the right proxy is returned for the right URL). This of course would require better proxy support in yum (say, through libproxy, bug #542224).

This way the user could provide http://proxyconf/proxy.pac, and be done with it.

> However, this bug identified an issue to me - in our current UI redesign
> mockups, we only have proxy configuration available for http install sources
> (see
> http://linuxgrrl.com/fedora-ux/Projects/Anaconda/Prototypes/Previews/hubandspoke-preview6.png).
> You can configure it without having to error out first, but the configuration
> as designed right now only applies to the main install source, not to any
> add-on repos.

I'm not sure about the add-on repos, but it's per-URL, yeah. And it's annoying to have to wait until it errors out (several minutes).

> Now I'm beginning to think maybe we should move the proxy configuration to the
> networking screen instead and have it effect all URLs across anaconda, and for
> folks who need per-URL proxys, add individual optional proxy 'overrides' for
> individual repos.

The URL's to avoid is usually enough, but you could re-use the existing per-URL proxy configuration. It's just that it would still be annoying to wait for the error. Maybe there should be a way to get the error sooner.

> What do you think? Would this change make it easier for you to install?

Definitely :)
Comment 4 Felipe Contreras 2012-02-02 14:39:00 EST
Is there any chance of this moving forward?

If not, let's just be honest and say WONTFIX.
Comment 5 Felipe Contreras 2012-02-14 18:37:17 EST
Doesn't look like there's enough interest.
Comment 6 Máirín Duffy 2012-02-14 18:46:28 EST
Felipe, there is interest. We've undergoing a major overhaul of the UI.
Comment 7 Felipe Contreras 2012-02-14 19:06:34 EST
(In reply to comment #6)
> Felipe, there is interest. We've undergoing a major overhaul of the UI.

Oh, cool :)

Yes, I've been following your blog, I just didn't see anything related to proxies.
Comment 8 Radek Vykydal 2012-02-15 06:37:16 EST
I have some notes regarding proxy configuration here:
https://fedoraproject.org/wiki/Anaconda/Network#Anaconda_UX_redesign
I think we should have setting for all repositories overridable by per-repository setting, both in sw source spoke (because they would apply just to sw source).
Comment 9 Chris Lumens 2012-08-03 15:35:09 EDT
The new ui in anaconda-18.3 includes this functionality.

Note You need to log in before you can comment on or make changes to this bug.