Bug 75302 - gnome-volume-control reports errors when using VIA VT82C686 audio hardware
gnome-volume-control reports errors when using VIA VT82C686 audio hardware
Status: CLOSED DUPLICATE of bug 75144
Product: Red Hat Linux
Classification: Retired
Component: gnome-media (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-06 22:35 EDT by Michael Redd
Modified: 2015-01-07 19:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-06 22:35:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Redd 2002-10-06 22:35:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
I am using a VIA VT82C686 audio device (integrated into the motherboard) with my
copy of Red Hat Linux 8. Whenever I start gnome-volume-control, the app reports
an error regarding saving/loading the mixer settings. The plain error message is
as follows:

"An error occurred while loading or saving configuration information for
gnome-volume-control. Some of your configuration settings may not work properly."

When I click Details, it generates the following detailed error description:
---
Bad key or directory name:
 "/apps/gnome-volume-control/OSS-SigmaTel_STAC????-1/vol": `?' is an invalid
character in key/directory names
Bad key or directory name:
 "/apps/gnome-volume-control/OSS-SigmaTel_STAC????-1/pcm": `?' is an invalid
character in key/directory names
Bad key or directory name:
 "/apps/gnome-volume-control/OSS-SigmaTel_STAC????-1/speaker": `?' is an invalid
character in key/directory names
Bad key or directory name:
 "/apps/gnome-volume-control/OSS-SigmaTel_STAC????-1/line": `?' is an invalid
character in key/directory names
Bad key or directory name:
 "/apps/gnome-volume-control/OSS-SigmaTel_STAC????-1/mic": `?' is an invalid
character in key/directory names
Bad key or directory name:
 "/apps/gnome-volume-control/OSS-SigmaTel_STAC????-1/cd": `?' is an invalid
character in key/directory names
Bad key or directory name:
 "/apps/gnome-volume-control/OSS-SigmaTel_STAC????-1/igain": `?' is an invalid
character in key/directory names
Bad key or directory name:
 "/apps/gnome-volume-control/OSS-SigmaTel_STAC????-1/line1": `?' is an invalid
character in key/directory names
Bad key or directory name:
 "/apps/gnome-volume-control/OSS-SigmaTel_STAC????-1/phin": `?' is an invalid
character in key/directory names
Bad key or directory name:
 "/apps/gnome-volume-control/OSS-SigmaTel_STAC????-1/phout": `?' is an invalid
character in key/directory names
Bad key or directory name:
 "/apps/gnome-volume-control/OSS-SigmaTel_STAC????-1/video": `?' is an invalid
character in key/directory names
---

The app doesn't seem to have any trouble afterwards, and I am able to adjust and
keep my audio and volume settings just fine. Perhaps the app is reporting a
bogus error?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.You must be using a motherboard with the aforementioned audio hardware
2.Open gnome-volume-control
3.
	

Actual Results:  The aforementioned error message occurs.

Expected Results:  Clean usage of app. -- no error messages.

Additional info:
Comment 1 Havoc Pennington 2002-10-06 22:43:16 EDT

*** This bug has been marked as a duplicate of 75144 ***

Note You need to log in before you can comment on or make changes to this bug.