Bug 753216 - tigervnc-server-1.1.0-1.fc16 writes errors during uninstall
tigervnc-server-1.1.0-1.fc16 writes errors during uninstall
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
16
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
: 741727 (view as bug list)
Depends On: 744881
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-11 11:06 EST by Adam Tkac
Modified: 2013-04-30 19:50 EDT (History)
6 users (show)

See Also:
Fixed In Version: tigervnc-1.1.0-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 744881
Environment:
Last Closed: 2011-12-02 16:26:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Tkac 2011-11-11 11:06:39 EST
+++ This bug was initially created as a clone of Bug #744881 +++

From /var/log/Xorg.0.log:

[    40.532] (II) Loading /usr/lib64/xorg/modules/extensions/libvnc.so
[    40.550] (EE) Failed to load /usr/lib64/xorg/modules/extensions/libvnc.so: /usr/lib64/xorg/modules/extensions/libvnc.so: undefined symbol: GetMaster
[    40.550] (EE) LoadModule: Module vnc does not have a vncModuleData data object.
[    40.550] (II) UnloadModule: "vnc"
[    40.550] (II) Unloading vnc
[    40.551] (EE) Failed to load module "vnc" (invalid module, 0)

--- Additional comment from atkac@redhat.com on 2011-10-11 09:18:31 EDT ---

Thanks for report, there are multiple ways how to fix this bug. The best way is to export the GetMaster() symbol from Xorg, I've just sent the patch[1] to Xorg upstream and if they accept it, I will backport it to Fedora.

[1] http://lists.x.org/archives/xorg-devel/2011-October/026217.html

--- Additional comment from bugzilla-redhat-2010@martins.cc on 2011-11-10 10:42:45 EST ---

This didn't seem to make into the released F16.  Is one of the multiple ways to fix this bug something a simple user can do or do I have to forego tightervnc till then?

--- Additional comment from atkac@redhat.com on 2011-11-10 10:52:46 EST ---

(In reply to comment #2)
> This didn't seem to make into the released F16.  Is one of the multiple ways to
> fix this bug something a simple user can do or do I have to forego tightervnc
> till then?

I will release fixed libvnc.so later today or tomorrow.

--- Additional comment from updates@fedoraproject.org on 2011-11-11 09:42:52 EST ---

tigervnc-1.1.0-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/tigervnc-1.1.0-2.fc16

--- Additional comment from bugzilla-redhat-2010@martins.cc on 2011-11-11 10:57:14 EST ---

Seems to work for both i686 and x86_64.

Cleanup phase of update yields a couple of warnings:

Cleanup    : tigervnc-server-1.1.0-1.fc16.x86_64
Non-fatal POSTUN scriptlet failure in rpm package tigervnc-server-.1.0-1.fc16.x86_64 
Cleanup    : tigervnc-server-minimal-1.1.0-1.fc16.x86_64
warning: %postun(tigervnc-server-1.1.0-1.fc16.x86_64) scriptlet failed, exit status 1

--- Additional comment from atkac@redhat.com on 2011-11-11 11:05:56 EST ---

(In reply to comment #5)
> Cleanup    : tigervnc-server-1.1.0-1.fc16.x86_64
> Non-fatal POSTUN scriptlet failure in rpm package
> tigervnc-server-.1.0-1.fc16.x86_64 
> Cleanup    : tigervnc-server-minimal-1.1.0-1.fc16.x86_64
> warning: %postun(tigervnc-server-1.1.0-1.fc16.x86_64) scriptlet failed, exit
> status 1

This seems like a bug somewhere in the tigervnc-server scriptlets. I will clone this bugreport to track this issue...
Comment 1 Orion Poplawski 2011-11-16 16:40:25 EST
preuninstall scriptlet (using /bin/sh):
if [ "$1" -eq 0 ]; then
        /bin/systemctl --no-reload vncserver.service > /dev/null 2>&1
        /bin/systemctl stop vncserver.service > /dev/null 2>&1
fi
postuninstall scriptlet (using /bin/sh):
if [ "$1" -ge "1" ]; then
        /bin/systemctl try-restart vncserver.service > /dev/null 2>&1
fi

You at least need to have "|| :" at the end.  But does this even apply?  One takes the sample file and copies to vncserver@:1.service for example.  And even if this were to restart all of the vncservers, would one want this done?  Seems like it could unexpectedly kill sessions.
Comment 2 Adam Tkac 2011-11-22 09:04:54 EST
(In reply to comment #1)
> preuninstall scriptlet (using /bin/sh):
> if [ "$1" -eq 0 ]; then
>         /bin/systemctl --no-reload vncserver.service > /dev/null 2>&1
>         /bin/systemctl stop vncserver.service > /dev/null 2>&1
> fi
> postuninstall scriptlet (using /bin/sh):
> if [ "$1" -ge "1" ]; then
>         /bin/systemctl try-restart vncserver.service > /dev/null 2>&1
> fi
> 
> You at least need to have "|| :" at the end.  But does this even apply?  One
> takes the sample file and copies to vncserver@:1.service for example.  And even
> if this were to restart all of the vncservers, would one want this done?  Seems
> like it could unexpectedly kill sessions.

You are right, those statements are useless when user creates separate vncserver@:<display>.service service files.
Comment 3 Fedora Update System 2011-11-22 09:27:37 EST
tigervnc-1.1.0-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/tigervnc-1.1.0-3.fc16
Comment 4 Fedora Update System 2011-11-22 19:54:25 EST
Package tigervnc-1.1.0-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tigervnc-1.1.0-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16244/tigervnc-1.1.0-3.fc16
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2011-12-02 16:26:44 EST
tigervnc-1.1.0-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Adam Tkac 2013-03-12 14:38:18 EDT
*** Bug 741727 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.