Bug 753260 - [abrt] guake-0.4.2-3.fc15: prefs.py:502:load_configs:TypeError: Gtk.FontButton.set_font_name() argument 1 must be string, not None
Summary: [abrt] guake-0.4.2-3.fc15: prefs.py:502:load_configs:TypeError: Gtk.FontButto...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: guake
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pierre-YvesChibon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:fed34348a9493d4e057b6e49bf2...
: 756167 757600 761299 830464 849023 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-11 18:19 UTC by Adam DiFrischia
Modified: 2012-12-20 16:17 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-20 16:17:00 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 753266 0 unspecified CLOSED [abrt] guake-0.4.2-3.fc15: guake.py:369:reload_globals:ShowableError 2021-02-22 00:41:40 UTC

Internal Links: 753266

Description Adam DiFrischia 2011-11-11 18:19:21 UTC
libreport version: 2.0.7
abrt_version:   2.0.6
cmdline:        guake-prefs -OO /usr/lib64/guake/prefs.py
executable:     /usr/lib64/guake/prefs.py
kernel:         3.1.0-7.fc16.x86_64
reason:         prefs.py:502:load_configs:TypeError: Gtk.FontButton.set_font_name() argument 1 must be string, not None
time:           Fri 11 Nov 2011 01:17:54 PM EST
uid:            1000
username:       adamdifrischia

backtrace:
:prefs.py:502:load_configs:TypeError: Gtk.FontButton.set_font_name() argument 1 must be string, not None
:
:Traceback (most recent call last):
:  File "/usr/lib64/guake/prefs.py", line 718, in <module>
:    setup_standalone_signals(PrefsDialog()).show()
:  File "/usr/lib64/guake/prefs.py", line 314, in __init__
:    self.load_configs()
:  File "/usr/lib64/guake/prefs.py", line 502, in load_configs
:    self.get_widget('font_style').set_font_name(value)
:TypeError: Gtk.FontButton.set_font_name() argument 1 must be string, not None
:
:Local variables in innermost frame:
:i: <gtk.TreeModelRow object at 0x176c148>
:self: PrefsDialog(path="/usr/share/guake/prefs.glade", root="config_window")
:value: None
:combo: <gtk.ComboBox object at 0x17ccbe0 (GtkComboBox at 0x1831000)>

comment:
:Tried to run the Preferences menu before running the actual program.
:
:Expected result: Preferences menu.
:Actual result: Crash.

Comment 1 Pierre-YvesChibon 2011-11-11 19:01:33 UTC
I think the two bugs you reported are related.

Does this block you from using guake?
If so you may want to stop guake, edit the gconf file:
.gconf/apps/guake/keybindings/global/%gconf.xml
and change the key there.

There is my file as an example:
<?xml version="1.0"?>
<gconf>
	<entry name="show_hide" mtime="1320406698" type="string">
		<stringvalue>F1</stringvalue>
	</entry>
</gconf>
(I use the F1 key)

Comment 2 Adam DiFrischia 2011-11-14 01:15:27 UTC
No, they're slightly different. In this instance, having used Guake before, I wanted to configure before I ran it things like colors, how far it sticks down, etc. However, trying to run the preferences before it had created the preferences file caused it to crash. It would probably be a workaround to check if there's a pref's file and, if not, create one. Alas, I am not a coder.

Comment 3 Adam DiFrischia 2011-11-14 01:16:16 UTC
Also, no, it does not block the use of Guake; you just have to start Guake first to generate the initial pref's.

Comment 4 Afriza N. Arief 2011-11-18 03:12:08 UTC
Package: guake-0.4.2-3.fc15
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Trying to Install & Run Guake

Comment 5 badseed 2011-11-21 01:13:56 UTC
Package: guake-0.4.2-3.fc15
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Launching Guake preferences for the first time after installed.

Comment 6 Pierre-YvesChibon 2011-11-23 08:04:19 UTC
*** Bug 756167 has been marked as a duplicate of this bug. ***

Comment 7 Steven Roy 2011-11-29 15:51:18 UTC
Package: guake-0.4.2-3.fc15
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Launching the program after install.

Comment 8 Pierre-YvesChibon 2011-12-01 08:59:36 UTC
*** Bug 757600 has been marked as a duplicate of this bug. ***

Comment 9 Pierre-YvesChibon 2012-01-11 10:31:13 UTC
*** Bug 761299 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Admin XMLRPC Client 2012-01-26 20:07:30 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 11 Rob Sharp 2012-02-03 00:57:48 UTC
Executing guake for the first time, using the 'open, run' dialog presented by 'add/remove software'

Package: guake-0.4.2-3.fc15
OS Release: Fedora release 16 (Verne)

Comment 12 Alen Siljak 2012-04-24 09:46:42 UTC
just installed Guake with dependencies and ran it as a normal user

Package: guake-0.4.2-7.fc16
OS Release: Fedora release 16 (Verne)

Comment 13 Max Beikirch 2012-06-07 13:57:18 UTC
Immediately after starting guake preferences; Works fine under Ubuntu 12.04 LTS

Package: guake-0.4.2-7.fc17
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)

Comment 14 Rafael Louback Ferraz 2012-06-21 18:05:45 UTC
just opened it

Package: guake-0.4.2-7.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 15 Matthew 2012-06-23 15:41:46 UTC
Launching application immediately causes crash.

Package: guake-0.4.2-7.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 16 Pierre-YvesChibon 2012-07-26 08:43:46 UTC
*** Bug 830464 has been marked as a duplicate of this bug. ***

Comment 17 Patrice FERLET 2012-08-08 23:33:10 UTC
I simply tried to open guake...

Package: guake-0.4.2-7.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 18 Pierre-YvesChibon 2012-08-17 10:03:00 UTC
*** Bug 849023 has been marked as a duplicate of this bug. ***

Comment 19 Ondra Pelech 2012-10-07 14:19:08 UTC
tried to run guake settings right after guake installation (from the suggestion that gnome packagekit gives after installation), even before launching the guake itselt

Package: guake-0.4.4-4.fc17
OS Release: Fedora release 17 (Beefy Miracle)

Comment 20 Eduardo Villagrán Morales 2012-10-25 17:24:17 UTC
Start guake

Package: guake-0.4.4-4.fc17
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)

Comment 21 Fedora Update System 2012-11-02 17:17:58 UTC
guake-0.4.4-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/guake-0.4.4-6.fc17

Comment 22 Fedora Update System 2012-11-02 17:18:09 UTC
guake-0.4.4-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/guake-0.4.4-6.fc18

Comment 23 Fedora Update System 2012-11-03 19:26:30 UTC
Package guake-0.4.4-6.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing guake-0.4.4-6.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17538/guake-0.4.4-6.fc18
then log in and leave karma (feedback).

Comment 24 Fedora Update System 2012-12-20 16:17:03 UTC
guake-0.4.4-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.