Bug 849023 - [abrt] guake-0.4.4-4.fc17: prefs.py:513:load_configs:TypeError: Gtk.FontButton.set_font_name() argument 1 must be string, not None
[abrt] guake-0.4.4-4.fc17: prefs.py:513:load_configs:TypeError: Gtk.FontButto...
Status: CLOSED DUPLICATE of bug 753260
Product: Fedora
Classification: Fedora
Component: guake (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pierre-YvesChibon
Fedora Extras Quality Assurance
abrt_hash:2de0b8e5acfe42b01ddc00d9e1e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-17 01:52 EDT by Pratyush Sahay
Modified: 2012-08-17 06:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-17 06:03:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pratyush Sahay 2012-08-17 01:52:13 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        python -m guake.prefs
comment:        Opening the preferences option just after installing guake.
executable:     /usr/lib64/python2.7/site-packages/guake/prefs.py
kernel:         3.5.1-1.fc17.x86_64
time:           Fri 17 Aug 2012 11:21:20 AM IST
uid:            1000
username:       ipcv11

backtrace:
:prefs.py:513:load_configs:TypeError: Gtk.FontButton.set_font_name() argument 1 must be string, not None
:
:Traceback (most recent call last):
:  File "/usr/lib64/python2.7/runpy.py", line 162, in _run_module_as_main
:    "__main__", fname, loader, pkg_name)
:  File "/usr/lib64/python2.7/runpy.py", line 72, in _run_code
:    exec code in run_globals
:  File "/usr/lib64/python2.7/site-packages/guake/prefs.py", line 730, in <module>
:    setup_standalone_signals(PrefsDialog()).show()
:  File "/usr/lib64/python2.7/site-packages/guake/prefs.py", line 321, in __init__
:    self.load_configs()
:  File "/usr/lib64/python2.7/site-packages/guake/prefs.py", line 513, in load_configs
:    self.get_widget('font_style').set_font_name(value)
:TypeError: Gtk.FontButton.set_font_name() argument 1 must be string, not None
:
:Local variables in innermost frame:
:i: <gtk.TreeModelRow object at 0x1a69420>
:self: PrefsDialog(path="/usr/share/guake/prefs.glade", root="config_window")
:value: None
:combo: <gtk.ComboBox object at 0x1a92870 (GtkComboBox at 0x1af8000)>

smolt_data:
:
:
:General
:=================================
:UUID: 779e4d20-1e8b-407c-81d6-53683582562a
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 4266.86
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 CPU          6400  @ 2.13GHz
:CPU Stepping: 6
:CPU Family: 6
:CPU Model Num: 15
:Number of CPUs: 2
:CPU Speed: 2133
:System Memory: 2003
:System Swap: 8191
:Vendor: Hewlett-Packard
:System: HP xw4400 Workstation 
:Form factor: Mini Tower
:Kernel: 3.5.1-1.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Permissive
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10186:4156:10252) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #3
:(32902:10176:4156:10252) pci, ata_piix, STORAGE, N10/ICH7 Family SATA IDE Controller
:(32902:10192:4156:10252) pci, pcieport, PCI/PCI, N10/ICH 7 Family PCI Express Port 1
:(32902:10168:4156:10252) pci, None, PCI/ISA, 82801GB/GR (ICH7 Family) LPC Interface Bridge
:(32902:10208:4156:10252) pci, pcieport, PCI/PCI, 82801GR/GH/GHM (ICH7 Family) PCI Express Port 5
:(32902:10210:4156:10252) pci, pcieport, PCI/PCI, 82801GR/GH/GHM (ICH7 Family) PCI Express Port 6
:(32902:10207:4156:10252) pci, ata_piix, STORAGE, 82801G (ICH7 Family) IDE Controller
:(32902:9294:4156:10252) pci, None, PCI/PCI, 82801 PCI Bridge
:(5348:5755:4156:10252) pci, tg3, ETHERNET, NetXtreme BCM5755 Gigabit Ethernet PCI Express
:(4318:357:4318:820) pci, nouveau, VIDEO, NV44 [Quadro NVS 285]
:(32902:10185:4156:10252) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #2
:(32902:10184:4156:10252) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #1
:(32902:10108:4156:10252) pci, i82975x_edac, HOST/PCI, 82975X Memory Controller Hub
:(32902:10200:4156:10252) pci, None, MULTIMEDIA, N10/ICH 7 Family High Definition Audio Controller
:(32902:10187:4156:10252) pci, uhci_hcd, USB, N10/ICH 7 Family USB UHCI Controller #4
:(32902:10188:4156:10252) pci, ehci_hcd, USB, N10/ICH 7 Family USB2 EHCI Controller
:(32902:10109:32902:0) pci, pcieport, PCI/PCI, 82975X PCI Express Root Port
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda3 / ext4 4096 4096 4128490 2062653 2020721 1048576 770240 770240
:/dev/sda7 WITHHELD ext4 4096 4096 4031218 1636595 1431821 1024000 930494 930494
:/dev/sda6 WITHHELD ext4 4096 4096 4523231 3000384 2770612 1150560 1132173 1132173
:/dev/sda1 WITHHELD ext4 4096 4096 5039839 2004189 1748177 1281120 1274561 1274561
:/dev/sdb3 WITHHELD fuseblk 4096 4096 5518327 2671902 2671902 10753144 10698266 10698266
:/dev/sdb8 WITHHELD fuseblk 4096 4096 7721232 1452148 1452148 5906896 5876296 5876296
:
Comment 1 Pierre-YvesChibon 2012-08-17 06:03:00 EDT

*** This bug has been marked as a duplicate of bug 753260 ***

Note You need to log in before you can comment on or make changes to this bug.