Bug 753356 - [abrt] Zim-0.53-1.fc16: pageindex.py:206:select_page:ValueError: invalid tree path
[abrt] Zim-0.53-1.fc16: pageindex.py:206:select_page:ValueError: invalid tree...
Status: CLOSED DUPLICATE of bug 802750
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robin Lee
Fedora Extras Quality Assurance
abrt_hash:ea8d68890a4bc7918ef0abba38a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-11 18:38 EST by udtduetl
Modified: 2012-05-27 04:02 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-27 04:02:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description udtduetl 2011-11-11 18:38:46 EST
libreport version: 2.0.6
abrt_version:   2.0.4.981
cmdline:        /usr/bin/python /usr/bin/zim
comment:        I've done nothing, Zim did not crashed, this seems to be only some internal problem.
event_log:      2011-11-12-00:38:13> Smolt profile successfully saved
executable:     /usr/bin/zim
kernel:         3.1.0-7.fc16.x86_64
reason:         pageindex.py:206:select_page:ValueError: invalid tree path
time:           Fri Nov 11 23:31:46 2011
uid:            1000
username:       merlyn

backtrace:
:pageindex.py:206:select_page:ValueError: invalid tree path
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/zim/gui/pageindex.py", line 732, in on_open_page
:    self.treeview.select_page(path, vivificate=True)
:  File "/usr/lib/python2.7/site-packages/zim/gui/pageindex.py", line 635, in select_page
:    model.select_page(path)
:  File "/usr/lib/python2.7/site-packages/zim/gui/pageindex.py", line 206, in select_page
:    treeiter = self.get_iter(treepath)
:ValueError: invalid tree path
:
:Local variables in innermost frame:
:self: <PageTreeStore object at 0x7f925d3824b0 (zim+gui+pageindex+PageTreeStore at 0x18d76e0)>
:path: <HistoryPath: Home>
:oldpath: <IndexPath: zim-merlyn>
:treepath: (13,)
:mypath: <IndexPath: zim-merlyn>

smolt_data:
:
:
:General
:=================================
:UUID: 277f086e-b986-46c2-b48a-246c925dd8b7
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 6428.99
:CPU Vendor: AuthenticAMD
:CPU Model: AMD Phenom(tm) II X4 840 Processor
:CPU Stepping: 3
:CPU Family: 16
:CPU Model Num: 5
:Number of CPUs: 4
:CPU Speed: 3200
:System Memory: 7987
:System Swap: 10047
:Vendor: Gigabyte Technology Co., Ltd.
:System: M52LT-D3 
:Form factor: Desktop
:Kernel: 3.1.0-7.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4318:1014:5208:45058) pci, sata_nv, STORAGE, MCP61 SATA Controller
:(4318:1004:5208:20482) pci, pata_amd, STORAGE, MCP61 IDE
:(4130:4611:0:0) pci, k10temp, HOST/PCI, Family 10h Processor Miscellaneous Control
:(4318:1000:4318:0) pci, pcieport, PCI/PCI, MCP61 PCI Express bridge
:(4318:1009:5208:20484) pci, ohci_hcd, USB, MCP61 USB Controller
:(4318:1010:5208:20484) pci, ehci_hcd, USB, MCP61 USB Controller
:(4130:4610:0:0) pci, None, HOST/PCI, Family 10h Processor DRAM Controller
:(4130:4612:0:0) pci, None, HOST/PCI, Family 10h Processor Link Control
:(4130:4609:0:0) pci, None, HOST/PCI, Family 10h Processor Address Map
:(4130:4608:0:0) pci, None, HOST/PCI, Family 10h Processor HyperTransport Configuration
:(4318:1011:5208:623) pci, None, PCI/PCI, MCP61 PCI bridge
:(4318:1007:5208:57344) pci, forcedeth, BRIDGE, MCP61 Ethernet
:(4318:1764:5218:8288) pci, nouveau, VIDEO, G98 [GeForce 8400 GS]
:(4318:1002:5208:20481) pci, None, RAM, MCP61 Memory Controller
:(4318:1008:5208:40962) pci, snd_hda_intel, MULTIMEDIA, MCP61 High Definition Audio
:(4318:1013:5208:3089) pci, None, RAM, MCP61 Memory Controller
:(4318:1003:5208:3089) pci, nForce2_smbus, SERIAL, MCP61 SMBus
:(4318:992:5208:3089) pci, None, PCI/ISA, MCP61 LPC Bridge
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_odin-lv_root / ext4 4096 4096 12901535 3354321 2698961 3276800 2809375 2809375
:/dev/sda2 /boot ext4 1024 1024 495844 437487 411887 128016 127792 127792
:/dev/mapper/vg_odin-lv_home /home ext4 4096 4096 104615106 98129453 92815303 26574848 26437821 26437821
:/dev/loop0 WITHHELD iso9660 2048 2048 2355069 0 0 0 0 0
:
Comment 1 udtduetl 2011-11-15 12:03:22 EST
Package: Zim-0.53-1.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
I was moving a page under another page (as a sub page). I'm not sure if the crash is somehow related to that action.
Comment 2 nomnex 2011-12-14 19:10:43 EST
Package: Zim-0.53-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)

Comment
-----
I keeps having these ABRT reports when I use Zim 0.53.
Comment 3 nomnex 2011-12-14 19:15:38 EST
here too, moving a page under another page generates these ABRT reports.
Comment 4 nomnex 2011-12-25 17:14:30 EST
Package: Zim-0.53-1.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)

Comment
-----
I think I have already reported this bug (ABRT).
Comment 5 Fedora Admin XMLRPC Client 2012-01-10 22:24:20 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Pierguido Lambri 2012-02-02 05:02:25 EST
I deleted an empty page

Package: Zim-0.54-2.fc16
OS Release: Fedora release 16 (Verne)
Comment 7 Martin Schuppert 2012-02-02 05:08:31 EST
I deleted a sub-page, but can not reproduce it.

Package: Zim-0.54-2.fc16
OS Release: Fedora release 16 (Verne)
Comment 8 nomnex 2012-03-09 00:38:19 EST
Package: Zim-0.54-2.fc15
Architecture: i686
OS Release: Fedora release 15 (Lovelock)

Comment
-----
I encounter this bug report about an error, anytime I use zim
Comment 9 nomnex 2012-03-09 00:40:43 EST
I did it again...
Comment 10 nomnex 2012-03-09 00:48:03 EST
When I use the menu "File" > "Move" to re-order a page, there is not ABRT report generated. I though it was already mentioned, somewhere, along the bug report, but I don't see it, re-reading the comments.

The error occurs when I click on a page in the index panel, and drag it to a new location.

Forgive my repeated comments, I did not use Zim for some time, and I clear the ABRT as soon as I have reported them, since they tend to accumulate.
Comment 11 Robin Lee 2012-05-27 04:02:52 EDT

*** This bug has been marked as a duplicate of bug 802750 ***

Note You need to log in before you can comment on or make changes to this bug.