This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 75345 - missing entry for conduit config in control-center
missing entry for conduit config in control-center
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: gnome-pilot (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 74689 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-07 10:49 EDT by diego.santacruz
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-24 16:08:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description diego.santacruz 2002-10-07 10:49:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
The entry for the Pilot config in control center (preferences:/// under
nautilus) is only to configure the palm pilot harware, but not the conduits.
Another entry for the conduit configuration should be added, that executes
"gpilotd-control-applet --cap-id=1" (the tool to configure the conduits).

Version-Release number of selected component (if applicable):
gnome-pilot-0.1.65-8

How reproducible:
Always

Steps to Reproduce:
1. Open the control-center (Applications->Preferences->Control Center)
2.
3.
	

Actual Results:  No entry to configure the conduits settings

Expected Results:  An entry should be there that let's the user set the conduit
settings.

Additional info:

The command that needs to be run to configure the conduits is
"gpilotd-control-applet --cap-id=1". gpilotd-control-applet alone only
configures the hardware settings.
Comment 1 Jeremy Katz 2002-10-07 11:48:06 EDT
*** Bug 74689 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2002-10-07 11:49:53 EDT
Going to look at trying to solve this somehow, preferably without adding more
menu items.
Comment 3 berto 2002-10-07 12:03:49 EDT
As I suggested in bug 74689, is it possible to add a tab ( next to Pilots,
Devices, Advanced ) to the Handspring/Pilot Tool window?  

That would make it the most comprehensive since *all* pilot configuration will
be under one window instead of having to guess which pilot tool one would need
to run to either configure the pilot itself or configure the conduits.
Comment 4 Jeremy Katz 2002-10-07 12:25:24 EDT
That's the approach I'm currently looking at taking.
Comment 5 Jeremy Katz 2002-10-07 15:34:51 EDT
I've put up the package I just built at
http://people.redhat.com/~katzj/gnome-pilot/ with the conduits configuration
integrated into the main capplet.  Unfortunately, I didn't remember to bring my
cradle in to work with me to test with, so I've only been able to do minimal
testing, but it should work.

Any information on whether it works for you or not is appreciated
Comment 6 berto 2002-10-07 15:51:06 EDT
It's looking good, just that the capplet doesn't save the setting once ok is
hit.  For example, if I open up the capplet disable the ECalendar sync action,
hit ok, and then open up the capplet again, the sync action will still be set to
Synchronize.

Seems like conduits dialog is not bound to the Ok button in the main capplet. 
Another clue that leads me to believe this is that when a sync action is
disabled, the Apply button doesn't enable itself.
Comment 7 Jeremy Katz 2002-10-07 18:13:07 EDT
Okay, I'll fix that up this evening when I get home and update to 0.1.66 while
I'm at it.  Thanks for the test.  I'll update here when I have a newer package
to try out.
Comment 8 Jeremy Katz 2002-10-08 01:33:41 EDT
Fixed up in -10 at the same place and also to be in rawhide soon.  Works for me
here with my USB Visor.  Reopen if it shows regressions for you.
Comment 9 berto 2002-10-08 10:10:58 EDT
The new capplet is looking awesome.  

I did find one more problem that should be fixed.  If a pilot is added or
removed, the Conduits tab will not reflect the changes until the capplet is
closed and reopened.  When a pilot is removed, it should be removed from the
conduits tab; same when one is added.

Say I didn't have a pilot setup.  After adding a pilot in the Pilots tab, I
should be able to go to the Conduits tab and setup the conduits for that pilot
without having to close and reopen the window.

Along the same lines, when there is no pilot setup, it may be beneficial to have
a note in the Conduits dialog that reads something like, "There are no pilots
setup on this machine; please click on the Pilots tab and add one first."

Lastly, what is the purpose of "Sync Type" in the Pilots dialog ( or "Sync
Action" in Pilot Settings, when a pilot is being added or edited )?  I have
tried to change that setting, but it remains at "Use conduit setting" no matter
what.  Is that a bug, or is there no point to that option anymore?  If it does
have a purpose and is going to stay in the dialog, the selection should have the
same name in both windows; either "Sync Type" or "Sync Action", but not both.

( I just had another idea to approach to the conduits dialog; I'll add another
comment for that.  you're gonna hate me : )
Comment 10 berto 2002-10-08 10:23:02 EDT
Since conduits are directly related to the pilot they are setup for, maybe the
conduits tab should be in the "Pilot Settings" window when a pilot is being
added/edited.

If this approach is taken, then there would be no need for the pulldown to
select the pilot in the Conduits dialog.

I don't know how much rework this approach would take.  Maybe in the next version?
Comment 11 Linus Walleij 2002-10-15 17:52:25 EDT
Excellent solution to the problem. Have you submitted changes to the GNOME CVS
too, cause I filed a bug there too... See:

http://bugzilla.gnome.org/show_bug.cgi?id=95597

Also I think this package is important enough to go into the "updates"
directory, as it is a definite showstopper for anyone using a pilot with their
RedHat 8.0
Comment 12 Richard Torkar 2002-10-18 04:55:37 EDT
This should be pushed out to red hat network asap. RH8 is useless when it comes
to handling Plam Pilots now..

Comment 13 diego.santacruz 2002-11-07 12:15:23 EST
Apparently this problem is fixed by the just released Gnome Pilot 0.1.69. From
the announcement:

Features
* Collapsed two capplets into one

It would be very desirable to upgrade the package to 0.1.69 then and pushing it
through up2date. Having no visible way in Red Hat 8.0 to configure conduits is
probably stopping many users from upgrading to 8.0.
Comment 14 diego.santacruz 2002-11-12 06:40:12 EST
I just saw that on RawHide there is a gnome-pilot 0.1.69 package (with the
required pilot-link 0.11.5-2). Upgraded and tested with the new integraded
control applet (pilots + counduits). Fixes the problem very nicely and is
working smoothly for me.

Is this going to be released as an official update for RedHat 8.0 ? That would
fix the issues that I suppose all pilot users have with RedHat 8.0.
Comment 15 Jeremy Katz 2003-09-24 16:08:51 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-220.html

Note You need to log in before you can comment on or make changes to this bug.