Bug 753967 - Brightness settings do not work
Brightness settings do not work
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-14 19:34 EST by Michael Knepher
Modified: 2012-11-13 10:39 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-13 10:39:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Knepher 2011-11-14 19:34:44 EST
Description of problem:
Did clean install of Fedora 16 on my Acer Aspire 5553G-5357. After first boot and login, I set brightness to full. I then did a software update and updated all packages. Rebooted, and brightness was back on lowest setting, but would not change, either using keyboard brightness controls or the Screen settings panel. Settings worked under Fedora 15 and Fedora 16 beta.

The brightness slider on the Screen settings panel can be adjusted, but has no effect. Using the brightness keyboard controls, the OSD shows the setting starting at lowest setting (no fill in the "progress" bar) and only moving one position, with no discernible effect. 

Version-Release number of selected component (if applicable):
kernel-3.1.0
kernel-3.1.1

How reproducible:
Always

Steps to Reproduce:
1. Login to GnomeShell
2. Try to adjust brightness
3.
  
Actual results:
Brightness remains at lowest setting

Expected results:
Display should get brighter or dimmer as adjusted

Additional info:
Comment 1 Pavel Ondračka 2011-11-20 13:31:43 EST
I have the same problem with Toshiba Satellite A100, the brightness cannot be changed using usual methods (function keys or screen settings). Changing brightness manually by modifying /sys/class/backlight/acpi_video0/brightness works.
Comment 2 collura 2011-11-24 02:37:23 EST
had an f15-gnome with functioning brightness slider control.

had an preupgraded f16-gnome with updates-testing enabled that brightness failed.

tried a fresh install of f16-gnome release and the brightness slider worked fine
  (kernel-3.1.0-7.fc16.x86_64 ) at firstreboot
but then after ran updates the brightness slider nolonger had any effect
  (kernel-3.1.1-2.fc16.x86_64 ).
Comment 3 Kim B. Heino 2011-11-25 07:13:45 EST
I have the same problem, except that my brightness is set to maximum.

HP EliteBook 8440p, 3.1.1-2.fc16.x86_64 kernel. 

/sys/class/backlight/acpi_video0/max_brightness is 24 and I can manually adjust it with /sys/class/backlight/acpi_video0/brightness.

/sys/class/backlight/intel_backlight/max_brightness is 648 and again /sys/class/backlight/intel_backlight/brightness works.
Comment 4 Michael Knepher 2011-11-28 15:43:02 EST
I just discovered that my laptop has switchable graphics, so I played around with the BIOS settings to see what happens. The original report was based on the BIOS default setting of "Switchable". lspci reports the following VGA devices: 

01:05.0 VGA compatible controller: ATI Technologies Inc M880G [Mobility Radeon HD 4200]
02:00.0 VGA compatible controller: ATI Technologies Inc Manhattan [Mobility Radeon HD 5400 Series]

And gnome-shell's system info reports "Gallium 0.4 on AMD RS880"

After changing the BIOS setting to "Discrete", lspci only reports the Mobility Radeon HD 5400 VGA device, and System Info reports "Gallium 0.4 on AMD CEDAR"

With this setting, the brightness can be adjusted using the keyboard controls, but not via the gnome settings. The brightness slider has no effect, and does not move to reflect the hardware settings. The OSD popup also continues to only go from lowest setting to one step brighter when adjusting using the keyboard, regardless of how high I set the brightness.
Comment 5 collura 2011-12-03 03:27:06 EST
hmm the update to xorg-x11-drv-ati-6.14.3-3.20111125git534fb6e41.fc16.x86_64
seemed to help.  no function keys but slider adjusts brightness now though forgets at reboot:

  https://bugzilla.redhat.com/show_bug.cgi?id=695087#c5
   f16-gnome-updates_testing_repo: brightness works again (yay) 
                                  but still forgetful
     kernel-3.1.2-1.fc16.x86_64
     xorg-x11-drv-ati-6.14.3-3.20111125git534fb6e41.fc16.x86_64
     control-center-3.2.2-1.fc16.x86_64
     gnome-settings-daemon-3.2.2-1.fc16.x86_64
     dconf-0.10.0-1.fc16.x86_64
     gconf2-3.2.3-1.fc16.x86_64
Comment 6 Dave Jones 2012-03-22 13:01:33 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 7 Dave Jones 2012-03-22 13:05:08 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 8 Dave Jones 2012-03-22 13:16:05 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 9 collura 2012-03-22 15:21:19 EDT
kernel 3.3.0-4.fc16.x86_64 gives similar effect as in comment#5 above except now the slider just disappears instead of adjusting brightness and function keys still have no effect :')

  https://bugzilla.redhat.com/show_bug.cgi?id=784532
Comment 10 Michael Knepher 2012-07-11 17:27:48 EDT
I'm now running Fedora 17 with kernel 3.4.4-5, and the system settings brightness slider and hardware keys work as expected, though the brightness seems to always revert to the lowest setting after a reboot.
Comment 11 collura 2012-08-22 19:59:07 EDT
0) still forgetful across reboot :'(

1) keys still dont work for me 

2) slider works  :')

so at least no longer need to 

   # echo 3 > /sys/class/backlight/acpi_video0/brightness 

to avoid snowblindness. :')



3) currently have:

     kernel-3.5.0-2.x86_64
     xorg-x11-drv-ati-6.14.4-6.20120602git93076094.fc17.x86_64
     control-center-1:3.4.2-1.fc17.x86_64
     gnome-settings-daemon-3.4.2-3.fc17.x86_64
     dconf-0.12.1-1.fc17.x86_64
     gconf2-3.2.5-1.fc17.x86_64

     http://www.smolts.org/client/show/pub_d71dc9ab-d675-4ee2-a9a9-303efc25df83
Comment 12 collura 2012-09-30 15:53:30 EDT
almost there:

0) still forgetfull across reboot :'(

1) keys work now, ya

2) slider still works, ya

3) currently have:

     kernel-3.5.4-2.fc17.x86_64
     xorg-x11-drv-ati-6.14.4-6.20120602git930760942.fc17.x86_64
     control-center-1:3.4.2-1.fc17.x86_64
     gnome-settings-daemon-3.4.2-3.fc17.x86_64
     dconf-0.12.1-1.fc17.x86_64
     gconf2-3.2.5-2.fc17.x86_64
Comment 13 Dave Jones 2012-10-23 11:28:29 EDT
# Mass update to all open bugs.

Kernel 3.6.2-1.fc16 has just been pushed to updates.
This update is a significant rebase from the previous version.

Please retest with this kernel, and let us know if your problem has been fixed.

In the event that you have upgraded to a newer release and the bug you reported
is still present, please change the version field to the newest release you have
encountered the issue with.  Before doing so, please ensure you are testing the
latest kernel update in that release and attach any new and relevant information
you may have gathered.

If you are not the original bug reporter and you still experience this bug,
please file a new report, as it is possible that you may be seeing a
different problem. 
(Please don't clone this bug, a fresh bug referencing this bug in the comment is sufficient).
Comment 14 Justin M. Forbes 2012-11-13 10:39:45 EST
With no response, we are closing this bug under the assumption that it is no longer an issue. If you still experience this bug, please feel free to reopen the bug report.

Note You need to log in before you can comment on or make changes to this bug.