Bug 75404 - mysqld (compiled from source) experiences intermittent crashes.
mysqld (compiled from source) experiences intermittent crashes.
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: mysql (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Patrick Macdonald
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-07 23:42 EDT by Dan Goodes
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-10 11:56:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dan Goodes 2002-10-07 23:42:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
The MySQL server 'mysqld' experiences intermittent crashes and hangups. 
Following much difficulty (see below) getting the server running in the first 
place, now whenever I try to connect and/or execute a query (from the command 
line or manually within the mysql client), I lose the connection and 
mysqld "restarts". The server remains 'active' for a maximum of about 15-20 
seconds (barely time to type a query), before restarting again. This problem is 
present using mysql versions 3.23.51 and 3.23.52 compiled from source, as well 
as using the 3.23.52-3 SRPM.

This generally happens only when trying to perform a "write" query (e.g. 
update, insert, create, etc) - however there is nothing wrong with the 
permissions - they've been checked. It also happens, on occasion, with select 
or connect queries as well.

Additionally, when compiling MySQL from the source distribution, 
using ./configure with "--localstatedir=/server/local/mysql/", mysqld compiles 
with the value "/ser/" (as can be seen using the "mysqld --help" command and 
looking for the "datadir" variable).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Compile and install mysql (on RedHat8.0) using the standard source 
instructions that come with the mysql distribution.
2. Verify that the "datadir" value is correct, as set using the --localstatedir 
option at configure time.
3. Start the mysql daemon (using safe_mysqld).
4. Start the mysql client, and execute a number of queries.
	

Actual Results:  Intermittently, the mysql client will display an error "Lost 
connection to MySQL server during query". Additionally, the following is 
printed on STDERR and in the log file:

Number of processes running now: 0
021008 13:17:22  mysqld restarted


Expected Results:  At this point, mysqld should have performed the query.

Additional info:

I'm almost sure this is not a bug with mysql, as I've had this version of mysql 
working on RedHat 7.2, using exactly these steps. My initial guess is that it's 
something to do with one of the components that mysql uses, that's changed in 
RH8 (such as, e.g. glibc or something).
Comment 1 Joe Orton 2002-12-12 07:39:14 EST
Are you testing the server from a different machine? Probably a duplicate of bug
77467 if so.
Comment 2 Patrick Macdonald 2003-03-25 14:23:53 EST
I've tried this using the latest glibc/kernel and can not reproduce.  Can
you please upgrade and see if it still fails.  

Using the 3.23.54a-11 version of MySQL with the latest glibc and kernel
errata.

Also, Joe asks an important question:  Are you attempting remote connections?
If so, there was a problem with MySQL + glibc.

Moving this to NEEDINFO.

Note You need to log in before you can comment on or make changes to this bug.