Bug 77467 - upgrade to RH 8.0 glibc breaks mysql remote connections
upgrade to RH 8.0 glibc breaks mysql remote connections
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 74943 75290 76229 77039 78769 78990 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-07 10:41 EST by Don Himelrick
Modified: 2016-11-24 10:09 EST (History)
37 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-10 19:08:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Himelrick 2002-11-07 10:41:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:

Remot connections to mysql fail.  This is exactly the same as the folowing bug
and errata for pre 8.0.   Why no fix for 8.0?

http://rhn.redhat.com/errata/RHSA-2002-197.html

Bug #   75128


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Try a remote connection to an 8.0 box running mysql.
2.
3.
	

Actual Results:  Connection fails, just like in the bug for other versions of
RedHat.

Expected Results:  Remote connections should work.   

Additional info:

I've been watching this bug for some time waiting for a solution, and when the
solution finaly came, it was for all of the older versions of redhat.   I guess
I missed the fine print (version numbers) in the other bug reports.  Probably
others did as well.  Any chance this can get fixed soon as well?
Comment 1 Leonid Mamtchenkov 2002-11-07 10:45:58 EST
You might want to upgrade to MySQL-3.23.53a-1. :)
Comment 2 Jakub Jelinek 2002-11-09 07:17:34 EST
For 8.0, you can use rpms from rawhide for the time being.
It will eventually become errata when one further regex bugs gets fixed.
Comment 3 Jakub Jelinek 2002-12-04 11:51:02 EST
*** Bug 77039 has been marked as a duplicate of this bug. ***
Comment 4 Joe Orton 2002-12-12 07:15:50 EST
*** Bug 78990 has been marked as a duplicate of this bug. ***
Comment 5 Joe Orton 2002-12-12 07:27:18 EST
*** Bug 74943 has been marked as a duplicate of this bug. ***
Comment 6 Joe Orton 2002-12-12 07:29:16 EST
*** Bug 75290 has been marked as a duplicate of this bug. ***
Comment 7 Joe Orton 2002-12-12 07:30:02 EST
*** Bug 78769 has been marked as a duplicate of this bug. ***
Comment 8 Joe Orton 2002-12-12 07:34:15 EST
*** Bug 76229 has been marked as a duplicate of this bug. ***
Comment 9 James 'Showkilr' Peterson 2002-12-22 22:42:03 EST
creating symlinks from /usr/lib/mysql/libmysqlclient.so so.10 so.10.0.0 to
/usr/lib and recompiling the RPM with the release 18 kernel and latest glibc
updates. seams to have resolved the issue with connecting to the mysql port from
remote without having entrys in /etc/hosts   this also resolved the annoyance
with compiling 3rd party apps that were looking for the shared lib in /usr/lib
even though /usr/lib/mysql is in /etc/ld.so.conf and ldconfig being exicuted.
Comment 10 David Yip 2003-01-16 04:16:49 EST
Although new rpm for RH 8.0 is just released, it still doesn't address the
remote connect problem!?
Comment 11 Richard Brown 2003-01-26 04:42:22 EST
I'm hoping I'm not spamming a list or posting in an inappropriate spot but:

On RH8.0, MySQL 3.23.49, glib-1.2.10-5 I was able to fix the remote connection 
problem by adding this line to /etc/my.cnf in the [mysqld] section:

set-variable	= thread_stack=256k

this suggestion was placed elsewhere in the string of bug reports related to 
the probem but in relation to previous versions of RH.

Hope this helps.
Comment 12 Russell Odom 2003-01-26 07:00:44 EST
The above didn't work for me, but adding
skip-name-resolve
to the [mysqld] section in /etc/my.cnf did (as mentioned in bug 75128 comment 40
relating to earlier RH versions). Unfortunately, it means changing the hosts in
the user table, but at least it now works.
Comment 13 Caleb Groom 2003-02-02 19:15:11 EST
Can duplicate as well.  

Server: RH8, MySQL compiled from source (source from mysql.com not SRPM)
Client: RH8, MySQL RPMS for client

DNS running on server.mydomain.org.  I can do forward and reverse lookups on
client.mydomain.org.  MySQL table permissions should allow for connections from
client.mydomain.org (host specified, not IP).
Comment 14 Ken Liccardo 2003-02-18 16:44:41 EST
I just installed RH 8.0 and MySql which comes with it (3.23.52).  I used the 
MySqlCC GUI (downloaded from mysql.com) to connect to MySql on the local host, 
no problem.  I tried to connect from another machine (Windows), with the error 
2013 Lost Connection...

I first confirmed security settings, which were OK (no firewall).

For some reason, the only way the remote connection would work was if I entered 
the client workstation's info in the HOSTS section (System Settings > Network > 
Hosts)of the RH8/MySQL server.  The DNS which the server uses is fine (all 
other apps requiring DNS lookup work fine; forward and reverse tables all OK), 
but for some reason MySql does not like it. Unfortunately, you would have to 
make HOSTS entries for all the workstations from which you want to connect to 
the MySql server.  Actually, I only have a couple workstations anyway.

Being new (~ couple days) to Linux/MySQL, I also did not realize that the user 
account HOST field was for the CLIENT host name, not the server host name.  I 
thought there was a correlation between the user account HOST field and the 
HOST field in the MySqlCC connection registration (in the MySqlCC connection 
registration, HOST is the host name of the MySQL server to which you want to 
connect).  Oh well, live and learn.  The user account HOST name can be a 
wildcard so you can connect from any workstation, but I kept unknowingly using 
the server host name for HOST when I created the user accounts.  This gave me a 
1130 error until I figured it all out.

I hope this helps someone.
Comment 15 David Yip 2003-03-01 12:34:04 EST
Anyone from redhat is going to provide a fix or suggestion or say something? I
think the situation is quite series. Suggest to adjust the priority and have it
fixed quick. Thanks.
Comment 16 Jakub Jelinek 2003-03-02 14:15:27 EST
I've built current rawhide glibc for 8.0, in:
ftp://people.redhat.com/jakub/glibc/errata/8.0/
(particular changes are linuxthreads only (no NPTL), no INIT/FINI_ARRAY support,
no warnings about borken programs using errno, h_errno or _res symbols directly).
Comment 17 neil davis 2003-03-06 11:35:00 EST
This fix:
------- Additional Comment #11 From Richard Brown on 2003-01-26 04:42 -------

Also works on Redhat 7.0 running MySQL 3.23.54(rpm mysql-3.23.54a-3.70) using
glibc rpm version glibc-2.2.4-18.7.0.7

For the lazy you set a variable in my.cnf under [mysqld] section of file:
[mysqld]
set-variable=thread_stack=256k

... and you don't even need to restart mysqld: ) Query once, then query again
and it takes effect.

Thank you Richard!!!! I would have to assume that the notes about mysql using
too large of a default thread stack for the latest glibc stack restrictions are
accurate.

Probably not a redhat bug, more like a mysql/glibc configuration snafu. I would
like to add that recompiling mysql and/or glibc from source, alone, using
defaults, does not help one bit. I tried it on another box in my cube. This is
why I feel that it is not a redhat problem. However, redhat could help by
re-releasing the mysql rpm and adding this configuration parameter, provided
this fixes the issue on enough platforms/versions.

This certainly beats re-installing or upgrading the OS (unless your patches are
hopelessly out of date) which is how I fixed it last time this happened (after
an xinetd update on another RH7.1 box).

thx,
Neil Davis
davisneilp@mindspring.com
large bank (not allowed to say: )
Comment 18 Jakub Jelinek 2003-04-10 19:08:58 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2003-089.html

Note You need to log in before you can comment on or make changes to this bug.