Bug 754484 - virt-manager: offer to install openssh-askpass if catch an error about it
virt-manager: offer to install openssh-askpass if catch an error about it
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
: 784710 786660 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-16 11:27 EST by David Jaša
Modified: 2012-08-09 19:23 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 19:02:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2011-11-16 11:27:09 EST
Description of problem:
SSIA

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-8.fc16.noarch (f16 virt-preview repo)

How reproducible:
always

Steps to Reproduce:
1. run virt-manager on computer where ssh-askpass is *not* installed
2. add a remote ssh connection, try to connect to it
3.
  
Actual results:
cryptic error message is thrown (full output in additional info)

Expected results:
first virt-manager says that it needs ssh-askpass,
second virt-manager asks PackageKit to install it

Additional info: Error message:
===========================
Unable to open a connection to the libvirt management daemon.

Libvirt URI is: qemu+ssh://root@10.34.29.7/system

Verify that:
 - The 'libvirtd' daemon has been started
----------------------------
Details:

Unable to open a connection to the libvirt management daemon.

Libvirt URI is: qemu+ssh://root@10.34.29.7/system

Verify that:
 - The 'libvirtd' daemon has been started


Cannot recv data: ssh_askpass: exec(/usr/libexec/openssh/ssh-askpass): No such file or directory

Permission denied, please try again.

ssh_askpass: exec(/usr/libexec/openssh/ssh-askpass): No such file or directory

Permission denied, please try again.

ssh_askpass: exec(/usr/libexec/openssh/ssh-askpass): No such file or directory

Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password).
: Connection reset by peer

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 1146, in _open_thread
    self.vmm = self._try_open()
  File "/usr/share/virt-manager/virtManager/connection.py", line 1130, in _try_open
    flags)
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 102, in openAuth
    if ret is None:raise libvirtError('virConnectOpenAuth() failed')
libvirtError: Cannot recv data: ssh_askpass: exec(/usr/libexec/openssh/ssh-askpass): No such file or directory

Permission denied, please try again.

ssh_askpass: exec(/usr/libexec/openssh/ssh-askpass): No such file or directory

Permission denied, please try again.

ssh_askpass: exec(/usr/libexec/openssh/ssh-askpass): No such file or directory

Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password).
: Connection reset by peer
Comment 1 David Jaša 2011-11-16 11:29:57 EST
minor correction:

(In reply to comment #0)
> 1. run virt-manager on computer where ssh-askpass is *not* installed
openssh-askpass

> Expected results:
> first virt-manager says that it needs ssh-askpass,
openssh-askpass again
Comment 2 Cole Robinson 2012-01-25 18:28:42 EST
*** Bug 784710 has been marked as a duplicate of this bug. ***
Comment 3 Cole Robinson 2012-02-02 17:47:25 EST
*** Bug 786660 has been marked as a duplicate of this bug. ***
Comment 4 Sergio Pascual 2012-02-16 06:40:45 EST
Without openssh-askpass, virt-manager doesn't ask you the connection password. ssh conections are unusable unless you start virt-manager in a terminal and type the password there
Comment 6 Fedora Update System 2012-07-09 18:02:39 EDT
virt-manager-0.9.3-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/virt-manager-0.9.3-1.fc17
Comment 7 Fedora Update System 2012-07-09 18:02:40 EDT
virt-manager-0.9.3-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/virt-manager-0.9.3-1.fc16
Comment 8 Fedora Update System 2012-07-10 16:50:58 EDT
Package virt-manager-0.9.3-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing virt-manager-0.9.3-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10462/virt-manager-0.9.3-1.fc17
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-07-29 17:22:40 EDT
virt-manager-0.9.4-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/virt-manager-0.9.4-1.fc17
Comment 10 Fedora Update System 2012-07-29 17:23:41 EDT
virt-manager-0.9.4-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/virt-manager-0.9.4-1.fc16
Comment 11 Fedora Update System 2012-08-09 19:02:22 EDT
virt-manager-0.9.4-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-08-09 19:23:32 EDT
virt-manager-0.9.4-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.