Bug 786660 - libvirt or libvirt-python (or vlirt-manager) lacks dependency to openssh-askpass (/usr/libexec/openssh/ssh-askpass)
libvirt or libvirt-python (or vlirt-manager) lacks dependency to openssh-askp...
Status: CLOSED DUPLICATE of bug 754484
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-01 23:23 EST by Satoru SATOH
Modified: 2012-02-02 17:47 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-02 17:47:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Satoru SATOH 2012-02-01 23:23:18 EST
Description of problem:
If openssh-askpass which provides /usr/libexec/openssh/ssh-askpass not installed on the system and remote ssh connection needs password input, 
users cannot connect to the remote livritd w/ virt-manager.

To fix this, how about making libvirt or libvirt-python or virt-manager
depends on openssh-askpass (Requires: openss-askpass) ?


Version-Release number of selected component (if applicable):
Confirmed w/ libvirt*-0.9.6-4.fc16 and virt-manager-0.9.0-7.fc16,
libvirt-0.9.9-2 and virt-manager-0.9.0-8? (koji HEAD)

 
How reproducible: always under certain specified conditions (ssh 
connection needs password input and /usr/libexec/openssh/ssh-askpass
is not available)


Steps to Reproduce:
1. Start virt-manager
2. Create remote connection (ssh; the remote host needs password input)
3. Connect that remote host
  

Actual results: Could not connect remote host via ssh as ssh-askpass is missing


Additional info:

It seems that no packages require openssh-askpass.

ssato@localhost% LANG=C yum provides /usr/libexec/openssh/ssh-askpass
Loaded plugins: auto-update-debuginfo, presto, priorities, refresh-packagekit
31329 packages excluded due to repository priority protections
openssh-askpass-5.8p2-16.fc16.1.x86_64 : A passphrase dialog for OpenSSH and X
Repo        : fedora
Matched from:
Filename    : /usr/libexec/openssh/ssh-askpass
...
ssato@localhost% LANG=C rpm -q --whatrequires openssh-askpass
no package requires openssh-askpass
ssato@localhost%
Comment 1 Cole Robinson 2012-02-02 17:47:25 EST

*** This bug has been marked as a duplicate of bug 754484 ***

Note You need to log in before you can comment on or make changes to this bug.