Bug 75469 - running gnome mixer breaks xawtv sound
running gnome mixer breaks xawtv sound
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gnome-media (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
Jay Turner
: Triaged
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2002-10-08 17:16 EDT by Need Real Name
Modified: 2015-01-07 19:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-27 15:04:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-08 17:16:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When I run xawtv under gnome in RH8.0, I get the TV but no sound. I have a 
Fly '98 TV card and I have installed it manually in /etc/modules.conf,
under previous versions of RH I didn't get this problem.
Under another apps, for example xmms, I don't have any problem with sound.
My sound card is SB PCI64 with ess1370 (I guess) chipset.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RH 8.0 with gnome
2.Install a bt878 Fly '98 TV card in /etc/modules.conf
3.run 'xawtv'
	

Actual Results:  I don't get the sound of the TV.

Expected Results:  This was not the case under RH 7.1-7.3

Additional info:

I don't get any error messages or nothing seems to be wrong.
Comment 1 Need Real Name 2002-10-08 17:29:10 EDT
These are the lines I have added to /etc/modules.conf : 

options bttv pll=1 radio=1 card=56
options tuner type=5
post-install bttv /sbin/modprobe "-k" tuner; \
 /sbin/modprobe "-k" msp3400
Comment 2 Alessandro Tommasi 2002-11-15 06:46:08 EST
Same here. I also have a bt878 card, and my modules.conf (the relevant part)
looks like:

alias char-major-81-1 bttv
options bttv card=41 radio=1

(I also have a webcam, hence the 81-1).

I had no problem whatsoever under 7.1, 2 or 3.
Comment 3 Ngo Than 2003-03-06 15:14:59 EST
Bill, i think it's something wrong in modules.conf, but i cannot fix it because
i don't have this hardware for testing. 

It works for me with Hauppauge (bt848).
Comment 4 Bill Nottingham 2003-03-06 15:23:24 EST
Hm, in 7.x, did it automatically load btaudio for you?
Comment 5 Need Real Name 2003-03-07 08:12:26 EST
I discovered that the (my) problem is with gnome sound mixer. When I do a fresh 
install and don't ever run mixer, everything runs fine. I can adjust the sound 
with the sound applet on gnome panel. But when i run the mixer, just one time, 
i can never get the sound with xawtv back.
So this is a workaround and my system runs now fine.
Comment 6 Need Real Name 2003-08-06 17:42:51 EDT
This bug doesn't seem to be exist on RH 9.
Mixer and xawtv run both properly, at least on my configuration, which i have
described above.
Comment 7 Colin Walters 2004-09-27 15:04:39 EDT
If this is fixed in RH9, I'm going to close.  Please reopen if you can
reproduce in FC2.

Note You need to log in before you can comment on or make changes to this bug.