Bug 75469 - running gnome mixer breaks xawtv sound
Summary: running gnome mixer breaks xawtv sound
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-media
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Colin Walters
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2002-10-08 21:16 UTC by Need Real Name
Modified: 2015-01-08 00:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-27 19:04:39 UTC


Attachments (Terms of Use)

Description Need Real Name 2002-10-08 21:16:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When I run xawtv under gnome in RH8.0, I get the TV but no sound. I have a 
Fly '98 TV card and I have installed it manually in /etc/modules.conf,
under previous versions of RH I didn't get this problem.
Under another apps, for example xmms, I don't have any problem with sound.
My sound card is SB PCI64 with ess1370 (I guess) chipset.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RH 8.0 with gnome
2.Install a bt878 Fly '98 TV card in /etc/modules.conf
3.run 'xawtv'
	

Actual Results:  I don't get the sound of the TV.

Expected Results:  This was not the case under RH 7.1-7.3

Additional info:

I don't get any error messages or nothing seems to be wrong.

Comment 1 Need Real Name 2002-10-08 21:29:10 UTC
These are the lines I have added to /etc/modules.conf : 

options bttv pll=1 radio=1 card=56
options tuner type=5
post-install bttv /sbin/modprobe "-k" tuner; \
 /sbin/modprobe "-k" msp3400

Comment 2 Alessandro Tommasi 2002-11-15 11:46:08 UTC
Same here. I also have a bt878 card, and my modules.conf (the relevant part)
looks like:

alias char-major-81-1 bttv
options bttv card=41 radio=1

(I also have a webcam, hence the 81-1).

I had no problem whatsoever under 7.1, 2 or 3.

Comment 3 Than Ngo 2003-03-06 20:14:59 UTC
Bill, i think it's something wrong in modules.conf, but i cannot fix it because
i don't have this hardware for testing. 

It works for me with Hauppauge (bt848).

Comment 4 Bill Nottingham 2003-03-06 20:23:24 UTC
Hm, in 7.x, did it automatically load btaudio for you?

Comment 5 Need Real Name 2003-03-07 13:12:26 UTC
I discovered that the (my) problem is with gnome sound mixer. When I do a fresh 
install and don't ever run mixer, everything runs fine. I can adjust the sound 
with the sound applet on gnome panel. But when i run the mixer, just one time, 
i can never get the sound with xawtv back.
So this is a workaround and my system runs now fine.

Comment 6 Need Real Name 2003-08-06 21:42:51 UTC
This bug doesn't seem to be exist on RH 9.
Mixer and xawtv run both properly, at least on my configuration, which i have
described above.

Comment 7 Colin Walters 2004-09-27 19:04:39 UTC
If this is fixed in RH9, I'm going to close.  Please reopen if you can
reproduce in FC2.


Note You need to log in before you can comment on or make changes to this bug.