Bug 75475 - Installer for RH8.0 crashed with unhandled exception during upgrade.
Installer for RH8.0 crashed with unhandled exception during upgrade.
Status: CLOSED DUPLICATE of bug 75377
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
8.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-08 18:09 EDT by kevin
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-08 18:10:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full output from crash saved to floppy during installation (69.67 KB, text/plain)
2002-10-08 18:10 EDT, kevin
no flags Details

  None (edit)
Description kevin 2002-10-08 18:09:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (Windows NT 5.0; U)

Description of problem:
Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 786, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 149, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 632, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 719, in doInstall
    problems = ts.run(0, ~rpm.RPMPROB_FILTER_DISKSPACE, cb.cb, 0)
  File "/usr/lib/anaconda/packages.py", line 283, in cb
    fn = self.method.getFilename(h, self.pkgTimer)
  File "/usr/lib/anaconda/image.py", line 119, in getFilename
    f = open("/mnt/source/.discinfo")
IOError: [Errno 2] No such file or directory: '/mnt/source/.discinfo'

Local variables in innermost frame:
h: <header object at 0x8869e10>
self: <image.CdromInstallMethod instance at 0x868efc4>
timer: <timer.Timer instance at 0xa80e024>


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Existing RH 7.3 System working
2. Upgrade with personal RH 8.0 disks purchased from retail outlet.
3. Select components (detailed in attachment), and begin install; installer crashes in less than a minute.
	

Actual Results:  Installer crashed with unhandled exception (details in attachment) and could not continue.
System left in uncertain state, since some upgrading did take place.

Expected Results:  It should upgrade normally.

Additional info:
Comment 1 kevin 2002-10-08 18:10:25 EDT
Created attachment 79524 [details]
Full output from crash saved to floppy during installation
Comment 2 Jeremy Katz 2002-10-09 11:37:35 EDT
An update disk for Red Hat Linux 8.0 is available at
http://people.redhat.com/~katzj/8.0-cdread.img that should correct this problem.
 If you download this image and place it on a floppy disk (using dd or rawrite
as with a boot disk), and then boot with 'linux updates' from the syslinux
prompt, you will be prompted to provide this disk.

*** This bug has been marked as a duplicate of 75377 ***

Note You need to log in before you can comment on or make changes to this bug.