Bug 75481 - (NET TULIP) Lite on network driver is unreliable
(NET TULIP) Lite on network driver is unreliable
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
: 75480 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-08 19:01 EDT by Alan Cox
Modified: 2013-07-02 22:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-14 05:42:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[PATCH] this is potentially a fix for this problem... need to review more and verify (28.49 KB, patch)
2002-10-09 11:12 EDT, Jeff Garzik
no flags Details | Diff

  None (edit)
Description Alan Cox 2002-10-08 19:01:20 EDT
With the 8.0 kernel I am getting failures with lite-on ethernet cards. It seems 
I can trigger it reliably in an environment where the card transmits and is hit
almost instantly by a series of frames back to back, and probably close to back
to back after the transmit
Comment 1 Jeff Garzik 2002-10-09 10:44:10 EDT
*** Bug 75480 has been marked as a duplicate of this bug. ***
Comment 2 Jeff Garzik 2002-10-09 11:12:31 EDT
Created attachment 79645 [details]
[PATCH] this is potentially a fix for this problem... need to review more and verify
Comment 3 Andrew Gilmore 2002-12-04 11:27:07 EST
Have also seen this bug.

Symptom:
text console reports:
Spurious 8259A interrupt: IRQ7   then ide system hangs with hda: lost interrupt
reported every second or two. console is still responsive until disk access from 
the console occurs.

has twice just reported "Unknown interrupt" and hung.

how I repeat it:
ssh to the box, login usually works, then hold down Enter, usually takes from 3
to 10 or so.

occurs over 10mbit hub, crossover cable, and 100mb switch. 

Box is stock 8.0, no updates (yet).

Card is labeled FA-310, with a NetGear on the back, but reports as Lite-on?
Is definitely a tulip card.
Comment 4 Alan Cox 2002-12-04 11:57:13 EST
That looks unrelated actually

Can you file a seperate bug about this and include info on your hardware then
let me know and I'll take  a look
Comment 5 Alan Cox 2003-08-14 05:42:59 EDT
Seems happy now

Note You need to log in before you can comment on or make changes to this bug.