Bug 754961 - [abrt] tumbler-0.1.22-4.fc16: g_type_check_instance_is_a: Process /usr/lib64/tumbler-1/tumblerd was killed by signal 11 (SIGSEGV)
[abrt] tumbler-0.1.22-4.fc16: g_type_check_instance_is_a: Process /usr/lib64/...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: tumbler (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
abrt_hash:3691491a5f81e79d83546c1f90e...
:
: 757641 759846 759935 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-18 06:52 EST by Ralf Corsepius
Modified: 2012-01-07 05:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-04 05:10:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (47.31 KB, text/plain)
2011-11-18 06:52 EST, Ralf Corsepius
no flags Details
File: maps (36.16 KB, text/plain)
2011-11-18 06:52 EST, Ralf Corsepius
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 8219 None None None Never

  None (edit)
Description Ralf Corsepius 2011-11-18 06:52:32 EST
libreport version: 2.0.6
abrt_version:   2.0.4.981
backtrace_rating: 4
cmdline:        /usr/lib64/tumbler-1/tumblerd
comment:        No idea how to reproduce it. Machine was unattended when this segfault occurred.
crash_function: g_type_check_instance_is_a
executable:     /usr/lib64/tumbler-1/tumblerd
kernel:         3.1.1-1.fc16.x86_64
reason:         Process /usr/lib64/tumbler-1/tumblerd was killed by signal 11 (SIGSEGV)
time:           Fri Nov 18 12:46:05 2011
uid:            8690
username:       corsepiu

backtrace:      Text file, 48448 bytes
maps:           Text file, 37025 bytes

build_ids:
:1ddf6e597ba6f382f8490a52401f6905b9715abb
:80d1527bdbaa66a7f4467a3432a25332fb76758a
:5ffc709ae37f52d7d0743329a39f1b83e5493827
:1c6a95451ee19617be5abea3d121f0226d21ddda
:08325b64e0774167b3ade9126c3971ae6de9a4a6
:44ece411beb2ef1acdb5eb2161666de41cc2f31d
:98fa95d21e16075ada6df19748c6c133ee9165d0
:b5a67213cba87f4e37046b7b7728a1eb4e7aff07
:e3c88cb9ea428bd61f4064dbd53acae2d396a1ec
:dd09997b3723567329e48ecd0d4bac542c0a903c
:87461d97d0ba0bd94e4d74ff0879190b67b326c5
:72ea6ca9c81b71bba99cb18620abb9029a87927c
:5e8c36ca13a4af14fa6b1b45a0dbfb43ed6aed6e
:722092ce63f29994224c42970e34d60a30a80e46
:a70947162966aa69c7ac92b53dcd9e6748cffe35
:9e3a33f915a032d57db9e51c90f1b295fc9e425c
:a47e3764e7de48ace1ecfcfd8c2e0c49bd8cf1a3
:30af62b93e2ab7dbaf39c52e346cd52101b4b590
:9d1209fc79304f03cc839de1c0036c61b48dfff8
:3e08f14ed2767ff642c7477a25b63214050e42cb
:9af722e8d4717709aa49739efc0ed10d0f952e3e
:fa1cfd183d984f9b0a77a35f5da619fe71da5fe2
:48d3cff26c916dff6cbcb5e67d5cf6d391f6ccca
:8264e35452b2a930c1b9b092b87f32d42d69d8c5
:e7d37d7c1c48886f369bf4cc2eb07134faf900e0
:09834b108bacbb167847d374f4cd9965ce8c78f0
:b502249bcf2a4f465feeb8b9578c80cda6f4103d
:c8a4e40c84c2f52e78c64d31efc0191c565a9049
:921b64859b34786348daf376801c05efbf9bac81
:8acc43df965b3c0a70dcfad11c0ade056bdb055b
:106981fc8c382f3593c7326d039e026b11dd9ba5
:4953d1f613914126bccceb3cb96386647ffba9df
:db0921d37dbfcfc6115a7a4aeb0c6928c08abd1c
:0911ea7c180d733724f89037b8e8a34e64024aec
:6e7d3edc38bf427fb8cb8dd115b5e23b5b1b1854
:48aea888319e1848137073c9cbde54a4c2a731c9
:400aa053edc0e34645dd535201f1a1395573a681
:7055a3f0dc1ecedda325c75912ccb1fbe361013c
:bed3a3de569d0a8795d948f4630b7e6af3566d36
:a07d8451a42fb256942df953f790ded8f6b5b372
:2636afe466ed20d65ac6d8fc08f1b120974f9ceb
:b0eabf9093defbfdd0857ea3ed1a4563b743434e
:fe59af234d3adcdbdfc45a81c2099c3529d5b37d
:4c842320387ff7f6f91b7842b223c16518be909f
:c3df263f0b70a9fff51c727bd49c52f0794b9f9e
:68d260a8e19b5758a2ca3a8bf6a9e3a49a6d6bfd
:ec16722d991717e07e829bef2955435824df5083
:ebb2f0a89bbd1ef97f373a99cb44d4c968d2579f
:017a0c9c46d30256c1d6af189b4809146ef312f6
:7994f114cf7189e482f2665fae8e351ed8bc05e3
:94e29139152ba767534403cf94a672fe6b3fe515
:ee03ac98c3ac61b47aa163886a17cc1e0c491906
:be507c791e34415e8f42f0e6030c889b2895cf9a
:33fcde0445e582dff00a8703873e1863ff1ca547
:3d22dd762f2430ac679e61c98e8d856e5f3423ed
:28f59ffca68245ca3e236e5a26db1e2a1d86e0d7
:437b7f944169cc3842441dd7b9be2973207ee72e
:632e2d2fe66298723101ff693447d3b3fc1af720
:b475123058f5a0538c0592eaf40ec27bac64a2d0
:ccadad4ec7dab3bb6abc23f9d4cdf53ff01cb235
:e5d7ac2dfe435e205e491f7ce827563859fca4f4
:b453c88fcaacf75c19ab1c941fc008d752bce86c
:3e2404bd469800afd61eda83d0292a2165ef0db0
:3b50812827b755646178db9447ced77425add5d8
:c5e42d196957e22b2106b6ed9144f0baff42a9c0
:2e979936a64ecafe4d85a5b4f07e594415691d38
:11307731c4aa95e08b6de3064d064a12d12dee8f
:ea561edd4a545276e281c0c1f3d51fb6d5f7dcb6
:56d0d755b880afdd9ebf2c8c707282384fed90fd
:c85b0533529a1a79855cc4e765885b9af1ef8b9e
:c3a3e49f393f383721c6485dab54a620d7b9da52
:3afcef19b83b4d703cf89db41982aabaa2d1618b
:650b733aecfb9c46bdfc023661f19244a278df04
:b0a2d0b4c09d819887ec7d711c8cf3977a074c4f
:a518a8b1b5c3e80dee813df05e951d205d6ac48c
:375ad839663dc5e07d4b27e624d49c8922895e08
:5f68fecc89bbb7cf2200b4caed6fb26006a189b7
:88d586ed67ebe5227b761b4ab2e02433f29c840f
:b67d01f9230119a215e7151dc3aa43428b886c8f

dso_list:
:/usr/lib64/gstreamer-0.10/libgsta52dec.so gstreamer-plugins-ugly-0.10.18-3.fc16.x86_64 (RPM Fusion) 1321275470
:/lib64/libm-2.14.90.so glibc-2.14.90-14.x86_64 (Fedora Project) 1321083865
:/usr/lib64/libxcb.so.1.1.0 libxcb-1.7-3.fc16.x86_64 (Fedora Project) 1321083877
:/usr/lib64/libpoppler.so.18.0.0 poppler-0.18.0-2.fc16.x86_64 (Fedora Project) 1321241319
:/usr/lib64/libgstaudio-0.10.so.0.24.0 gstreamer-plugins-base-0.10.35-3.fc16.x86_64 (Fedora Project) 1321086912
:/usr/lib64/libgvfscommon.so.0.0.0 gvfs-1.10.1-2.fc16.x86_64 (Fedora Project) 1321084238
:/usr/lib64/gstreamer-0.10/libgsttypefindfunctions.so gstreamer-plugins-base-0.10.35-3.fc16.x86_64 (Fedora Project) 1321086912
:/usr/lib64/gstreamer-0.10/libgstcoreelements.so gstreamer-0.10.35-1.fc16.x86_64 (Fedora Project) 1321083963
:/usr/lib64/gstreamer-0.10/libgstaudioresample.so gstreamer-plugins-base-0.10.35-3.fc16.x86_64 (Fedora Project) 1321086912
:/usr/lib64/libgdk_pixbuf-2.0.so.0.2400.0 gdk-pixbuf2-2.24.0-1.fc16.x86_64 (Fedora Project) 1321084246
:/usr/lib64/tumbler-1/plugins/tumbler-gst-thumbnailer.so tumbler-0.1.22-4.fc16.x86_64 (Fedora Project) 1321084614
:/lib64/libgmodule-2.0.so.0.3000.1 glib2-2.30.1-1.fc16.x86_64 (Fedora Project) 1321083874
:/usr/lib64/tumbler-1/plugins/tumbler-poppler-thumbnailer.so tumbler-0.1.22-4.fc16.x86_64 (Fedora Project) 1321084614
:/usr/lib64/libffi.so.5.0.10 libffi-3.0.10-1.fc16.x86_64 (Fedora Project) 1321083873
:/usr/lib64/gconv/ISO8859-1.so glibc-2.14.90-14.x86_64 (Fedora Project) 1321083865
:/usr/lib64/libdbus-glib-1.so.2.1.0 dbus-glib-0.92-2.fc15.x86_64 (Fedora Project) 1321083875
:/usr/lib64/gstreamer-0.10/libgstvolume.so gstreamer-plugins-base-0.10.35-3.fc16.x86_64 (Fedora Project) 1321086912
:/usr/lib64/libpng12.so.0.46.0 libpng-2:1.2.46-1.fc16.x86_64 (Fedora Project) 1321083869
:/lib64/libudev.so.0.12.0 libudev-173-3.fc16.x86_64 (Fedora Project) 1321083872
:/usr/lib64/gstreamer-0.10/libgstplaybin.so gstreamer-plugins-base-0.10.35-3.fc16.x86_64 (Fedora Project) 1321086912
:/usr/lib64/libfontconfig.so.1.4.4 fontconfig-2.8.0-4.fc16.x86_64 (Fedora Project) 1321084047
:/lib64/libpthread-2.14.90.so glibc-2.14.90-14.x86_64 (Fedora Project) 1321083865
:/lib64/libexpat.so.1.5.2 expat-2.0.1-11.fc15.x86_64 (Fedora Project) 1321083871
:/lib64/libnss_files-2.14.90.so glibc-2.14.90-14.x86_64 (Fedora Project) 1321083865
:/usr/lib64/tumbler-1/plugins/tumbler-pixbuf-thumbnailer.so tumbler-0.1.22-4.fc16.x86_64 (Fedora Project) 1321084614
:/usr/lib64/libbluray.so.0.0.0 libbluray-0.2-0.5.20110710git51d7d60a96d06.fc16.x86_64 (Fedora Project) 1321083883
:/lib64/libglib-2.0.so.0.3000.1 glib2-2.30.1-1.fc16.x86_64 (Fedora Project) 1321083874
:/usr/lib64/gio/modules/libgioremote-volume-monitor.so gvfs-1.10.1-2.fc16.x86_64 (Fedora Project) 1321084238
:/usr/lib64/libXrender.so.1.3.0 libXrender-0.9.6-2.fc15.x86_64 (Fedora Project) 1321084247
:/lib64/libgobject-2.0.so.0.3000.1 glib2-2.30.1-1.fc16.x86_64 (Fedora Project) 1321083874
:/usr/lib64/tumbler-1/plugins/tumbler-font-thumbnailer.so tumbler-0.1.22-4.fc16.x86_64 (Fedora Project) 1321084614
:/usr/lib64/libX11.so.6.3.0 libX11-1.4.3-1.fc16.x86_64 (Fedora Project) 1321084246
:/lib64/libgcc_s-4.6.2-20111027.so.1 libgcc-4.6.2-1.fc16.x86_64 (Fedora Project) 1321083847
:/usr/lib64/libgstreamer-0.10.so.0.29.0 gstreamer-0.10.35-1.fc16.x86_64 (Fedora Project) 1321083963
:/usr/lib64/gstreamer-0.10/libgstffmpegcolorspace.so gstreamer-plugins-base-0.10.35-3.fc16.x86_64 (Fedora Project) 1321086912
:/usr/lib64/gstreamer-0.10/libgstmpeg2dec.so gstreamer-plugins-ugly-0.10.18-3.fc16.x86_64 (RPM Fusion) 1321275470
:/usr/lib64/gstreamer-0.10/libgstaudioconvert.so gstreamer-plugins-base-0.10.35-3.fc16.x86_64 (Fedora Project) 1321086912
:/usr/lib64/libxml2.so.2.7.8 libxml2-2.7.8-6.fc16.x86_64 (Fedora Project) 1321083869
:/lib64/libdbus-1.so.3.5.6 dbus-libs-1:1.4.10-3.fc16.x86_64 (Fedora Project) 1321083869
:/usr/lib64/gio/modules/libgvfsdbus.so gvfs-1.10.1-2.fc16.x86_64 (Fedora Project) 1321084238
:/usr/lib64/libgstbase-0.10.so.0.29.0 gstreamer-0.10.35-1.fc16.x86_64 (Fedora Project) 1321083963
:/usr/lib64/liborc-0.4.so.0.16.0 orc-0.4.16-4.fc16.x86_64 (Fedora Project) 1321083903
:/usr/lib64/libgstinterfaces-0.10.so.0.24.0 gstreamer-plugins-base-0.10.35-3.fc16.x86_64 (Fedora Project) 1321086912
:/lib64/libdl-2.14.90.so glibc-2.14.90-14.x86_64 (Fedora Project) 1321083865
:/usr/lib64/tumbler-1/plugins/tumbler-jpeg-thumbnailer.so tumbler-0.1.22-4.fc16.x86_64 (Fedora Project) 1321084614
:/usr/lib64/gstreamer-0.10/libgstvideoscale.so gstreamer-plugins-base-0.10.35-3.fc16.x86_64 (Fedora Project) 1321086912
:/usr/lib/locale/locale-archive glibc-common-2.14.90-14.x86_64 (Fedora Project) 1321083864
:/usr/lib64/libgstpbutils-0.10.so.0.24.0 gstreamer-plugins-base-0.10.35-3.fc16.x86_64 (Fedora Project) 1321086912
:/lib64/libc-2.14.90.so glibc-2.14.90-14.x86_64 (Fedora Project) 1321083865
:/lib64/libnsl-2.14.90.so glibc-2.14.90-14.x86_64 (Fedora Project) 1321083865
:/usr/lib64/tumbler-1/tumblerd tumbler-0.1.22-4.fc16.x86_64 (Fedora Project) 1321084614
:/usr/lib64/libopenjpeg.so.3.1.4.0 openjpeg-libs-1.4-6.fc16.x86_64 (Fedora Project) 1321083909
:/lib64/librt-2.14.90.so glibc-2.14.90-14.x86_64 (Fedora Project) 1321083865
:/usr/lib64/libmpeg2.so.0.1.0 libmpeg2-0.5.1-8.fc12.x86_64 (RPM Fusion) 1321159987
:/usr/lib64/libXau.so.6.0.0 libXau-1.0.6-2.fc15.x86_64 (Fedora Project) 1321083877
:/usr/lib64/libpixman-1.so.0.22.2 pixman-0.22.2-1.fc16.x86_64 (Fedora Project) 1321083879
:/usr/lib64/libgstcontroller-0.10.so.0.29.0 gstreamer-0.10.35-1.fc16.x86_64 (Fedora Project) 1321083963
:/usr/lib64/liba52.so.0.0.0 a52dec-0.7.4-15.fc11.x86_64 (RPM Fusion) 1321159990
:/usr/lib64/gstreamer-0.10/libgstmpegvideoparse.so gstreamer-plugins-bad-free-0.10.22-2.fc16.1.x86_64 (Fedora Project) 1321084260
:/usr/lib64/libgstvideo-0.10.so.0.24.0 gstreamer-plugins-base-0.10.35-3.fc16.x86_64 (Fedora Project) 1321086912
:/lib64/libz.so.1.2.5 zlib-1.2.5-5.fc16.x86_64 (Fedora Project) 1321371791
:/lib64/ld-2.14.90.so glibc-2.14.90-14.x86_64 (Fedora Project) 1321083865
:/usr/lib64/liborc-test-0.4.so.0.16.0 orc-0.4.16-4.fc16.x86_64 (Fedora Project) 1321083903
:/usr/lib64/libjpeg.so.62.0.0 libjpeg-turbo-1.1.1-2.fc16.x86_64 (Fedora Project) 1321371793
:/usr/lib64/libstdc++.so.6.0.16 libstdc++-4.6.2-1.fc16.x86_64 (Fedora Project) 1321083869
:/usr/lib64/tumbler-1/plugins/cache/tumbler-xdg-cache.so tumbler-0.1.22-4.fc16.x86_64 (Fedora Project) 1321084614
:/usr/lib64/gstreamer-0.10/libgstmpegdemux.so gstreamer-plugins-bad-free-0.10.22-2.fc16.1.x86_64 (Fedora Project) 1321084260
:/lib64/libgthread-2.0.so.0.3000.1 glib2-2.30.1-1.fc16.x86_64 (Fedora Project) 1321083874
:/usr/lib64/gstreamer-0.10/libgstdecodebin2.so gstreamer-plugins-base-0.10.35-3.fc16.x86_64 (Fedora Project) 1321086912
:/lib64/libresolv-2.14.90.so glibc-2.14.90-14.x86_64 (Fedora Project) 1321083865
:/lib64/libutil-2.14.90.so glibc-2.14.90-14.x86_64 (Fedora Project) 1321083865
:/usr/lib64/libtumbler-1.so.0.0.0 tumbler-0.1.22-4.fc16.x86_64 (Fedora Project) 1321084614
:/usr/lib64/libpoppler-glib.so.8.2.0 poppler-glib-0.18.0-2.fc16.x86_64 (Fedora Project) 1321241319
:/lib64/libgio-2.0.so.0.3000.1 glib2-2.30.1-1.fc16.x86_64 (Fedora Project) 1321083874
:/usr/lib64/libcairo.so.2.11000.2 cairo-1.10.2-4.fc16.x86_64 (Fedora Project) 1321084247
:/usr/lib64/gconv/gconv-modules.cache glibc-2.14.90-14.x86_64 (Fedora Project) 1321083865
:/usr/lib64/libfreetype.so.6.7.1 freetype-2.4.6-3.fc16.x86_64 (Fedora Project) 1321083868
:/lib64/libselinux.so.1 libselinux-2.1.6-4.fc16.x86_64 (Fedora Project) 1321086916
:/lib64/libnss_nis-2.14.90.so glibc-2.14.90-14.x86_64 (Fedora Project) 1321083865
:/usr/lib64/libgsttag-0.10.so.0.24.0 gstreamer-plugins-base-0.10.35-3.fc16.x86_64 (Fedora Project) 1321086912
:/usr/lib64/liblcms.so.1.0.19 lcms-libs-1.19-4.fc16.x86_64 (Fedora Project) 1321083879

environ:
:SHELL=/bin/bash
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-GGjpgqnUqG,guid=49a3c03cb65c02713c8089ba0004d274
:XDG_SESSION_COOKIE=fa8ca0e3ac19b584c263547100000006-1321601880.133527-749520394
:XDG_RUNTIME_DIR=/run/user/corsepiu
:DISPLAY=:0
:DESKTOP_SESSION=xfce
:WINDOWPATH=2
:PATH=/usr/local/bin:/usr/bin:/bin
:GDMSESSION=xfce
:XDG_VTNR=2
:USERNAME=corsepiu
:XDG_SESSION_ID=93
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-GGjpgqnUqG,guid=49a3c03cb65c02713c8089ba0004d274
:XDG_SEAT=seat0
:XAUTHORITY=/var/run/gdm/auth-for-corsepiu-mHcccA/database
:USER=corsepiu
:DBUS_STARTER_BUS_TYPE=session
:GNOME_KEYRING_PID=9613
:SHLVL=1
:PWD=/users/corsepiu
:EDITOR=joe
:'PS1=\\u@\\h:\\w > '
:GNOME_KEYRING_CONTROL=/tmp/keyring-BSwRHa
:LANG=en_US.UTF-8
:_=/usr/bin/dbus-launch
:LOGNAME=corsepiu
:HOME=/users/corsepiu

var_log_messages:
:Nov 15 08:46:16 beck kernel: [57316.481898] tumblerd[4691]: segfault at 747261702e4a ip 00000034b66329e0 sp 00007f2f66e68ac8 error 4 in libgobject-2.0.so.0.3000.1[34b6600000+4c000]
:Nov 15 08:46:16 beck abrt[5481]: saved core dump of pid 4690 (/usr/lib64/tumbler-1/tumblerd) to /var/spool/abrt/ccpp-2011-11-15-08:46:16-4690 (160051200 bytes)
:Nov 18 12:46:05 beck kernel: [330905.368264] tumblerd[15762] general protection ip:34b66329e0 sp:7f630b221ac8 error:0 in libgobject-2.0.so.0.3000.1[34b6600000+4c000]
:Nov 18 12:46:05 beck abrt[7860]: saved core dump of pid 15761 (/usr/lib64/tumbler-1/tumblerd) to /var/spool/abrt/ccpp-2011-11-18-12:46:05-15761 (167395328 bytes)
Comment 1 Ralf Corsepius 2011-11-18 06:52:36 EST
Created attachment 534378 [details]
File: backtrace
Comment 2 Ralf Corsepius 2011-11-18 06:52:38 EST
Created attachment 534379 [details]
File: maps
Comment 3 Ralf Corsepius 2011-11-21 08:40:23 EST
Package: tumbler-0.1.22-4.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
Open an *.mpg in nautilus to play it with totem.
Comment 4 Christoph Wickert 2011-11-21 08:59:15 EST
Are you sure it was nautilus and Thunar was not involved here? I am beginning to think that the problem is not in tumbler' GStreamer plugin but in GStreamer itself. We have reports of other applications (e.g. midori) crashing and freezing as soon as they are trying to use GStreamer.
Comment 5 Ralf Corsepius 2011-11-21 09:17:32 EST
(In reply to comment #4)
> Are you sure it was nautilus and Thunar was not involved here?
You are right on the spot - Though I was 100% sure to once have configured nautilus as my preferred "File Manager", I currently have Thunar :)

[No idea about the cause, but I am facing other "automagic"
Gnome3<->xfce switchers with gdm's "session"].

> I am beginning
> to think that the problem is not in tumbler' GStreamer plugin but in GStreamer
> itself. We have reports of other applications (e.g. midori) crashing and
> freezing as soon as they are trying to use GStreamer.
Hmm. I am currently pretty clueless, except that I only reported a very small numbers of the segfaults I actually have seen so far (I could flood you if I'd wanted to).

Looks like a systematic issue with some files I have on disk to me.

Also, as I don't actually know what thumbler does, I am not sure if it's actually launching totem on a particular video which causes the segfaults, but browsing a folder of videos - thumbnail creation?
Comment 6 Christoph Wickert 2011-11-22 19:27:41 EST
(In reply to comment #5)
> (In reply to comment #4)
> > Are you sure it was nautilus and Thunar was not involved here?
> You are right on the spot - Though I was 100% sure to once have configured
> nautilus as my preferred "File Manager", I currently have Thunar :)

If you are using Xfce you can use exo-preferred-applications to select your favorite file manager. Not all GNOME apps honor this setting though and I don't know where to set the default file manager in GNOME 3.x

> Also, as I don't actually know what thumbler does, I am not sure if it's
> actually launching totem on a particular video which causes the segfaults, but
> browsing a folder of videos - thumbnail creation?

Bingo!

You can remove /usr/lib*/tumbler-1/plugins/tumbler-gst-thumbnailer.so if the crashes continue.
Comment 7 Christoph Wickert 2011-11-28 04:24:31 EST
*** Bug 757641 has been marked as a duplicate of this bug. ***
Comment 8 Christoph Wickert 2011-11-28 06:25:07 EST
*** Bug 757641 has been marked as a duplicate of this bug. ***
Comment 9 Christoph Wickert 2011-12-04 05:03:29 EST
*** Bug 757641 has been marked as a duplicate of this bug. ***
Comment 10 Christoph Wickert 2011-12-04 05:03:51 EST
*** Bug 759846 has been marked as a duplicate of this bug. ***
Comment 11 Christoph Wickert 2011-12-04 05:10:14 EST
Thanks everybody for submitting this crash report. I have forwarded it to the developers at https://bugzilla.xfce.org/show_bug.cgi?id=8219

From now on, further investigation of this crash should take place in the Xfce bug tracker. I will get back to you if I need more info and let you know once this bug is resolved in Fedora.
Comment 12 Christoph Wickert 2011-12-04 18:14:07 EST
*** Bug 759935 has been marked as a duplicate of this bug. ***
Comment 13 Ralf Corsepius 2012-01-07 01:29:41 EST
I am still facing this bug almost every day.

However BZ now refuses to accept reports about it, probably due to the fact you have closed this BUG "fixed upstream":

--- Running report_Bugzilla ---
Logging into Bugzilla at https://bugzilla.redhat.com
Checking for duplicates
Bug is already reported: 754961
Logging out
Status: CLOSED UPSTREAM https://bugzilla.redhat.com/show_bug.cgi?id=754961

=> This bug has not been fixed in fedora.
=> You are cheating.
Comment 14 Christoph Wickert 2012-01-07 04:36:57 EST
(In reply to comment #13)
> => This bug has not been fixed in fedora.
> => You are cheating.

Please take a minute to read the bugzilla documentation and become familar with the workflow. CLOSED UPSTREAM does not imply the bug is actually fixed in Fedora but "bugs closed with this resolution are filed in the upstream bugs tracker or reported to the upstream mailing list".

More info is available at https://bugzilla.redhat.com/page.cgi?id=fields.html#status

Let me quote you from bug 757641 comment 10: "There is nothing I can do about these segfaults." - So what do you expect me to to or to track here?

If you really hit this bug every day, then please use the work around I have given you. TIA.
Comment 15 Ralf Corsepius 2012-01-07 05:10:10 EST
(In reply to comment #14)
> (In reply to comment #13)
> > => This bug has not been fixed in fedora.
> > => You are cheating.
> 
> Please take a minute to read the bugzilla documentation and become familar with
> the workflow. CLOSED UPSTREAM does not imply the bug is actually fixed in
> Fedora but "bugs closed with this resolution are filed in the upstream bugs
> tracker or reported to the upstream mailing list".
> 
> More info is available at
> https://bugzilla.redhat.com/page.cgi?id=fields.html#status
As long as Fedora exists, I have been discouraging maintainers to use CLOSED UPSTREAM. because it's a bold lie, which is only useful to violently play down the number of bugs Fedora suffers from.

Combined with the fact, abrt now "silently exits 0" once a bug was CLOSDED UPSTREAM, I am considering maintainers closing bugs "CLOSED UPSTREAM" to be doing so deliberately in hostile intentions.

> Let me quote you from bug 757641 comment 10: "There is nothing I can do about
> these segfaults."
Correct. These segfaults happen in the background, without any any immediate interaction attached and without abrt not providing any helpful information to reproduce them.

> - So what do you expect me to to or to track here?
At minimum, I am expecting maintainers to keep bugs open as long as they affect Fedora - What you are doing is cheating!

> If you really hit this bug every day, then please use the work around I have
> given you. TIA.
You mean to 
"rm /usr/lib*/tumbler-1/plugins/tumbler-gst-thumbnailer.so"?

Certainly this stops the segfaults, ... because it's stops all thumbnailing.
== Suppressing symptoms

Note You need to log in before you can comment on or make changes to this bug.