Bug 755270 - No recovery mode in boot-menu after kernel update
No recovery mode in boot-menu after kernel update
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
: 755411 756485 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-20 04:08 EST by arturj
Modified: 2011-11-25 11:22 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-22 14:37:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description arturj 2011-11-20 04:08:56 EST
Description of problem:
MY boot-menu has only one recovery mode entry for the first stock fedora 16 kernel. All newer kernels installed via yum update have no recovery mode entries.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install Fedora 16 and verify boot-menu (should contain one kernel with recovery mode)
2. Run yum update (should install a newer kernel)
3. Check once again the boot-menu. New kernel has no recovery mode
  
Actual results:
No recovery mode in boot-menu for updated kernels

Expected results:
Each kernel should have a recovery mode in boot-menu. E.g. 3 kernels should have 6 entries in the boot-menu (one for normal operation one for recovery mode)

Additional info:
Comment 1 Mads Kiilerich 2011-11-22 14:37:53 EST
The lack of recovery entries is not a bug.

It could be considered a bug that recovery entries are created at all - see bug 751898.
Comment 2 Mads Kiilerich 2011-11-22 14:44:43 EST
*** Bug 755411 has been marked as a duplicate of this bug. ***
Comment 3 arturj 2011-11-23 01:49:39 EST
Recovery modes are present in all major distros for a long time now and since Fedora 16 its becoming a bug? 751898 states this as well and boot-menu passwords are the only real solution along with disk-encryption to secure your OS from unauthorized access (like booting from a live-cd or USB and mounting your harddisk). Could someone advice how to configure "back" recovery-option if its still considered as a bug so the will show up after each kernel update automatically?
Comment 4 Mads Kiilerich 2011-11-23 06:21:54 EST
(In reply to comment #3)
> Recovery modes are present in all major distros for a long time now and since
> Fedora 16 its becoming a bug?

That is not correct.

Recovery or not is discussed on bug 751898 - that is where you should comment if you want to influence anything.
Comment 5 Mads Kiilerich 2011-11-25 11:22:51 EST
*** Bug 756485 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.