Bug 755574 - 'Globally uncaught exception' when browsing file-system template snapshot history
'Globally uncaught exception' when browsing file-system template snapshot hi...
Status: CLOSED DUPLICATE of bug 755712
Product: RHQ Project
Classification: Other
Component: Core UI, drift (Show other bugs)
unspecified
Unspecified Unspecified
urgent Severity unspecified (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: jon30-sprint9 707225
  Show dependency treegraph
 
Reported: 2011-11-21 09:16 EST by Libor Zoubek
Modified: 2015-11-01 19:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-22 10:30:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
file-system drift (77.32 KB, image/png)
2011-11-21 09:29 EST, Libor Zoubek
no flags Details

  None (edit)
Description Libor Zoubek 2011-11-21 09:16:11 EST
Description of problem: I get expce


Version-Release number of selected component (if applicable):
JON 3.0.0.CR2
Build Number: 0a92497:a16c2ea

How reproducible: always


Steps to Reproduce:
1. create file system drift from template (see screenshot, not sure if matters)
2. do not pin
3. let JON detect snapshot 0
4. make some changes on file system (touch new file), let JON find snapshot 1
5. navigate to snapshot history, you should see snapshot 1 with 1 new file
6. hit 'Previous' button
  
Actual results: 

com.google.gwt.core.client.JavaScriptException:(TypeError): Cannot read property 'java_lang_Integer_value' of null
--- STACK TRACE FOLLOWS ---
(TypeError): Cannot read property 'java_lang_Integer_value' of null
   at Unknown.org_rhq_enterprise_gui_coregui_client_components_carousel_Carousel_$setCarouselStartFilter__Lorg_rhq_enterprise_gui_coregui_client_components_carousel_Carousel_2Ljava_lang_Integer_2V(Unknown source:0)
   at Unknown.org_rhq_enterprise_gui_coregui_client_components_carousel_Carousel_$previous__Lorg_rhq_enterprise_gui_coregui_client_components_carousel_Carousel_2V(Unknown source:0)
   at Unknown.org_rhq_enterprise_gui_coregui_client_components_carousel_Carousel$5_onClick__Lcom_smartgwt_client_widgets_events_ClickEvent_2V(Unknown source:0)
   at Unknown.com_smartgwt_client_widgets_events_ClickEvent_dispatch__Lcom_google_gwt_event_shared_EventHandler_2V(Unknown source:0)
   at Unknown.com_google_gwt_event_shared_HandlerManager$HandlerRegistry_$fireEvent__Lcom_google_gwt_event_shared_HandlerManager$HandlerRegistry_2Lcom_google_gwt_event_shared_GwtEvent_2ZV(Unknown source:0)
   at Unknown.com_google_gwt_event_shared_HandlerManager_$fireEvent__Lcom_google_gwt_event_shared_HandlerManager_2Lcom_google_gwt_event_shared_GwtEvent_2V(Unknown source:0)
   at Unknown.com_smartgwt_client_widgets_BaseWidget_fireEvent__Lcom_google_gwt_event_shared_GwtEvent_2V(Unknown source:0)
   at Unknown.<anonymous>(Unknown source:0)
   at Unknown.com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2(Unknown source:0)
   at Unknown.click(Unknown source:0)


Expected results:



Additional info:
Comment 1 Libor Zoubek 2011-11-21 09:29:02 EST
Created attachment 534791 [details]
file-system drift
Comment 2 Mike Foley 2011-11-22 10:30:42 EST
<jshaughn> mfoley: yes, this is a dup of 755712
<jsanda> mfoley: but that bz is a known issue and i think jshaughn is already looking at it
<jshaughn> which is now ON_QA-Master

*** This bug has been marked as a duplicate of bug 755712 ***

Note You need to log in before you can comment on or make changes to this bug.