Bug 75609 - Nautilus : Cannot access the content of a SMB server
Nautilus : Cannot access the content of a SMB server
Product: Red Hat Linux
Classification: Retired
Component: gnome-vfs2-extras (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Jay Turner
: Triaged
Depends On:
Blocks: 79579 CambridgeTarget
  Show dependency treegraph
Reported: 2002-10-10 04:19 EDT by Need Real Name
Modified: 2015-01-07 19:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-04-22 16:33:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-10 04:19:37 EDT
Description of Problem:

With nautilus, I cannot access the content of an SMP server (the machine itself
for instance or any Windows NT server)

Version-Release number of selected component (if applicable):
RedHat 8.0

How Reproducible:
Make your machine an SMP server (modify the smb.conf file, the smbpasswd file
and the smbusers file)
Open Nautilus, use the smb:// browsing functionality. Find your own server (or
any other Windows NT server), click on it... The files are never displayed or it
ask for the login and passwd to be send encrypted (they are not validated by the
server anyway...)

Steps to Reproduce:
1. Setup the SMB server and the smbfiles according to the RedHat 8.0 manual:

[root@cherbourg samba]# diff smb.conf smb.conf.org
<    workgroup = WIN
>    workgroup = MYGROUP
<    server string = RedHat Linux 8.0. Samba 2.2.5 Server
>    server string = Samba Server

2. Open Nautilus and browse your own machine

Actual Results:
No files displayed
File server not opened
Uncrypted login and passwd asked, and not validated. 

Expected Results:
Access to the content of the file servers

Additional Information:
The other way around it works: Windows NT machines access the machine I setup as
a file server. It seems to prove that the problem is on the Linux SMB client side.
I think it is a problem of encryption. Somehow the user name or the passwd is
not recognised (I generated a smbpasswd and a smbusers file however)
Maybe I have a daemon to restart after having modified the smbusers file. I
restarted smbd but it did not change anything.
Comment 1 Havoc Pennington 2002-10-10 11:10:10 EDT
You might try with your Linux firewall totally disabled. (run
/etc/init.d/ipchains stop, and verify with "ipchains -L" that there are no rules)
Comment 2 Need Real Name 2002-10-10 11:35:13 EDT
Actually, I had NO firewalls at all...
I had to install ipchains, to reboot the machine and here is what I got:
[root@cherbourg ted]# /etc/rc.d/init.d/ipchains stop
Flushing all chains: ipchains: Incompatible with this kernel
Removing user defined chains: ipchains: Incompatible with this kernel
Resetting built-in chains to the default ACCEPT policy:ipchains: Protocol not

Obviously there has been no changes with Nautilus

I tried to stop iptables also but it has not solved either my problem with

Comment 4 John Thacker 2006-04-22 16:33:27 EDT
Very old bug with no information.  There have been lots of changes since then,
and it certainly works for me.  (Though making sure that the firewall isn't
blocking the relevant ports, 137 and 138, is always reasonable.)

Note You need to log in before you can comment on or make changes to this bug.