Bug 75631 - gnome-terminal leaks memory when used through vncserver
Summary: gnome-terminal leaks memory when used through vncserver
Status: CLOSED DUPLICATE of bug 75498
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vte   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
: 75701 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-10 14:26 UTC by Ernst-Richard Myrbakk
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-17 22:13:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ernst-Richard Myrbakk 2002-10-10 14:26:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2a) Gecko/20020910

Description of problem:
If you start a new gnome-session in a vncserver session, and uses the default
terminal in Gnome (gnome-terminal), it will "leak memory" quite quick if the
terminal is being used. A simple test is to just have the terminal run the
command: "top", and watch how it increases in memory usage untill it finally
crashes.

I'm running the default vncserver that is in the RedHat 8.0 release (version:
3.3.3r2-39) and have also tested the new 3.3.4 release with the same results.
On the other end of the vnc session, I'm running vncviewer v.3.3.3r9 on a
machine running WindowsXP(Service pack 1). I have also tested it whith the new
vncviewer v.3.3.4 - same result.
What is funny about this, is that this behavior is only observed with the
gnome-terminal running in a vncsession. Other terminals, like xterm, konsole
etc. are working flawlessly. I have tested this with two different installations
with the same result. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start a gnome-session in a vncserver
2. Connect to vncsession by using a vncviewer from a Windows box
3. Open a gnome-terminal
4. Run: "top"
5. Watch the memory usage for the process "gnome-terminal" grow....
	

Additional info:

Comment 1 Nalin Dahyabhai 2002-10-17 22:12:55 UTC
*** Bug 75701 has been marked as a duplicate of this bug. ***

Comment 2 Nalin Dahyabhai 2002-10-17 22:19:46 UTC

*** This bug has been marked as a duplicate of 75498 ***


Note You need to log in before you can comment on or make changes to this bug.