Bug 756505 - [abrt] yum-3.4.3-5.fc16: yummain.py:51:exIOError:UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 11: ordinal not in range(128)
[abrt] yum-3.4.3-5.fc16: yummain.py:51:exIOError:UnicodeDecodeError: 'ascii' ...
Status: CLOSED DUPLICATE of bug 749239
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
abrt_hash:5ddcabc798b9e450d82e2689bea...
:
Depends On: 749478
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-23 14:30 EST by Alexei Panov
Modified: 2014-01-21 18:20 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-28 09:59:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: smolt_data (3.14 KB, text/plain)
2011-11-23 14:30 EST, Alexei Panov
no flags Details

  None (edit)
Description Alexei Panov 2011-11-23 14:30:20 EST
libreport version: 2.0.7
abrt_version:   2.0.6
cmdline:        /usr/bin/python /usr/bin/yum -d 0 -C list available spi*
executable:     /usr/bin/yum
kernel:         3.1.1-2.fc16.x86_64
reason:         yummain.py:51:exIOError:UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 11: ordinal not in range(128)
time:           Ср. 23 нояб. 2011 23:14:10
uid:            1000
username:       alex

smolt_data:     Binary file, 3218 bytes

backtrace:
:yummain.py:51:exIOError:UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 11: ordinal not in range(128)
:
:Traceback (most recent call last):
:  File "/usr/bin/yum", line 29, in <module>
:    yummain.user_main(sys.argv[1:], exit_code=True)
:  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
:    errcode = main(args)
:  File "/usr/share/yum-cli/yummain.py", line 149, in main
:    return exIOError(e)
:  File "/usr/share/yum-cli/yummain.py", line 51, in exIOError
:    logger.critical(_('\n\n%s') % exception2msg(e))
:UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 11: ordinal not in range(128)
:
:Local variables in innermost frame:
:unlock: <function unlock at 0x14280c8>
:e: IOError(13, '\xd0\x9e\xd1\x82\xd0\xba\xd0\xb0\xd0\xb7\xd0\xb0\xd0\xbd\xd0\xbe \xd0\xb2 \xd0\xb4\xd0\xbe\xd1\x81\xd1\x82\xd1\x83\xd0\xbf\xd0\xb5')
:logger: <logging.Logger object at 0x134f350>

comment:
:1. opened a gnome-terminal
:2. typing in it: "sudo yum list spice-" and press the button TAB for autocomplete
:3. crash (open abrt-applet) and no autocomplete
:
:$ locale
:LANG=ru_RU.utf8
:LC_CTYPE="ru_RU.utf8"
:LC_NUMERIC="ru_RU.utf8"
:LC_TIME="ru_RU.utf8"
:LC_COLLATE="ru_RU.utf8"
:LC_MONETARY="ru_RU.utf8"
:LC_MESSAGES="ru_RU.utf8"
:LC_PAPER="ru_RU.utf8"
:LC_NAME="ru_RU.utf8"
:LC_ADDRESS="ru_RU.utf8"
:LC_TELEPHONE="ru_RU.utf8"
:LC_MEASUREMENT="ru_RU.utf8"
:LC_IDENTIFICATION="ru_RU.utf8"
:LC_ALL=
:
:With LANG set to "C" - bug is not reproduced.
Comment 1 Alexei Panov 2011-11-23 14:30:25 EST
Created attachment 535604 [details]
File: smolt_data
Comment 2 Zdeněk Pavlas 2011-11-28 09:59:55 EST

*** This bug has been marked as a duplicate of bug 749239 ***

Note You need to log in before you can comment on or make changes to this bug.