Bug 756540 - [abrt] kernel: irq 17: nobody cared (try booting with the "irqpoll" option) ASM108x
[abrt] kernel: irq 17: nobody cared (try booting with the "irqpoll" option) A...
Status: CLOSED DUPLICATE of bug 755956
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:92ea791c4c6fe1a9880bea42258...
:
: 759900 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-23 16:32 EST by James Cape
Modified: 2012-03-05 17:00 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-05 17:00:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: smolt_data (3.01 KB, text/plain)
2011-11-23 16:32 EST, James Cape
no flags Details
same error at boot (1.41 KB, text/plain)
2011-12-17 06:02 EST, Juan P. Daza P.
no flags Details
interrupts file (2.02 KB, text/plain)
2011-12-17 06:03 EST, Juan P. Daza P.
no flags Details

  None (edit)
Description James Cape 2011-11-23 16:32:03 EST
libreport version: 2.0.7
abrt_version:   2.0.6
cmdline:        BOOT_IMAGE=/vmlinuz-3.1.1-2.fc16.x86_64 root=/dev/mapper/vg_jamescape-lv_root ro rd.md=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 rd.lvm.lv=vg_jamescape/lv_swap rd.lvm.lv=vg_jamescape/lv_root LANG=en_US.UTF-8 enforcing=0
kernel:         3.1.1-2.fc16.x86_64
reason:         irq 17: nobody cared (try booting with the "irqpoll" option)
time:           Wed 23 Nov 2011 04:31:24 PM EST

smolt_data:     Text file, 3081 bytes

backtrace:
:irq 17: nobody cared (try booting with the "irqpoll" option)
:Pid: 0, comm: kworker/0:1 Not tainted 3.1.1-2.fc16.x86_64 #1
:Call Trace:
: <IRQ>  [<ffffffff810b2222>] __report_bad_irq+0x38/0xc3
: [<ffffffff810b24bc>] note_interrupt+0x176/0x1fa
: [<ffffffff810b0a0f>] handle_irq_event_percpu+0x15d/0x1a5
: [<ffffffff810b0a92>] handle_irq_event+0x3b/0x59
: [<ffffffff81078268>] ? sched_clock_cpu+0x42/0xc6
: [<ffffffff810b2c7c>] handle_fasteoi_irq+0x80/0xa4
: [<ffffffff81010af9>] handle_irq+0x88/0x8e
: [<ffffffff814c040d>] do_IRQ+0x4d/0xa5
: [<ffffffff814b756e>] common_interrupt+0x6e/0x6e
: <EOI>  [<ffffffff813a5cb2>] ? poll_idle+0x2f/0x65
: [<ffffffff813a5c9e>] ? poll_idle+0x1b/0x65
: [<ffffffff813a5fce>] cpuidle_idle_call+0xe8/0x182
: [<ffffffff8100e2e3>] cpu_idle+0xa4/0xe8
: [<ffffffff814a54dc>] start_secondary+0x23f/0x241
Comment 1 James Cape 2011-11-23 16:32:07 EST
Created attachment 535659 [details]
File: smolt_data
Comment 2 Josh Boyer 2011-12-05 09:34:56 EST
*** Bug 759900 has been marked as a duplicate of this bug. ***
Comment 3 Josh Boyer 2011-12-05 12:19:05 EST
Does this happen frequently?  If so, can you attach the output of /proc/interrupts from your machine?
Comment 4 Juan P. Daza P. 2011-12-17 06:02:58 EST
Created attachment 548131 [details]
same error at boot

When booting fedora 16 (3.1.5-2.fc16.x86_64) this error always shows up in dmesg.
Comment 5 Juan P. Daza P. 2011-12-17 06:03:32 EST
Created attachment 548132 [details]
interrupts file

interrupts file
Comment 6 Josh Boyer 2012-02-02 15:37:22 EST
Your motherboard is using the ASM108x PCI bridge.  There is a problem identified with this particular chip upstream that might be causing this issue:

http://thread.gmane.org/gmane.linux.kernel/1245767
Comment 7 Josh Boyer 2012-03-05 16:57:55 EST
We're going to consolidate all of these bugs with the impacted hardware into a single bug.  The latest F15 and F16 kernel updates that should hit the mirrors soon have a patch to at least fall back to the irqpoll method when this happens.  Hopefully it results in a bit better experience for you.
Comment 8 Josh Boyer 2012-03-05 17:00:11 EST

*** This bug has been marked as a duplicate of bug 755956 ***

Note You need to log in before you can comment on or make changes to this bug.