This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 757178 - Non processed IOE prevents drift report
Non processed IOE prevents drift report
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: drift (Show other bugs)
4.2
All All
urgent Severity urgent (vote)
: ---
: RHQ 4.3.0,JON 3.0.0
Assigned To: Heiko W. Rupp
Mike Foley
:
Depends On:
Blocks: jon30-sprint9
  Show dependency treegraph
 
Reported: 2011-11-25 12:23 EST by Heiko W. Rupp
Modified: 2012-02-07 14:21 EST (History)
2 users (show)

See Also:
Fixed In Version: 4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:21:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Heiko W. Rupp 2011-11-25 12:23:08 EST
I am checking files in /etc/ and can not access /etc/aliases.db (as the agent user has no rights)
this prevents drift detection:


2011-11-25 18:20:47,835 ERROR [pool-3-thread-1] (rhq.core.pc.drift.DriftDetector)- Drift detection failed: An error occurred while generati
ng a drift change set
org.rhq.core.pc.drift.DriftDetectionException: An error occurred while generating a drift change set
        at org.rhq.core.pc.drift.DriftDetector$1.visit(DriftDetector.java:239)
        at org.rhq.core.pc.drift.FilterFileVisitor.visit(FilterFileVisitor.java:136)
        at org.rhq.core.util.file.FileUtil.forEachFile(FileUtil.java:361)
        at org.rhq.core.pc.drift.DriftDetector.generateDriftChangeSet(DriftDetector.java:213)
        at org.rhq.core.pc.drift.DriftDetector.run(DriftDetector.java:114)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
        at java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:317)
        at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:150)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:98)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodic(ScheduledThreadPoolExecutor.java:180)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:204)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:680)
Caused by: java.io.FileNotFoundException: /etc/aliases.db (Permission denied)
        at java.io.FileInputStream.open(Native Method)
        at java.io.FileInputStream.<init>(FileInputStream.java:120)
        at org.rhq.core.util.MessageDigestGenerator.calcDigest(MessageDigestGenerator.java:255)
        at org.rhq.core.util.MessageDigestGenerator.calcDigestString(MessageDigestGenerator.java:291)
        at org.rhq.core.pc.drift.DriftDetector.sha256(DriftDetector.java:514)
        at org.rhq.core.pc.drift.DriftDetector.access$200(DriftDetector.java:51)
        at org.rhq.core.pc.drift.DriftDetector$1.visit(DriftDetector.java:233)
        ... 13 more
Comment 1 Heiko W. Rupp 2011-11-25 13:54:13 EST
master b9ef6c8
Comment 2 John Sanda 2011-11-28 13:51:04 EST
release_jon3.x commit hash: 20c2bae9c4c9aa6f9127c0a9d81ebada8d4dfd23
Comment 3 Mike Foley 2011-11-28 14:28:32 EST
i encountered an error verifying this BZ.

https://bugzilla.redhat.com/show_bug.cgi?id=757827

could the fix for this BZ have caused 757827?
Comment 4 Mike Foley 2011-11-28 14:36:16 EST
reassigning to ON_QA ... 757827 was environmental  (not a regression)
Comment 5 Mike Foley 2011-11-28 14:36:59 EST
verified jon 3 branch
Comment 6 Mike Foley 2012-02-07 14:21:17 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.