Bug 75720 - redhat-config-packages thinks a lot of software isn't installed when it is
redhat-config-packages thinks a lot of software isn't installed when it is
Status: CLOSED DUPLICATE of bug 71289
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-11 11:08 EDT by Scott Dowdle
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-11 11:12:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Complete listing of "rpm -qa | sort (15.79 KB, text/plain)
2002-10-11 11:12 EDT, Scott Dowdle
no flags Details

  None (edit)
Description Scott Dowdle 2002-10-11 11:08:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020827

Description of problem:
Looking at the list of packages, "Web Server" does NOT have a check by it and
says that 0/14 packages are installed.  This is simply not true.  the httpd
package, php, and many other packages ARE installed and rpm (with rpm -qa) shows
that they are there.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run redhat-config-packages (via System Settings->Packages)
2. View list after it gathered info and it does NOT have a check by "Web Server"
and shows 0/14 packages installed
3. Ask rpm and it says httpd and php ARE installed
	

Additional info:

For good measure, I did an rpm --rebuilddb and tried again but got the same
results.  Also, I'm sure there are a large number of packages that it is just
NOT picking up.  For example, under the "Development" catagory NOTHING has a
check and all sections (Development Tools, Kernel Development, X Software
Development, Gnome Software Development, KDE Software Development) show 0/x
packages installed.  I'll attach the output of rpm -qa | sort
Comment 1 Scott Dowdle 2002-10-11 11:12:06 EDT
Created attachment 79986 [details]
Complete listing of "rpm -qa | sort
Comment 2 Jeremy Katz 2002-10-11 17:07:59 EDT
This is related to 71289 since if we show something other than 0, we should also
let you look at the details of the group.  In the case of web server, you're
getting it's not installed because you don't have httpd-manual installed which
was marked (mistakenly, fixed in cvs) as required for a web server to be
considered "installed"

*** This bug has been marked as a duplicate of 71289 ***
Comment 3 Scott Dowdle 2002-10-11 18:43:59 EDT
Hmmm, I don't understand how you think this is a duplication of bug #71289. 
That bug wasn't actually a bug but a request for a operational change to how the
program works.  In said suggestion the person said it would be nice IF he could
view the list of packages in groups that aren't installed (without having to
mark it to be installed just to get a list).

The bug I reported is that I have stuff installed and it is showing up as
UNINSTALLED... which is COMPLETELY different.

Please note that in my further explanation, I mentioned that there are a number
of groups that are not showing as installed when they really are... not just the
"Web Server" section... unless you have the same problem with many other
packages that you noted on the new CVS package for httpd-manual (or whatever it
was).

...or perhaps I misunderstood.

Note You need to log in before you can comment on or make changes to this bug.