Bug 757302 - SIGABRT: Modules/gcmodule.c:275: visit_decref: Assertion > `gc->gc.gc_refs != 0' failed
SIGABRT: Modules/gcmodule.c:275: visit_decref: Assertion > `gc->gc.gc_refs !=...
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: python-psycopg2 (Show other bugs)
el5
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Devrim GÜNDÜZ
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks: 843723
  Show dependency treegraph
 
Reported: 2011-11-26 03:26 EST by Šimon Lukašík
Modified: 2012-08-12 23:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 843723 (view as bug list)
Environment:
Last Closed: 2012-08-12 23:00:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
A backtrace (13.86 KB, text/plain)
2011-11-26 03:27 EST, Šimon Lukašík
no flags Details
A proposed patch (1.47 KB, patch)
2011-11-26 03:29 EST, Šimon Lukašík
no flags Details | Diff

  None (edit)
Description Šimon Lukašík 2011-11-26 03:26:14 EST
Description of problem:
There is a reference leak bug in python-psycopg2. Sadly, I cannot provide
narrow reproducer (without Spacewalk components).

Version-Release number of selected component (if applicable):
python-psycopg2-2.0.14-1.el5

How reproducible:
deterministic

Steps to Reproduce:
1. Install Spacewalk nightly (PostgreSQL variant) on RHEL5 (or equivalent)
2. Create some non-empty custom channels
3. # /usr/bin/rhn-satellite-exporter --channel=parent-qrywz \
   --channel=child-of-parent-qrywz --dir=/tmp/dump.errata.kgCvf28372

 
Actual results:
02:51:20 Gathering channel info...
Appending channels ['child-of-parent-qrywz', 'parent-qrywz']
02:51:20 Gathering binary RPM info...
python: Modules/gcmodule.c:275: visit_decref:
Assertion `gc->gc.gc_refs != 0' failed.
Aborted

Expected results:
Export should pass.

Additional info:
Comment 1 Šimon Lukašík 2011-11-26 03:27:14 EST
Created attachment 536652 [details]
A backtrace
Comment 2 Šimon Lukašík 2011-11-26 03:29:17 EST
Created attachment 536653 [details]
A proposed patch

This problem was actually fixed in upstream. The attached please find
an equivalent of upstream's commit: eaa97def731faa6fb9b17cfe9005d327f6a70341
Comment 3 Jan Hutař 2012-03-15 08:26:59 EDT
This was observed also on RHEL6 with python-psycopg2-2.0.14-1.el6_2.1
Comment 4 Jan Pazdziora 2012-07-25 07:57:50 EDT
(In reply to comment #3)
> This was observed also on RHEL6 with python-psycopg2-2.0.14-1.el6_2.1

Do we have a RHEL 6 version of this bugzilla?
Comment 5 Toshio Ernie Kuratomi 2012-07-25 11:15:15 EDT
I don't work with the Python CAPI but a quick look at the patch seems sane.  I also checked that

* This is the only difference between typecast.c in 2.0.14 and typecast.c at the time of the upstream commit.
* The patch is still applied in upstream's current 2.4.4 release.

Devrim, I'll go ahead and apply and build tomorrow unless I hear otherwise from you.
Comment 6 Jan Hutař 2012-07-27 03:51:49 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > This was observed also on RHEL6 with python-psycopg2-2.0.14-1.el6_2.1
> 
> Do we have a RHEL 6 version of this bugzilla?

I see, python-psycopg2 is in EPEL5 and RHEL6 (and not EPEL6). Cloned as bug 843723. Thanks for the ping here.
Comment 7 Fedora Update System 2012-07-27 14:24:00 EDT
python-psycopg2-2.0.14-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/python-psycopg2-2.0.14-2.el5
Comment 8 Toshio Ernie Kuratomi 2012-07-27 14:30:34 EDT
Thanks for the bug report and extracting the fix.  See if this update works.
Comment 9 Fedora Update System 2012-07-27 18:06:41 EDT
Package python-psycopg2-2.0.14-2.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing python-psycopg2-2.0.14-2.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-6533/python-psycopg2-2.0.14-2.el5
then log in and leave karma (feedback).
Comment 10 Jan Pazdziora 2012-07-30 11:28:12 EDT
My testing of Spacewalk with this new build shows that the problem is resolved. Thank you!
Comment 11 Fedora Update System 2012-08-12 23:00:42 EDT
python-psycopg2-2.0.14-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.