Bug 843723 - SIGABRT: Modules/gcmodule.c:275: visit_decref: Assertion > `gc->gc.gc_refs != 0' failed
Summary: SIGABRT: Modules/gcmodule.c:275: visit_decref: Assertion > `gc->gc.gc_refs !=...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-psycopg2
Version: 6.3
Hardware: Unspecified
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Tom Lane
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On: 757302
Blocks: 791327
TreeView+ depends on / blocked
 
Reported: 2012-07-27 07:50 UTC by Jan Hutař
Modified: 2013-07-03 03:45 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 757302
Environment:
Last Closed: 2013-02-21 08:41:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0327 normal SHIPPED_LIVE python-psycopg2 bug fix and enhancement update 2013-02-20 20:54:33 UTC

Description Jan Hutař 2012-07-27 07:50:11 UTC
+++ This bug was initially created as a clone of Bug #757302 +++

Description of problem:
There is a reference leak bug in python-psycopg2. Sadly, I cannot provide
narrow reproducer (without Spacewalk components).

Version-Release number of selected component (if applicable):
python-psycopg2-2.0.14-1.el5

How reproducible:
deterministic

Steps to Reproduce:
1. Install Spacewalk nightly (PostgreSQL variant) on RHEL5 (or equivalent)
2. Create some non-empty custom channels
3. # /usr/bin/rhn-satellite-exporter --channel=parent-qrywz \
   --channel=child-of-parent-qrywz --dir=/tmp/dump.errata.kgCvf28372

 
Actual results:
02:51:20 Gathering channel info...
Appending channels ['child-of-parent-qrywz', 'parent-qrywz']
02:51:20 Gathering binary RPM info...
python: Modules/gcmodule.c:275: visit_decref:
Assertion `gc->gc.gc_refs != 0' failed.
Aborted

Expected results:
Export should pass.

Additional info:

--- Additional comment from slukasik@redhat.com on 2011-11-26 03:27:14 EST ---

Created attachment 536652 [details]
A backtrace

--- Additional comment from slukasik@redhat.com on 2011-11-26 03:29:17 EST ---

Created attachment 536653 [details]
A proposed patch

This problem was actually fixed in upstream. The attached please find
an equivalent of upstream's commit: eaa97def731faa6fb9b17cfe9005d327f6a70341

--- Additional comment from jhutar@redhat.com on 2012-03-15 08:26:59 EDT ---

This was observed also on RHEL6 with python-psycopg2-2.0.14-1.el6_2.1

--- Additional comment from jpazdziora@redhat.com on 2012-07-25 07:57:50 EDT ---

(In reply to comment #3)
> This was observed also on RHEL6 with python-psycopg2-2.0.14-1.el6_2.1

Do we have a RHEL 6 version of this bugzilla?

--- Additional comment from a.badger@gmail.com on 2012-07-25 11:15:15 EDT ---

I don't work with the Python CAPI but a quick look at the patch seems sane.  I also checked that

* This is the only difference between typecast.c in 2.0.14 and typecast.c at the time of the upstream commit.
* The patch is still applied in upstream's current 2.4.4 release.

Devrim, I'll go ahead and apply and build tomorrow unless I hear otherwise from you.

Comment 2 Jan Pazdziora 2012-07-30 15:35:03 UTC
The change fixed the issues for the EPEL 5's python-psycopg2 package. It would be great to see it in RHEL 6 as well.

Comment 12 errata-xmlrpc 2013-02-21 08:41:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0327.html


Note You need to log in before you can comment on or make changes to this bug.