Bug 75762 - instdso.sh not included in httpd-devel RPM
instdso.sh not included in httpd-devel RPM
Status: CLOSED DUPLICATE of bug 73428
Product: Red Hat Linux
Classification: Retired
Component: httpd (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-11 18:31 EDT by Eric Koperda
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-11 18:31:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Koperda 2002-10-11 18:31:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4.1)
Gecko/20020508 Netscape6/6.2.3

Description of problem:
The script instdso.sh is not installed by the in the httpd-devel RPM.  The
result is a 'No such file or directory' error (documented below) when running
APXS to compile a new module for Apache Httpd.

After a build of the httpd-2.0.40 sources the necessary file can be found in the
build/ directory.  It appears that the problem can be corrected by adjusting the
http.spec file's contents to include '%{_libdir}/httpd/build/instdso.sh' in the
'%files devel' section.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RH 8.0 with the httpd-2.0.40 and httpd-devel-2.0.40 RPM's.
2. run apxs -c -i mod_recipnet_auth.c AuthConnector_stub.c DirectoryTable.c
(these are the sources for an Apache module my group is developing)
	

Actual Results:  Five commands are run and each one is echoed to the console. 
The fifth command generates two additional error lines on the console.

/usr/lib/httpd/build/libtool --mode=compile gcc ... (truncated for brevity)
/usr/lib/httpd/build/libtool --mode=compile gcc ... (truncated for brevity)
/usr/lib/httpd/build/libtool --mode=compule gcc ... (truncated for brevity)
/usr/lib/httpd/build/libtool --mode=link gcc ... (truncated for brevity)
/usr/lib/httpd/build/instdso.sh SH-LIBTOOL='/usr/lib/httpd/build/libtool'
/home/ekoperda/recipnet/mod_recipnet_auth/mod_recipnet_auth.la
/usr/lib/httpd/modules
sh: line 1: /usr/lib/httpd/build/instdso.sh: No such file or directory
axps:Error: Command failed with rc=8323072.


Expected Results:  The command should have completed without error and
mod_recipnet_auth.so should have been built.

Additional info:

I fixed the problem by extracting instdso.sh from the httpd-2.0.40 sources and
placing the filein /usr/lib/httpd/build on my system.
Comment 1 Joe Orton 2002-10-11 18:48:26 EDT

*** This bug has been marked as a duplicate of 73428 ***

Note You need to log in before you can comment on or make changes to this bug.