Bug 73428 - make install for php4 can't find instdso.sh
make install for php4 can't find instdso.sh
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: httpd (Show other bugs)
8.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Joe Orton
Brian Brock
:
: 75281 75707 75762 78557 81299 83169 84476 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-04 12:29 EDT by berto
Modified: 2007-04-18 12:46 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-09 12:31:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description berto 2002-09-04 12:29:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

Description of problem:
when building php4-STABLE-200209032100 from source, make install failed stating
that it was unable to find the file:

/usr/lib/httpd/build/instdso.sh


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install httpd-2.0.40-1 and httpd-devel-2.0.40-1
2. grab the latest php source
3. configure and try to install
	

Actual Results:  install dies.

Expected Results:  php should have installed fine.

Additional info:

the configure command was:

./configure --with-apxs2=/usr/sbin/apxs --with-mysql=/usr

my simple solution was to get the apache-2.0.40 source and copy that file into
/usr/lib/httpd/build.  that fixed the problem and php
Comment 1 Joe Orton 2002-09-11 16:01:06 EDT
Refiled against 'httpd' package.
Comment 2 Joe Orton 2002-10-07 06:20:10 EDT
*** Bug 75281 has been marked as a duplicate of this bug. ***
Comment 3 Ed Marshall 2002-10-10 16:48:53 EDT
Same problem with Subversion (http://subversion.tigris.org/). Grabbing
instdso.sh from the latest release as suggested and dropping in
/usr/lib/httpd/build worked like a champ.

(Now if only there were supported apr and apr-util packages...*grin*)
Comment 4 Joe Orton 2002-10-11 05:36:28 EDT
*** Bug 75707 has been marked as a duplicate of this bug. ***
Comment 5 Joe Orton 2002-10-11 18:48:18 EDT
*** Bug 75762 has been marked as a duplicate of this bug. ***
Comment 6 Per Winkvist 2002-10-14 13:50:34 EDT
I would like to request this as well. It would be great if  
   - instdso.sh  
   - apr-config 
   - apu-config 
 
these could be part of the httpd-devel package. The last two shell scripts are 
needed to compile subversion.
Comment 7 Nils Philippsen 2002-10-19 11:04:36 EDT
Joe, do you want a SPEC file for this? The Cc: list is getting a bit long :-).
Comment 8 Joe Orton 2002-11-06 13:11:14 EST
Fixed in httpd-2.0.40-13, should hit Raw Hide at some point soon.  Thanks for
the reports.
Comment 9 Joe Orton 2002-11-26 09:02:40 EST
*** Bug 78557 has been marked as a duplicate of this bug. ***
Comment 10 Joe Orton 2003-01-14 08:35:02 EST
*** Bug 81299 has been marked as a duplicate of this bug. ***
Comment 11 Dan Hollis 2003-01-21 19:03:23 EST
this bug still unresolved. we are still waiting for a fixed httpd-devel with
instdso.sh in it.

bug id 81299 says its available in httpd-devel-2.0.40-13 but neglects to tell us
where to get this version.

httpd-devel-2.0.40-11 is still the only currently most recent version available
for rh8.0 ...
Comment 12 Joe Orton 2003-01-22 05:02:31 EST
For testing purposes, you can get them from:
http://people.redhat.com/jorton/8.0-httpd/
Comment 13 Joe Orton 2003-03-31 10:02:34 EST
Reopen for erratum.
Comment 14 Joe Orton 2003-03-31 10:04:34 EST
*** Bug 83169 has been marked as a duplicate of this bug. ***
Comment 15 Joe Orton 2003-04-01 11:14:11 EST
*** Bug 84476 has been marked as a duplicate of this bug. ***
Comment 16 Mark J. Cox (Product Security) 2003-04-09 12:31:41 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHSA-2003-139.html

Note You need to log in before you can comment on or make changes to this bug.