Bug 75803 - vncserver does not respect KDE font selection.
vncserver does not respect KDE font selection.
Status: CLOSED DUPLICATE of bug 72965
Product: Red Hat Linux
Classification: Retired
Component: vnc (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-12 15:56 EDT by Ivo Sarak
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-13 11:26:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Sarak 2002-10-12 15:56:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Fonts used by vncserver is not that what is used under KDE at terminal. 


How reproducible:
Always


Images of this problem:

http://www.vendomar.ee/~ivo/vncviewer_font1.png
http://www.vendomar.ee/~ivo/vncviewer_font2.png

This error applies only to KDE menu fonts:
http://www.vendomar.ee/~ivo/vncviewer_font3.png

Additional infomation:
Somehow this error is related to (one) particular user as vncserver under root
is fine.
Comment 1 Ivo Sarak 2002-10-12 16:58:31 EDT
The same machine locally, not over vnc:
http://www.vendomar.ee/~ivo/localX_font1.png
Comment 2 Tim Waugh 2002-10-13 05:24:26 EDT
Does the same thing happen when the VNC server is run for root, rather than 
for a non-root user?
Comment 3 Ivo Sarak 2002-10-13 11:26:35 EDT
Root is fine:

http://www.vendomar.ee/~ivo/vncviewer_font_root.png

I made a new user and it is fine, too:

http://www.vendomar.ee/~ivo/vncviewer_font_third_user.png

So somehow this problem is with one old user. 

Where does vncserver take the X settings?
Comment 4 Tim Waugh 2002-10-13 11:36:09 EDT

*** This bug has been marked as a duplicate of 72965 ***
Comment 5 Rex Dieter 2003-06-06 10:26:44 EDT
I believe the(a) source of the problem in this case is that vnc/vncserver has no 
notion of the Serif, Mono, Sans fonts, which appear to be fontconfig/Xft-only. 

Note You need to log in before you can comment on or make changes to this bug.