Bug 75807 - No sound with SB Live
No sound with SB Live
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-12 17:12 EDT by MH
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-08 11:45:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description MH 2002-10-12 17:12:01 EDT
Description of Problem:  
  
After performing a clean install of RH 8.0 I lost sound, even though sndconfig  
appears to have correctly identified and loaded the necessary modules for my  
sound card. lsmod generates the following output: 
 
Module                  Size  Used by    Tainted: P 
parport_pc             19108   1  (autoclean) 
lp                      8996   0  (autoclean) 
parport                37152   1  (autoclean) [parport_pc lp] 
emu10k1                68840   0  (autoclean) 
ac97_codec             13384   0  (autoclean) [emu10k1] 
sound                  74228   0  (autoclean) [emu10k1] 
soundcore               6500   7  (autoclean) [emu10k1 sound] 
agpgart                42912   0  (autoclean) 
autofs                 13348   0  (autoclean) (unused) 
nfs                    82660   1  (autoclean) 
lockd                  58096   1  (autoclean) [nfs] 
sunrpc                 79420   1  (autoclean) [nfs lockd] 
3c59x                  30608   1 
mousedev                5524   0 
keybdev                 2976   0  (unused) 
hid                    22244   0  (unused) 
input                   5888   0  [mousedev keybdev hid] 
usb-uhci               26188   0  (unused) 
usbcore                77056   1  [hid usb-uhci] 
aic7xxx               137140   2 
sd_mod                 13552   4 
scsi_mod              107144   2  [aic7xxx sd_mod] 
  
/etc/modules.conf includes the following line: 
 
alias sound-slot-0 emu10k1 
 
as well as related pre-load and post-remove directives 
 
Version-Release number of selected component (if applicable):  
  
  
How Reproducible:  
  
Clean install of RH 8.0 
  
Steps to Reproduce:  
 
1. install RH 8.0   
2.   
3.   
  
Actual Results:  
  
No sound 
 
Expected Results:  
  
Working sound 
  
Additional Information:  
 
Sound card worked just fine under a previous installation of RH 7.2 
 
sndconfig correctly detects the sound card and offers to "test" the sound, but 
when clicking on the test button, no sound is produced.
Comment 1 Arjan van de Ven 2002-10-14 16:27:35 EDT
are you using something like the digital out ?
Comment 2 Jack Neely 2002-11-22 16:25:10 EST
I think I may have duplicated this.  I have a machine that I just installed 8.0
on with a SB Live and a built in Ensoniq ES1371 [AudioPCI-97] (which I've never
gotten to work...hence the SB Live).  I can't get modules for the card to load
and the SB Live does not appear in the output of lspci which I think is most
weird.  Worked fine in 7.3.
Comment 3 Jack Neely 2002-11-22 16:39:55 EST
Sorry...my error.  Definately detect the sound card.  Just get no sound.  Please
disregard.
Comment 4 Kevin Davies 2002-12-22 17:43:48 EST
Have you got a USB webcam attached to your machine? If you disconnect it and 
reboot, does sound work after a modprobe emu10k1?
If so see bug 69945 and bug 77178 for problem descriptions.

Have you tried to load the driver manually? While root, 
type modprobe emu10k1 and then see if sound starts working. 

Regards

Kevin Davies
Comment 5 Kevin Davies 2002-12-22 17:54:50 EST
Also probably related to bug 75015. It looks like kudzu us having a problem 
with USB audio devices and breaks the sound configuration on reboot. This  
includes webcams with an inbuilt microphone.
Comment 6 Alan Cox 2003-06-05 08:14:23 EDT
Closing as here has been no activity following the very sensible comment about
the webcam problem

Note You need to log in before you can comment on or make changes to this bug.