Bug 758417 - duplicate detection broken
duplicate detection broken
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libreport (Show other bugs)
16
Unspecified Unspecified
high Severity urgent
: ---
: ---
Assigned To: Nikola Pajkovsky
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ABRTF18
  Show dependency treegraph
 
Reported: 2011-11-29 14:02 EST by Christoph Wickert
Modified: 2014-02-02 17:16 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-15 05:33:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Wickert 2011-11-29 14:02:34 EST
Description of problem:
abrt's duplicate detect seems to be broken again. I receive a lot of duplicates and I just received two bug reports with an identical hash

Version-Release number of selected component (if applicable):
libreport version: 2.0.7
abrt_version:   2.0.6

How reproducible:
don't know

Steps to Reproduce:
1. don't know.
  
Actual results:
bug 758394 and bug 758395 are the same and have the same hash value of 86477caa0830e4561445305f294dce8678a479e9.

Expected results:
bug 758395 should be detected as a duplicate of bug 758394

Additional info:
Could that be a race condition of clicking the submit button twice?
Comment 1 Christoph Wickert 2011-11-29 14:15:05 EST
Another example: bug 758379 is a duplicate of bug 754585. Both have the same hash and this definitely is no race condition.
Comment 2 Nikola Pajkovsky 2011-11-30 09:16:38 EST
hmm, it starts with bugzilla's update; let's ask bugzilla's guys, because we didn't change the code.

Any ideas what's going on?
Comment 3 Emmanuel Seyman 2011-11-30 12:06:42 EST
I'm pretty sure this is meant to be filed against the Bugzilla product, not the bugzilla component of Fedora.
Comment 4 Christoph Wickert 2011-12-02 08:19:49 EST
Raising priority as this results in tons of duplicate bugs filed every day.

For the record: *Some* older bugs are still correctly identified as dupes, but new ones are not.
Comment 5 Nikola Pajkovsky 2011-12-02 09:46:46 EST
I have fix for that in my local git repo. Maybe push it into stable?
Comment 6 Jiri Moskovcak 2012-08-10 04:02:39 EDT
Do you still experience this bug?
Comment 7 Christoph Wickert 2012-08-13 07:31:11 EDT
Only sometimes, when the code has changed in the mean time. e.g. line numbers are no longer the same but the crash function and the crash itself is still the same.

I guess there is not much we can do about this, so feel free to close this bug. It has already improved a lot.

Note You need to log in before you can comment on or make changes to this bug.