Bug 758506 - [RFE] Upload manifest filename to enhance description
[RFE] Upload manifest filename to enhance description
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: FutureFeature, Triaged
: 852408 (view as bug list)
Depends On:
Blocks: sam21-tracker
  Show dependency treegraph
 
Reported: 2011-11-29 17:48 EST by scollier
Modified: 2016-12-12 09:19 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-12 09:19:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description scollier 2011-11-29 17:48:58 EST
Description of problem:

Need to be able to see the name of the manifest file that was uploaded in System Engine.  


Version-Release number of selected component (if applicable):

Red Hat Enterprise Linux Server release 6.1 (Santiago)
Linux cf-se2.cloud.lab.eng.bos.redhat.com 2.6.32-131.17.1.el6.x86_64 #1 SMP Thu Sep 29 10:24:25 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux
PyYAML-3.09-14.el6_1.x86_64
facter-1.5.9-1.el6.noarch
js-1.70-12.el6_0.x86_64
mongodb-1.6.4-3.el6_0.x86_64
mongodb-server-1.6.4-3.el6_0.x86_64
puppet-2.6.11-1.el6_1.noarch
pymongo-1.9-8.el6_1.x86_64
katello-0.1.111-2.el6.x86_64
katello-all-0.1.111-2.el6.x86_64
katello-cli-0.1.13-1.el6.noarch
katello-configure-0.1.16-2.el6.noarch


How reproducible:

Every time.

Steps to Reproduce:
1.  Click on "providers"
2.  Choose "Red Hat"
3.  Click on "Import History" link
4.  Click on "import history" tab

  
Actual results:

Gives generic output of:

OrgName file imported successfully

Expected results:

Filename of manifest.

Additional info:

Filing this on request of -- Mike McCune
Comment 1 Pavel Pokorny 2012-09-06 04:37:24 EDT
This cannot be done in Katello itself. History is loaded from Candlepin and it looks like there is no way how to modify the message. We can store import history also in Katello database but does it worth it?

Additional info:
http://candlepinproject.org/apidoc/post/owners/owner_key/imports/
http://candlepinproject.org/apidoc/get/owners/owner_key/imports/
Comment 3 Bryan Kearney 2012-12-13 16:00:07 EST
The API exists in candlepin now. I am moving this back to katello side of the house for implementation.
Comment 4 Bryan Kearney 2012-12-13 16:02:06 EST
The API exists in candlepin now. I am moving this back to katello side of the house for implementation.
Comment 5 Tom McKay 2012-12-18 08:45:37 EST
Moving to CFSE as shared feature
Comment 8 Bryan Kearney 2014-05-22 12:54:45 EDT
*** Bug 852408 has been marked as a duplicate of this bug. ***
Comment 9 Bryan Kearney 2016-07-08 16:40:57 EDT
Per 6.3 planning, moving out non acked bugs to the backlog
Comment 11 Tom McKay 2016-12-12 09:19:35 EST
This would be nice to have but there is a disconnect between what the browser knows about the file and what the server should be saving. The most reliable thing for logging/audit is the information that is currently shown (link to the customer portal and the source of the manifest).

Note You need to log in before you can comment on or make changes to this bug.