Bug 75860 - PC won't poweroff when told to.
PC won't poweroff when told to.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-14 01:25 EDT by Brad
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:40:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad 2002-10-14 01:25:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
I have 2 PCs with Athlon motherboards. One is an Epox 8KHA/+ and the other is an
MSI KT3Ultra2 and neither of them will power off from the GUI or the poweroff
command. They just reboot. I have a third PC with an Intel CPU and it powers off
fine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Type "poweroff" from CIF or click RedHat-Logout-Shutdown
2.
3.
	

Actual Results:  The PC shutdown normally and rebooted itself.

Expected Results:  It should have shut down and the power should have gone off.

Additional info:
Comment 1 Arjan van de Ven 2002-10-14 04:11:01 EDT
are these smp motherboards ?
Comment 2 Brad 2002-10-14 22:13:28 EDT
They are just single CPU workstation motherboards.

Epox 8KHA+:
http://www.epox.com/html/motherboard.asp?product=EP-8KHAplus&lang=1

MSI KT3 Ultra2 MS-6380E:
http://www.msi.com.tw/program/products/mainboard/mbd/pro_mbd_detail.php?UID=341&MODEL=MS-6380E
Comment 3 manuel wolfshant 2002-12-14 12:53:21 EST
Same thing happens to me, for a long time. My system uses am Acorp 7VIA71A
motherboard
Here is the output of lspci:
00:00.0 Host bridge: VIA Technologies, Inc. VT8371 [KX133] (rev 02)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8371 [KX133 AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 22)
00:07.1 IDE interface: VIA Technologies, Inc. VT82C586B PIPC Bus Master IDE (rev 10)
00:07.2 USB Controller: VIA Technologies, Inc. USB (rev 10)
00:07.3 USB Controller: VIA Technologies, Inc. USB (rev 10)
00:07.4 Bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 30)
00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97 Audio
Controller (rev 20)
The kernel is the version 2.4.18-18.8.0 (bhcompile@sylvester.devel.redhat.com)
(gcc version 3.2 20020903 (Red Hat Linux 8.0 3.2-7)) #1 Wed Nov 13 22:52:09 EST
2002 (athlon optimised version)
Comment 4 Brad 2003-05-06 00:33:57 EDT
I have now upgraded to Red hat 9 on both PCs and it is still the same. My
hardware hasn't changed and it seems that it hasn't been fixed in 9 yet.
Comment 5 Brad 2003-05-06 00:35:03 EDT
I should explain that both were new 9 installations, and not just upgrades.
Comment 6 Alan Cox 2003-06-05 08:17:35 EDT
Poweroff from Linux depends on the system having working APM poweroff support.
Many systems do but far from all support APM poweroff as well as reboot.

I'm closing this as WONTFIX since its really not related to the kernel but the
BIOS features available. Quite a few more boards will do poweroff properly with
ACPI as and when we decide ACPI is ready to ship
Comment 7 Brad 2003-06-10 02:17:15 EDT
I find your conclusion astounding. I have tried Win95, 98 and 2K on BOTH of the
motherboards in question and they ALL power off with no problems. I have had RH8
and now RH9 on both of them and it has NEVER powered off.

And you say that this is not a Linux issue, but a hardware/BIOS issue? I don't
think that Microsoft will agree with you.

I am trying to get Linux into my workplace. How will it look if half of the PCs
(AMDs) won't power off, and they are the ones running Linux?

If you say that ACPI will solve the problem, when will it be available?
Comment 8 Alan Cox 2003-06-10 11:17:50 EDT
ACPI is something we are still looking at for stability. It is certainly getting
close to being shippable.  There are third party Red Hat kernel rpms around with
ACPI if you want to verify whether ACPI fixes your board

http://www.cas.mcmaster.ca/~pavlidmh/Linux_on_a_Presario_900.html

has one.

Comment 9 aaron weber 2003-10-17 11:19:01 EDT
This may be a duplicate of 81514.

My PC (Dell Dimension, Pentium 4 2.2GHz, totally standard, default workstation
RH 9 install) gets as far as the "Power Down" message and then fails to turn
off. I have to press and hold the power button to get it to turn off.  

The system reboots correctly and when booted into Windows XP it powers down
correctly.
Comment 10 John I Wang 2004-03-24 17:39:32 EST
I was able to get RedHat 7.2 with a kernel.org 2.4.20 kernel to shut
down a PowerEdge 2650 by configuring ACPI support but I can't seem to
do it on RedHat 9.0 with RedHat's 2.4.20-8 kernel.
Comment 11 John I Wang 2004-03-24 18:03:22 EST
I've been browsing about bugzilla.   Looks like this is another
duplicate of bug 80360.   Basically the ACPI feature has been broke
since 2.4.20-2.2.   That would explain why my 2.4.20 kernels work fine
but the 2.4.20-8 kernel.
Comment 12 Bugzilla owner 2004-09-30 11:40:04 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.