Bug 80360 - 2.4.20-2.2 ACPI no longer powers down
2.4.20-2.2 ACPI no longer powers down
Status: CLOSED DUPLICATE of bug 82123
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
: 80513 80655 (view as bug list)
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2002-12-24 17:57 EST by Warren Togami
Modified: 2013-07-02 22:08 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-21 08:07:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of acpidmp on Nec Powermate Pentium IV system (65.69 KB, application/octet-stream)
2002-12-28 17:17 EST, Peter van Egdom
no flags Details
Output of dmidecode on Nec Powermate Pentium IV system (5.85 KB, text/plain)
2002-12-28 17:19 EST, Peter van Egdom
no flags Details
Output of acpidmp on Nec Powermate Pentium IV (65.69 KB, text/plain)
2002-12-28 17:21 EST, Peter van Egdom
no flags Details
output of dmidecode on asus k7m (athlon 600) (6.17 KB, text/plain)
2002-12-31 05:55 EST, Hans de Goede
no flags Details
output of acpidmp on asus k7m (athlon 600 desktop) (39.66 KB, text/plain)
2002-12-31 05:57 EST, Hans de Goede
no flags Details
Output of acpidmp on Aopen AK77-333 (61.63 KB, text/plain)
2003-01-01 10:36 EST, Ivo Sarak
no flags Details
Output of dmidecode on Aopen AK77-333 (5.36 KB, text/plain)
2003-01-01 10:38 EST, Ivo Sarak
no flags Details
acpidmp on Asus A7V8X (48.27 KB, text/plain)
2003-01-04 17:02 EST, Ivo Sarak
no flags Details
dmidecode on Asus A7V8X. (7.78 KB, text/plain)
2003-01-04 17:03 EST, Ivo Sarak
no flags Details
dmidecode output from i815 based computer (9.66 KB, text/plain)
2003-01-09 05:34 EST, Mattias Dahlberg
no flags Details
Output of acpidmp on IBM T21 (185.22 KB, text/plain)
2003-01-09 05:58 EST, Panu Matilainen
no flags Details
Output of dmidecode on IBM T21 (6.24 KB, text/plain)
2003-01-09 05:59 EST, Panu Matilainen
no flags Details

  None (edit)
Description Warren Togami 2002-12-24 17:57:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
Sony Vaio FXA-36 laptop
Athlon Palomino 1GHz
512MB SDRAM
VIA KT133A chipset

poweroff no longer turns off my laptop automatically.  All previous APM kernels
from Red Hat did successfully, as does http://sourceforge.net/projects/acpi
patch against 2.4.x and 2.5.x.

Version-Release number of selected component (if applicable):
Phoebe
Comment 1 Warren Togami 2002-12-27 19:46:17 EST
Several other systems including Pentium3 no longer power down with this ACPI.
Comment 2 Elton Woo 2002-12-28 16:37:15 EST
I concur that this problem also occurs on my system:
Motherboard:ASUS ATX A7V-E/Chipset:KT133
Award BIOS, Rev. 1004
CPU: Athlon Thunderbird 1.0G
System Memory: 512Mb / PC-133 DIMM

I can only shut off the machine by powering off from the power-bar,
not by holding the power switch on the box.
Comment 3 Peter van Egdom 2002-12-28 17:15:57 EST
I'm experiencing described ACPI problems too. Here's some output from dmesg.

[peterve@powermate tmp]$ dmesg |grep -i acpi
 BIOS-e820: 000000001fff0000 - 000000001fff8000 (ACPI data)
 BIOS-e820: 000000001fff8000 - 0000000020000000 (ACPI NVS)
ACPI: Core Subsystem version [20021205]
    ACPI-0263: *** Info: GPE Block0 defined as GPE0 to GPE15
    ACPI-0263: *** Info: GPE Block1 defined as GPE16 to GPE31
ACPI: Subsystem enabled
apm: overridden by ACPI.
[peterve@powermate tmp]$

I'll attach the output of "acpidmp" and "dmidecode" on my system to this bugzilla.
Comment 4 Peter van Egdom 2002-12-28 17:17:09 EST
Created attachment 88969 [details]
Output of acpidmp on Nec Powermate Pentium IV system
Comment 5 Peter van Egdom 2002-12-28 17:19:27 EST
Created attachment 88970 [details]
Output of dmidecode on Nec Powermate Pentium IV system

(previous attachment is a plain text file, auto-detect incorrectly interpreted
as binary...)
Comment 6 Peter van Egdom 2002-12-28 17:21:18 EST
Created attachment 88971 [details]
Output of acpidmp on Nec Powermate Pentium IV

this time uploaded as plain text.
Comment 7 Nathan G. Grennan 2002-12-28 22:51:43 EST
I see this problem on my home-built computer with MSI KT3-Ultra2 motherboard and
Athlon XP 1700+ processor.
Comment 8 Marius Andreiana 2002-12-29 07:39:21 EST
*** Bug 80513 has been marked as a duplicate of this bug. ***
Comment 9 Panu Matilainen 2002-12-29 09:55:36 EST
The same happens also on IBM T21 laptop - other kernels happily powered it off 
but not with Phoebe kernel.
Comment 10 Hans de Goede 2002-12-30 07:07:18 EST
*** Bug 80655 has been marked as a duplicate of this bug. ***
Comment 11 Hans de Goede 2002-12-30 07:09:47 EST
Same for me,  athlon 600 desktop with an asus irongate chipset slot a mb. I'll
attach a dmidecode and acpidmp for this system too.
Comment 12 Hans de Goede 2002-12-30 07:10:44 EST
Question where do I find dmidecode and acpidmp?
Comment 13 Peter van Egdom 2002-12-30 14:34:19 EST
/usr/sbin/acpidmp
/usr/sbin/dmidecode

Both members of package "kernel-utils-2.4-8.20"
Comment 14 Hans de Goede 2002-12-31 05:55:57 EST
Created attachment 88999 [details]
output of dmidecode on asus k7m (athlon 600)
Comment 15 Hans de Goede 2002-12-31 05:57:03 EST
Created attachment 89000 [details]
output of acpidmp on asus k7m (athlon 600 desktop)
Comment 16 Ivo Sarak 2003-01-01 10:36:41 EST
Created attachment 89031 [details]
Output of acpidmp on Aopen AK77-333

System with the same problem.
Comment 17 Ivo Sarak 2003-01-01 10:38:13 EST
Created attachment 89032 [details]
Output of dmidecode on Aopen AK77-333

System with the same problem.
Comment 18 Ivo Sarak 2003-01-04 17:02:57 EST
Created attachment 89132 [details]
acpidmp on Asus A7V8X

Same problem here.
Does any platform power down with this kernel?
Comment 19 Ivo Sarak 2003-01-04 17:03:41 EST
Created attachment 89133 [details]
dmidecode on Asus A7V8X.

Same problem here.
Does any platform power down with this kernel?
Comment 20 Mattias Dahlberg 2003-01-09 05:34:50 EST
Created attachment 89230 [details]
dmidecode output from i815 based computer

Dell Optiplex GX150 (Intel 815 chipset, Pentium 3 on 1GHz) doesn't power down.
Attached is the dmidecode output, as requested.
Comment 21 Panu Matilainen 2003-01-09 05:58:11 EST
Created attachment 89232 [details]
Output of acpidmp on IBM T21
Comment 22 Panu Matilainen 2003-01-09 05:59:41 EST
Created attachment 89233 [details]
Output of dmidecode on IBM T21
Comment 23 Jack Stewart 2003-01-09 12:30:25 EST
I also have the same problem (system does not power down).
Motherboard: PCChips 533 M922LU System with 1.8Ghz Celeron Chip and VIA P4X333 
& VT8235 chipsets.
It has the AMI BIOS with ACPI revision 1.0.
On the plus side, the upgrade fixed my problem with the VT8235 audio chipset.
(I have not included the acpidmp or dmidecode but will do so if someone thinks 
it will be useful)
Comment 24 Nathan G. Grennan 2003-01-10 15:51:01 EST
This problem is fixed for me with 2.4.20-2.9.
Comment 25 Panu Matilainen 2003-01-12 10:51:31 EST
IBM T21 also now powers off as it should (2.4.20-2.11 tested) - thanks!
Comment 26 Panu Matilainen 2003-01-12 12:33:20 EST
..except it's not because ACPI was fixed - the is no more ACPI at all. Oh well...
Comment 27 Jack Stewart 2003-01-12 20:46:13 EST
kernel 2.4.20-2.11 fixes the shutdown issue for me as well (along with a USB printing isue that cropped up under 2.4.20-2 ...)  
Comment 28 Jeff Garzik 2003-01-17 16:11:14 EST

*** This bug has been marked as a duplicate of 82123 ***

Note You need to log in before you can comment on or make changes to this bug.