Bug 758689 - remove workaround for zfs-fuse service
Summary: remove workaround for zfs-fuse service
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-node
Version: unspecified
Hardware: All
OS: All
medium
medium
Target Milestone: ---
: ---
Assignee: Mike Burns
QA Contact:
URL:
Whiteboard:
Depends On: 755464 757818
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-30 13:04 UTC by Mike Burns
Modified: 2016-04-26 15:52 UTC (History)
8 users (show)

Fixed In Version: 2.4.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 757818
Environment:
Last Closed: 2012-06-14 13:35:41 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Mike Burns 2011-11-30 13:04:35 UTC
+++ This bug was initially created as a clone of Bug #757818 +++

Description of problem:

Remove the workaround for zfs-fuse service being started in %post once that BZ is fixed.

--- Additional comment from mburns on 2011-11-28 17:21:50 EST ---

This is caused by zfs-fuse starting it's service in %post.  There are 2 possible fixes:

1.  blacklist zfs-fuse from the node
2.  manually kill the service in %post of the image build

zfs-fuse is required by:  libguestfs-1:1.14.2-1.fc16.x86_64


--- Additional comment from mburns on 2011-11-28 17:25:27 EST ---

Temporary workaround:

Apply the following, then rerun build starting with autogen.sh


diff --git a/recipe/ovirt-node-image.ks.in b/recipe/ovirt-node-image.ks.in
index a24275c..b3d69a8 100644
--- a/recipe/ovirt-node-image.ks.in
+++ b/recipe/ovirt-node-image.ks.in
@@ -25,3 +25,6 @@

 %include common-manifest.ks

+%post
+/sbin/service zfs-fuse stop
+%end

--- Additional comment from mburns on 2011-11-30 07:58:27 EST ---

Given the chance of a guest using ZFS, we should probably leave zfs-fuse on the node.  I'll apply the above workaround and file a separate bz to remove the workaround once zfs-fuse gets fixed.

--- Additional comment from mburns on 2011-11-30 08:01:23 EST ---

http://gerrit.ovirt.org/446

Comment 1 Mike Burns 2011-12-02 16:03:52 UTC
Moving to 2.3.0. 

zfs-fuse is currently in a transition between maintainers, so highly unlikely the related bz will be fixed before we release 2.2.0

Comment 2 Mike Burns 2012-05-23 22:08:24 UTC
http://gerrit.ovirt.org/4719


Note You need to log in before you can comment on or make changes to this bug.