Bug 758823 - cman and corosync RRP handling are not consistent and needs improvements
cman and corosync RRP handling are not consistent and needs improvements
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ricci (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: 6.3
Assigned To: Chris Feist
Cluster QE
:
Depends On: 722469 733298 735911 738390
Blocks: 758821
  Show dependency treegraph
 
Reported: 2011-11-30 14:04 EST by Fabio Massimo Di Nitto
Modified: 2016-04-26 09:42 EDT (History)
11 users (show)

See Also:
Fixed In Version: ricci-0.16.2-53.el6
Doc Type: Bug Fix
Doc Text:
Cause: ccs has no way of configuring RRP Consequence: User can't configure RRP with ccs Fix: options are now available in ccs to configure RRP Result: User can now configure RRP with ccs
Story Points: ---
Clone Of: 733298
Environment:
Last Closed: 2012-06-20 10:14:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Fabio Massimo Di Nitto 2011-11-30 14:05:36 EST
The relevant bits for ccs are in comment#3 unit test 4.
Comment 8 Chris Feist 2012-02-29 19:29:11 EST
With ricci-0.16.2-53.el6:


[root@ask-04 ~]# ccs -f testfile --createcluster blah
[root@ask-04 ~]# ccs -i -f testfile --setmulticast 1.1.1.1 port=555
[root@ask-04 ~]# ccs -i -f testfile --setaltmulticast 2.2.2.2 port=777
[root@ask-04 ~]# ccs -i -f testfile --addnode node1
Node node1 added.
[root@ask-04 ~]# ccs -i -f testfile --addnode node2
Node node2 added.
[root@ask-04 ~]# ccs -i -f testfile --addalt node1 myalt  port=888
[root@ask-04 ~]# ccs -i -f testfile --addalt node2 myalt2 port=8888
[root@ask-04 ~]# cat testfile
<cluster config_version="7" name="blah">
  <fence_daemon/>
  <clusternodes>
    <clusternode name="node1" nodeid="1">
      <altname name="myalt" port="888"/>
    </clusternode>
    <clusternode name="node2" nodeid="2">
      <altname name="myalt2" port="8888"/>
    </clusternode>
  </clusternodes>
  <cman>
    <multicast addr="1.1.1.1" port="555"/>
    <altmulticast addr="2.2.2.2" port="777"/>
  </cman>
  <fencedevices/>
  <rm>
    <failoverdomains/>
    <resources/>
  </rm>
</cluster>

multicast, altmulticast & individual cluster node altname's have been added.


[root@ask-04 ~]# ccs -i -f testfile --rmalt node2
[root@ask-04 ~]# ccs -i -f testfile --setmulticast
[root@ask-04 ~]# ccs -i -f testfile --setaltmulticast
[root@ask-04 ~]# cat testfile
<cluster config_version="10" name="blah">
  <fence_daemon/>
  <clusternodes>
    <clusternode name="node1" nodeid="1">
      <altname name="myalt" port="888"/>
    </clusternode>
    <clusternode name="node2" nodeid="2">
    </clusternode>
  </clusternodes>
  <cman>
  </cman>
  <fencedevices/>
  <rm>
    <failoverdomains/>
    <resources/>
  </rm>
</cluster>

multicast, altmulticast and node2 altname have been removed.
Comment 10 Chris Feist 2012-03-15 15:57:26 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: ccs has no way of configuring RRP

Consequence: User can't configure RRP with ccs

Fix: options are now available in ccs to configure RRP

Result: User can now configure RRP with ccs
Comment 13 errata-xmlrpc 2012-06-20 10:14:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0898.html

Note You need to log in before you can comment on or make changes to this bug.