This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 759035 - imsm: fix: correct checking newly missing disks
imsm: fix: correct checking newly missing disks
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jes Sorensen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 759036 759037
  Show dependency treegraph
 
Reported: 2011-12-01 05:02 EST by Jes Sorensen
Modified: 2012-05-04 12:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 759036 759037 (view as bug list)
Environment:
Last Closed: 2012-05-04 12:11:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jes Sorensen 2011-12-01 05:02:01 EST
commit a510b1c7f07ba750979ba2f213ebe261bcfc4de4
Author: Lukasz Dorau <lukasz.dorau@intel.com>
Date:   Mon Nov 14 15:52:52 2011 +0100

    imsm: fix: correct checking newly missing disks
    
    The problem occurs when RAID10 array under rebuild
    (after one disk fails) is assembled incrementally.
    Mdadm tries to start array just after adding the third disk
    and the volume is assembled incorrectly (in degraded state).
    
    The cause is that container_enough depends on
    newly missing disks which are checked incorrectly now.
    They should be checked using always the first map.
    
    Signed-off-by: Lukasz Dorau <lukasz.dorau@intel.com>
    Signed-off-by: NeilBrown <neilb@suse.de>
Comment 1 Jes Sorensen 2012-01-05 08:37:22 EST
Fix included in mdadm-3.2.3

Note You need to log in before you can comment on or make changes to this bug.