Bug 759037 - imsm: fix: correct checking newly missing disks
imsm: fix: correct checking newly missing disks
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jes Sorensen
Fedora Extras Quality Assurance
:
Depends On: 759035
Blocks: 759036
  Show dependency treegraph
 
Reported: 2011-12-01 05:04 EST by Jes Sorensen
Modified: 2012-01-30 15:53 EST (History)
4 users (show)

See Also:
Fixed In Version: mdadm-3.2.3-3.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 759035
Environment:
Last Closed: 2012-01-30 15:53:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jes Sorensen 2011-12-01 05:04:24 EST
+++ This bug was initially created as a clone of Bug #759035 +++

commit a510b1c7f07ba750979ba2f213ebe261bcfc4de4
Author: Lukasz Dorau <lukasz.dorau@intel.com>
Date:   Mon Nov 14 15:52:52 2011 +0100

    imsm: fix: correct checking newly missing disks
    
    The problem occurs when RAID10 array under rebuild
    (after one disk fails) is assembled incrementally.
    Mdadm tries to start array just after adding the third disk
    and the volume is assembled incorrectly (in degraded state).
    
    The cause is that container_enough depends on
    newly missing disks which are checked incorrectly now.
    They should be checked using always the first map.
    
    Signed-off-by: Lukasz Dorau <lukasz.dorau@intel.com>
    Signed-off-by: NeilBrown <neilb@suse.de>
Comment 1 Fedora Update System 2012-01-12 08:44:05 EST
mdadm-3.2.3-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mdadm-3.2.3-3.fc15
Comment 2 Fedora Update System 2012-01-13 23:00:01 EST
Package mdadm-3.2.3-3.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mdadm-3.2.3-3.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0433/mdadm-3.2.3-3.fc15
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-01-30 15:53:58 EST
mdadm-3.2.3-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.