Bug 759128 - left alt key not passed to application
Summary: left alt key not passed to application
Status: CLOSED DUPLICATE of bug 626792
Alias: None
Product: Fedora
Classification: Fedora
Component: vte
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-01 13:31 UTC by Thomas Moschny
Modified: 2011-12-02 09:09 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-12-02 09:09:41 UTC


Attachments (Terms of Use)

Description Thomas Moschny 2011-12-01 13:31:10 UTC
Description of problem:
I am using irssi in a xfce Terminal. Before the last gtk2 update, it was possible to switch windows in irssi using alt+number or alt+left or alt-right. This stopped working, and alt+number simply prints the number.

Version-Release number of selected component (if applicable):
gtk2-2.24.8-2.fc16.x86_64
Terminal-0.4.8-1.fc16.x86_64
irssi-0.8.15-6.fc16.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. in xfce, start Terminal
2. start irssi
3. /connect to some server, /join a channel
4. press alt+1, alt+2
  
Actual results:
Numbers are printed literally.

Expected results:
irssi should toggle between the two windows.

Additional info:
See also https://bugs.archlinux.org/task/26862 . The issue is most likely caused by this commit: http://mail.gnome.org/archives/gtk-devel-list/2011-October/msg00089.html

Comment 1 Thomas Moschny 2011-12-01 14:02:34 UTC
Could be this should be reassigned to vte and fixed there.

Comment 2 Thomas Moschny 2011-12-01 18:49:54 UTC
See also this bug: https://bugzilla.gnome.org/show_bug.cgi?id=663779 , changing component to vte.

Comment 3 Thomas Moschny 2011-12-01 19:10:32 UTC
The (second, revised) patch mentioned in that gnome bug applies cleanly to vte and solves the problem for me.

Comment 4 Jason Farrell 2011-12-02 06:02:28 UTC
I dearly missed my alt-d keycombo after my last boot, and arrived here, and here: bug 626792

I've downgraded gtk for now (though that might not work; I haven't restarted X yet to check)

Comment 5 Thomas Moschny 2011-12-02 09:09:41 UTC

*** This bug has been marked as a duplicate of bug 626792 ***


Note You need to log in before you can comment on or make changes to this bug.