Bug 626792 - "alt" key not passed to programs running in terminal
Summary: "alt" key not passed to programs running in terminal
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
(Show other bugs)
Version: 16
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
: 757795 759128 759471 759522 760605 766132 (view as bug list)
Depends On:
Blocks: 766607 767769
TreeView+ depends on / blocked
 
Reported: 2010-08-24 12:46 UTC by Jeff Layton
Modified: 2014-06-18 07:40 UTC (History)
40 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 766607 767766 767767 (view as bug list)
Environment:
Last Closed: 2012-01-12 20:22:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 649098 None None None Never
GNOME Bugzilla 663779 None None None Never
Launchpad 890555 None None None Never

Description Jeff Layton 2010-08-24 12:46:01 UTC
Opening against gnome-terminal since I'm not sure what actually broke this...

"Alt + numberkey" combinations no longer seem to work in gnome-terminal. Usually when you run gnome-terminal with bash, hitting alt + 1 will give you output like this:

(arg: 1) 

...as of a recent yum update, it just prints out '1'. The alt key seems to be ignored. This breaks a number of apps running within gnome-terminal.

Comment 1 Zdenek Kabelac 2010-08-24 15:04:46 UTC
Not just Alt+number - by any other key as well...

This makes usage of text editors or 'mc' quite painful in gnome-terminal.
Xterm works normally.

In fact it's a bug of 'vte' package vte-0.25.90-1.fc15.

Revert to version: 

vte-0.25.1-2.fc14.x86_64
gnome-terminal-2.31.3-1.fc14.x86_64

Fixes issue for this moment.

Comment 2 Behdad Esfahbod 2010-08-24 19:12:20 UTC
Should be fixed in the updates, or will be fixed soon.  Already fixed upstream.  There's a dup bug around.

Comment 3 Jeff Layton 2010-08-24 23:15:35 UTC
Confirmed... I don't see a newer vte package in koji, but downgrading vte fixed the issue.

Changing to a vte bug.

Comment 4 Jeff Layton 2010-08-30 13:09:51 UTC
Still no fixed package in koji. Can you push out an update for this soon? It makes gnome-terminal essentially useless.

Comment 5 Jeff Layton 2010-09-01 11:53:21 UTC
Seems to be fixed as of this morning's update (vte-0.25.91-1.fc14.x86_64)

Comment 6 Zdenek Kabelac 2010-09-24 10:56:31 UTC
Why is this bugzilla still open?

Comment 7 Jeff Layton 2010-09-24 11:17:10 UTC
Good question. It has been fixed for some time.

Comment 8 Tomas Mraz 2011-06-24 13:31:36 UTC
I've upgraded with preupgrade from Fedora 13 to Fedora 14 recently. With the current vte-0.26.1-1.fc14 I can still reproduce this bug 100% times.

I have to downgrade to vte-0.25.1-2.fc14 for fix.

Comment 9 Ville-Pekka Vainio 2011-11-26 20:18:08 UTC
I am seeing a bug like this right now on Fedora 16 using:

gnome-terminal-3.2.1-2.fc16.x86_64
gtk3-3.2.2-1.fc16.x86_64
gtk3-3.2.2-1.fc16.i686
vte-0.28.1-1.fc16.x86_64
vte3-0.30.1-2.fc16.x86_64

I found similar bugs with Google:
Upstream: https://bugzilla.gnome.org/show_bug.cgi?id=663779
Ubuntu: https://bugs.launchpad.net/ubuntu/+source/vte/+bug/890555

Comment 10 Florent Le Coz 2011-11-27 03:50:14 UTC
Happens to me too.
That bug was previously fixed long time ago, and it’s now broken again, in vte3 I think.

Comment 11 Aron Griffis 2011-11-28 02:48:47 UTC
Seeing this on F16 in g-t (vte3) and roxterm (vte)

vte-0.28.2-1.fc16.x86_64
vte3-0.30.1-2.fc16.x86_64

Comment 12 J.H.M. Dassen (Ray) 2011-11-28 09:02:44 UTC
I'm seeing this since updating to vte-0.28.2-1.fc16 (vte3 was updated to vte3-0.30.1-2.fc16 two weeks earlier without adverse effects). This is quite unfortunate, as this makes it less easy to use irssi effectively.

Comment 13 Bobby Powers 2011-11-28 09:10:03 UTC
esh, I'm also seeing this now in f16 on updates-testing:

vte3-0.30.1-2.fc16.x86_64
vte-0.28.2-1.fc16.x86_64

As JHM mentioned, it seems like the vte update (rather than vte3) is the culprit

Comment 14 Bobby Powers 2011-11-28 09:16:52 UTC
well, downgrading vte to 0.28.1 didn't seem to fix it, and gnome-terminal uses vte3 anyway:


[bpowers@fina ~]$ cat /proc/**/maps | grep vte
3f6d000000-3f6d09b000 r-xp 00000000 fd:00 3708245                        /usr/lib64/libvte2_90.so.9.3000.1
3f6d09b000-3f6d29b000 ---p 0009b000 fd:00 3708245                        /usr/lib64/libvte2_90.so.9.3000.1
3f6d29b000-3f6d29d000 r--p 0009b000 fd:00 3708245                        /usr/lib64/libvte2_90.so.9.3000.1
3f6d29d000-3f6d2a1000 rw-p 0009d000 fd:00 3708245                        /usr/lib64/libvte2_90.so.9.3000.1
7fe7a7e84000-7fe7a7e85000 r--p 00000000 fd:00 5638469                    /usr/share/vte/termcap-2.90/xterm

so I don't think that was the issue.  I'm at a bit of a loss on this one.

Comment 15 Bobby Powers 2011-11-28 09:24:17 UTC
through process of elimination, it seems that gtk3 is the cause of the breakage: https://admin.fedoraproject.org/updates/FEDORA-2011-16356/gtk3-3.2.2-1.fc16 (downgrading gtk3 to 3.2.1-1 enabled me to use the 'alt' key again).

Comment 16 Bobby Powers 2011-11-28 09:32:35 UTC
its most likely fallout from this commit: http://git.gnome.org/browse/gtk+/commit/?h=gtk-3-2&id=273283db9217960970810e90ef841f685231484a

Comment 17 Dave Jones 2011-11-28 17:48:29 UTC
*** Bug 757795 has been marked as a duplicate of this bug. ***

Comment 18 Dave Jones 2011-11-28 17:57:43 UTC
fwiw, I still see this even after downgrading to gtk3-3.2.1-1.fc16.x86_64

Comment 19 Chuck Ebbert 2011-11-28 18:07:38 UTC
The other Alt key (Alt Gr, on the right of the spacebar) seems to work for me.

Comment 20 Thomas Moschny 2011-12-02 09:08:56 UTC
For vte there's a patch available in https://bugzilla.gnome.org/show_bug.cgi?id=663779 .

For testing purposes, I've build a vte package with this patch applied, see
  http://thm.fedorapeople.org/vte/

This makes irssi in xfce's Terminal work for me again.

Comment 21 Thomas Moschny 2011-12-02 09:09:41 UTC
*** Bug 759128 has been marked as a duplicate of this bug. ***

Comment 22 Felipe Contreras 2011-12-03 01:14:16 UTC
(In reply to comment #20)
> For testing purposes, I've build a vte package with this patch applied, see
>   http://thm.fedorapeople.org/vte/
> 
> This makes irssi in xfce's Terminal work for me again.

I confirm this fixes the issue for me.

Comment 23 Jason Farrell 2011-12-03 01:50:02 UTC
I can't live without alt-d for forward-word-delete in bash.

"yum downgrade gtk2 gtk2-immodule-xim" restored my precious alt-d for now. Will be --excluding gtk2\* updates until I see an update with the fix.

Comment 24 Christoph Wickert 2011-12-03 15:22:37 UTC
There seems a bit of confusion, so allow me to summarize:
1. We are facing two different bugs although the symptoms are the same. The bug one from 2010 and F14 is not what we are facing now in F16.
2. The old bug should be fixed.
3. The nex bug was introduced by the gtk2-2.24.8-2.fc16 update, or to be more precise by this commit: http://git.gnome.org/browse/vte/commit/?id=b73782a28894e25ed146271f9d6c6775a6836199
4. The commit makes sense but requires a change in vte, too. There is a bug for this open at https://bugzilla.gnome.org/show_bug.cgi?id=663779
5. There is a patch available at https://bugzilla.gnome.org/attachment.cgi?id=201649 and it is confirmed to fix the issue.
6. As this bug affects all vte based terminals (Xfce's terminal, lilyterm, sakura, termit) we need a fix ASAP.

Comment 25 Felipe Contreras 2011-12-03 15:36:45 UTC
(In reply to comment #24)

> 3. The nex bug was introduced by the gtk2-2.24.8-2.fc16 update, or to be more
> precise by this commit:
> http://git.gnome.org/browse/vte/commit/?id=b73782a28894e25ed146271f9d6c6775a6836199

Is this really a good change? I see Xfce now gets confused about key sequences such as ctrl+alt+del becomes primary+alt+del.

I'd say this change wasn't carefully tested and should be reverted.

Comment 26 Dominic Hopf 2011-12-03 16:19:28 UTC
*** Bug 759522 has been marked as a duplicate of this bug. ***

Comment 27 Kevin Fenzi 2011-12-06 16:47:36 UTC
*** Bug 760605 has been marked as a duplicate of this bug. ***

Comment 28 Dave Jones 2011-12-08 16:33:01 UTC
Thomas's rpm's in comment 20 have been working fine for me for the last week with no noticable side-effects.

Comment 29 Christoph Wickert 2011-12-10 16:27:09 UTC
*** Bug 766132 has been marked as a duplicate of this bug. ***

Comment 30 Jaroslav Škarvada 2011-12-12 09:47:11 UTC
After last update (probably gtk3), I am getting same behaviour in gnome-terminal which worked previously fine. Xterm still works for me.

Comment 31 Stéphane Raimbault 2011-12-12 11:09:23 UTC
Yes, me too, may be it's related to:

https://bugzilla.gnome.org/show_bug.cgi?id=663856

Comment 32 Thorsten Leemhuis 2011-12-12 11:11:03 UTC
This bug imho is a nice example why bugzilla sometimes is a misleading and confusing tool. We *afaics* talk about one or two bugs in two different places:

- one seems in vte -- the responsible component marked in buzilla since a few days. I assume it can be worked around with the packages from thm (see comment #20)

- one seems to be in the stack that gnome-termial depends on -- that was the assigned component earlier [ and this is why I'm here ;-) ]

Not to mention that this bug was initially for a older release and then reopened, which adds to the confusion. And maybe my comment will lead to even more confusion now, even if I hope it avoids some of it

Comment 33 Jeff Layton 2011-12-12 12:48:34 UTC
Cloned this for vte3. See bug 766607.

Comment 34 Jonathan Abbey 2011-12-12 14:55:45 UTC
I got bit by this this morning in my gtk3-using ROXTerm after upgrading to gtk3-3.2.2-2.fc16.x86_64.

Comment 35 Felipe Contreras 2011-12-12 16:14:19 UTC
(In reply to comment #33)
> Cloned this for vte3. See bug 766607.

As you mention in that bug, reverting gtk3 solves the problem, and I think that's the way to go. Sure, all the users of this, like vte should be fixed, but this change should not be rolled out _until_ all those are fixed.

The important thing is not to break user-experience, which currently is broken, and reverting is the safest way to do that. In fact, I say this should be patched in the newest versions of gtk3, so we don't get stuck, and only remove the patch in rawhide, that's were people should be testing this kinds of stuff.

Comment 36 digimer 2011-12-13 17:03:37 UTC
Ran into this when I updated last night (F16 x86_64 on Dec. 12, 2011). Downgraded and got the <alt> key back;

yum downgrade gtk3 gtk3-immodule-xim

(gtk3 + anything it depends on, gtk3-immodule-xim in my case, gtk3-devel, etc)

Comment 37 Peter Backes 2011-12-13 21:50:45 UTC
*** Bug 759471 has been marked as a duplicate of this bug. ***

Comment 38 Peter Backes 2011-12-13 21:53:07 UTC
updates-testing now has vte-0.28.2-2.fc16.i686 for which I can confirm that it fixes the problem

Comment 39 Jan ONDREJ 2011-12-14 05:58:40 UTC
I can confirm, that vte-0.28.2-2.fc16.i686 fixes roxterm problem.

Comment 40 Jan Willies 2011-12-14 17:30:39 UTC
unfortunately behaviour for gnome-terminal hasn't changed with 0.28.2-2.fc16

Comment 41 Peter Backes 2011-12-14 18:12:36 UTC
(In reply to comment #40)
> unfortunately behaviour for gnome-terminal hasn't changed with 0.28.2-2.fc16

You are at the wrong bug. You are looking for bug 766607 -- gnome-terminal uses vte3, not vte. You need to update to vte3-0.30.1-3.fc16 from updates-testing to fix gnome-terminal.

Comment 42 Felipe Contreras 2011-12-14 20:43:06 UTC
This is a huge mess. I'm creating a tracking bug for all these issues, all the comments should go there I think.

Bug #767769.

I'm also cloning this for the relevant GTK+ issues, which are *regressions*, see bug #767766, and bug #767767.

Comment 43 Jan Willies 2011-12-15 07:25:03 UTC
(In reply to comment #41)
> (In reply to comment #40)
> > unfortunately behaviour for gnome-terminal hasn't changed with 0.28.2-2.fc16
> 
> You are at the wrong bug. You are looking for bug 766607 -- gnome-terminal uses
> vte3, not vte. You need to update to vte3-0.30.1-3.fc16 from updates-testing to
> fix gnome-terminal.

thank you peter. sorry for the noise.

Comment 44 Greywolf 2011-12-15 23:28:13 UTC
Thanks for this.  I am confirming that the gtk3{,-immodule-xim} downgrade fixed the problem.

Comment 45 Matthias Clasen 2012-01-12 20:22:41 UTC
This is fixed in current updates.


Note You need to log in before you can comment on or make changes to this bug.