Bug 759471 - alt key does not work in xfce terminal
Summary: alt key does not work in xfce terminal
Status: CLOSED DUPLICATE of bug 626792
Alias: None
Product: Fedora
Classification: Fedora
Component: vte
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-02 13:10 UTC by Peter Backes
Modified: 2011-12-13 21:50 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-12-13 21:50:45 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 649098 None None None Never

Description Peter Backes 2011-12-02 13:10:17 UTC
Description of problem:
after yum update of gtk2 from 2.24.7-2.fc16 to 2.24.8-2.fc16, the alt key is not passed to processes running inside xfce terminal

Version-Release number of selected component (if applicable):
gtk2-2.24.8-2.fc16.i686
Terminal-0.4.8-1.fc16.i686

How reproducible:
always

Steps to Reproduce:
1. star xfce terminal with bash
2. enter abc abc
3. press alt-backspace
  
Actual results:
last character is deleted

Expected results:
last word is deleted

Additional info:
yum downgrade gtk2 makes the problem go away

see also http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=649098

Comment 2 jonathan baron 2011-12-13 11:41:55 UTC
With Fedora 16, x86_64, and gnome-terminal, which is also loused up the same way, the critical thing to downgrade is gtk3, not gtk2.

gtk3.x86_64 0:3.2.1-1.fc16 works
gtk3.x86_64 0:3.2.2-2.fc16 does not work

To see the effect of downgrading, you need to log out and log in.

And this is with gnome-terminal, which is also affected. (I have not
tried the xfce terminal yet.  Maybe that requires downgrading gtk2.)

Comment 3 Peter Backes 2011-12-13 21:50:45 UTC

*** This bug has been marked as a duplicate of bug 626792 ***


Note You need to log in before you can comment on or make changes to this bug.