Bug 759522 - <alt> Key Doesn't Work in Terminator
Summary: <alt> Key Doesn't Work in Terminator
Status: CLOSED DUPLICATE of bug 626792
Alias: None
Product: Fedora
Classification: Fedora
Component: vte
Version: 16
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-02 15:21 UTC by Michael Babich
Modified: 2011-12-03 16:19 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-12-03 16:19:28 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 626792 None None None Never

Description Michael Babich 2011-12-02 15:21:38 UTC
Description of problem:
This started in the past few days. When Fedora 16 is updated, one of the updated packages breaks the <alt> modifier key of the tiling terminal application called "terminator". Let "foobar" be any key you press (such as "a" or "x"). terminator acts as if "foobar" was pressed instead of "Alt+foobar".

Version-Release number of selected component (if applicable):
terminator-0.96-1.fc16.noarch

How reproducible:
Update to the latest Fedora 16. This has been tested on an i686 laptop, an x86_64 desktop, and two VirtualBox VMs of Fedora 16. One of terminator's dependencies must have broken terminator when it gets updated. I isolated this by testing on the VMs because terminator itself does not get updated, but it clearly breaks after a "yum update".

Steps to Reproduce:
1. On a fresh Fedora 16 release, do "yum install terminator". Note how the <alt> key works, and you can send applications commands like Alt+a or Alt+x.
2. Now, "yum update" to update all packages to their most recent versions.
3. Bring up terminator again.
  
Actual results:
Pressing Alt+a, Alt+x or any other key combination just types "a", "x", etc., instead of using <alt> as a modifier.

Expected results:
The <alt> modifer should send an "Alt+foobar" signal instead of a "foobar" signal.

Additional info:
This only affects the terminals running within terminator. Terminator hotkeys appear to be unaffected. Alt+Up, Alt+F4, etc., still work within the application.

Comment 1 Dominic Hopf 2011-12-03 09:50:04 UTC
Hi Michael,

can you check if there is a gtk and/or vte update available in updates-testing for you? If yes, please apply them and try reproducing the issue. It most likely should already be fixed with one of those updates.

Regards,
Dominic

Comment 2 Dominic Hopf 2011-12-03 16:12:04 UTC
Otherwise the updates from here may fix it:

http://thm.fedorapeople.org/vte/

Comment 3 Christoph Wickert 2011-12-03 16:15:56 UTC
This is currently discussed in https://bugzilla.redhat.com/show_bug.cgi?id=626792, I think we should even close this bug as duplicate.

Comment 4 Dominic Hopf 2011-12-03 16:19:28 UTC

*** This bug has been marked as a duplicate of bug 626792 ***


Note You need to log in before you can comment on or make changes to this bug.