Bug 759647 - Simple macro crashes OOo.Impress
Simple macro crashes OOo.Impress
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
15
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
: 760034 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-02 17:27 EST by Zirneklitis
Modified: 2012-01-25 17:28 EST (History)
6 users (show)

See Also:
Fixed In Version: libreoffice-3.3.4.1-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-23 17:22:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Custom slide show (77.40 KB, application/vnd.oasis.opendocument.presentation)
2011-12-02 17:27 EST, Zirneklitis
no flags Details

  None (edit)
Description Zirneklitis 2011-12-02 17:27:40 EST
Created attachment 539810 [details]
Custom slide show

Description of problem:
OOo.Impress is rather unstable. In this example OOo.Impress is crashed during a slide show when one custom slide show is replaced by another.

Version-Release number of selected component (if applicable):
openoffice.org-impress.x86_64 1:3.3.0-20.8.fc14

How reproducible:
100%

Steps to Reproduce:
1. Open the attached presentation.
2. Enable macros for this presentation.
3. Start slide show.
4. Navigate to the second slide.
5. Choose the second or the third example.

  
Actual results:
OpenOffice.org crashes.

Expected results:
The slide show must go on.

Additional info:
This presentation works fine on:
Ubuntu 10.04	OOo 3.2.0 OOO320m12 Build:9483
Windows XP PRO	OOo 3.2.0 OOO320m12 Build:9483 (GoOO)
Windows 2000	OOo 3.3.0 OOO330m20 Build:9567
Windows XP PRO	OOo 3.3.0 OOO330m20 Build:9567

The "Killer-Macro" is as follows:
------------------------------------
Sub KursSkats (view_name as String)

	oDoc = ThisComponent
	oDoc.Presentation.setPropertyValue("CustomShow", view_name)
	oDoc.Presentation.start() 
    
End Sub
-------------------------------------
Comment 1 Zirneklitis 2011-12-02 17:32:17 EST
Simple error messages:

[ Zirneklitis ~]$ ooimpress 

** (soffice:8898): WARNING **: Inhibit method failed

** (soffice:8898): WARNING **: Inhibit problem : The name org.gnome.SessionManager was not provided by any .service files

** (soffice:8898): WARNING **: Invalid cookie

** (soffice:8898): WARNING **: Inhibit method failed

** (soffice:8898): WARNING **: Inhibit problem : The name org.gnome.SessionManager was not provided by any .service files
/usr/lib64/openoffice.org3/program/soffice: line 116:  8898 Segmentation fault      (core dumped) "$sd_prog/$sd_binary" "$@"
[ Zirneklitis ~]$
Comment 2 Zirneklitis 2011-12-03 00:31:05 EST
The update to

openoffice.org-impress.x86_64 1:3.3.0-20.10.fc14

DOES NOT solve the issue.
Comment 3 Caolan McNamara 2011-12-06 04:58:23 EST
problem seems to be still relevant in contemporary versions
Comment 4 Caolan McNamara 2011-12-06 04:59:38 EST
*** Bug 760034 has been marked as a duplicate of this bug. ***
Comment 5 Caolan McNamara 2011-12-06 17:59:30 EST
Fixed this upstream as http://cgit.freedesktop.org/libreoffice/core/commit/?id=d57887eaad534ca51fc4975918fab66b2f93633d

At this stage however there won't be another update for Fedora 14 (http://lists.fedoraproject.org/pipermail/announce/2011-November/003010.html) so moving to Fedora 15 as earliest release its practical to fix this for.

Did you ever report this to upstream OpenOffice.org or LibreOffice btw ?
Comment 6 Zirneklitis 2011-12-06 22:42:06 EST
> Did you ever report this to upstream OpenOffice.org or LibreOffice

I did not but I shall. As I've mentioned before – on other tested OS the macro does not crash OOo/LibreOffice.

The pre-compiled x64 versions of OOo (3.3.0, from www.openoffice.org) and LibreOffice (3.4.4, from http://www.libreoffice.org/) crashes under Fedora 14. 

The pre-compiled x86 versions of OOo (3.3.0, from www.openoffice.org) crashes under ScientificLinux 6.1 LiveCD.

Both of distributions ar RedHat based.
Comment 7 Zirneklitis 2011-12-06 23:07:11 EST
Reported as
https://issues.apache.org/ooo/show_bug.cgi?id=118671
Comment 8 Caolan McNamara 2011-12-07 07:37:40 EST
no need to report it upstream *now* :-) I just wondered if there were duplicates upstream that I could mark off as fixed now.

Will be in >= libreoffice-3.3.4.1-2.fc15
Comment 9 Fedora Update System 2011-12-15 15:43:42 EST
libreoffice-3.4.4.2-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libreoffice-3.4.4.2-6.fc16
Comment 10 Fedora Update System 2011-12-16 14:59:24 EST
Package libreoffice-3.4.4.2-6.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.4.4.2-6.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-17186/libreoffice-3.4.4.2-6.fc16
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2011-12-23 17:22:30 EST
libreoffice-3.4.4.2-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-01-17 04:09:15 EST
libreoffice-3.3.4.1-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libreoffice-3.3.4.1-2.fc15
Comment 13 Fedora Update System 2012-01-25 17:28:54 EST
libreoffice-3.3.4.1-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.