Bug 759763 - TCT (Alcatel) X200 doesn't work in Fedora 16
TCT (Alcatel) X200 doesn't work in Fedora 16
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: ModemManager (Show other bugs)
16
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-03 11:28 EST by Alexander Ploumistos
Modified: 2013-02-13 08:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 08:49:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages (20.07 KB, text/plain)
2011-12-03 11:28 EST, Alexander Ploumistos
no flags Details
dmesg output (67.94 KB, text/plain)
2011-12-03 11:31 EST, Alexander Ploumistos
no flags Details
newest /var/log/messages (81.78 KB, text/plain)
2012-02-16 02:57 EST, Alexander Ploumistos
no flags Details
ModemManager log (8.17 KB, text/plain)
2012-07-21 06:57 EDT, Alexander Ploumistos
no flags Details
NetworkManager log (7.88 KB, text/plain)
2012-07-21 06:58 EDT, Alexander Ploumistos
no flags Details

  None (edit)
Description Alexander Ploumistos 2011-12-03 11:28:27 EST
Created attachment 540078 [details]
/var/log/messages

Description of problem:

I have a USB 3G modem that used to work fine in Fedora 13 & 14. At most, I might have had to restart NetworkManager, though usually it picked it up and presented mobile broadband as an option.
In Fedora 16 however, that doesn't happen. usb_modeswitch does kick in and switch the device but the option never appears in NetworkManager and nm-connection-editor does not see the device (in previous versions I think it was ttyUSB2).

lsusb output before the switch:
Bus 001 Device 005: ID 1bbb:f000 T & A Mobile Phones 

and after:
Bus 001 Device 006: ID 1bbb:0000 T & A Mobile Phones 



Version-Release number of selected component (if applicable):

NetworkManager-0.9.1.90-5.git20110927.fc16.i686
ModemManager-0.4.998-1.git20110706.fc16.i686



Steps to Reproduce:
1. Plug the device, wait for it to switch modes.
2. Check NetworkManager applet and nm-connection-editor.
  
Actual results:
The device doesn't appear, nor the option for mobile broadband.

Expected results:
The device should appear in nm-connection-editor when a new configuration is to be created. There should also be an option for mobile broadband in NetworkManager.

Additional info:
A sticker on the back of the modem reads:

TCT Mobile Limited
One Touch X200 08 UJS
X200X-2AWNGR1

I tried to use the old usb_modeswitch rule, since the newer one contains more devices of the same family, but ultimately that didn't matter.

I came across this thread here
http://www.fedoraonline.it/modules/newbb/viewtopic.php?viewmode=flat&topic_id=16200&forum=41
and from what I could gather (I don't speak italian and Google Translate is quite flaky) he resolved his problem by downgrading ModemManager and preventing it from updating.

Although this bug mentions the X200 Lenovo laptop, it appears to be quite similar:
https://bugzilla.redhat.com/show_bug.cgi?id=735086


I forced a log rotation and followed the procedure described here https://live.gnome.org/NetworkManager/Debugging to produce the /var/log/messages attachment.

I'm also attaching my dmesg output. The dongle connects at 497.360202.
Comment 1 Alexander Ploumistos 2011-12-03 11:31:40 EST
Created attachment 540079 [details]
dmesg output
Comment 2 Alexander Ploumistos 2012-01-10 04:05:17 EST
Digging through back-ups, I noticed that ModemManager in Fedora 14 was the exact same version, so the problem must lie elsewhere. Any suggestions as to witch component I should put the blame on? Maybe NetworkManager?

I have to say that between this and bug #758543, my AAO's networking capabilities have been severely crippled...
Comment 3 Alexander Ploumistos 2012-02-16 02:57:48 EST
Created attachment 562429 [details]
newest /var/log/messages

I got my hands on a Huawei K3806 3G modem (which was sold to a client as a ZTE K3806) and that worked out of the box. As there have been a few usb_modeswitch and NetworkManager updates since I last checked, I decided to have another go at this. I am attaching my /var/log/messages. In the first half, my Alcatel X200 is connected, gets switched, but NetworkManager doesn't show any mobile broadband options. In the second half, the Huawei modem is connected, switched, NetworkManager picks it up and presents me with the option to use a connection I had created earlier (Vodafone contract).

Current package versions:
kernel-3.2.6-3.fc16.i686
ModemManager-0.4.998-1.git20110706.fc16.i686
NetworkManager-0.9.2-1.fc16.i686
usb_modeswitch-1.2.2-2.fc16.i686
usb_modeswitch-data-20111023-1.fc16.noarch
Comment 4 Dan Williams 2012-07-20 18:10:47 EDT
This one is kinda odd.  Any chance you can follow the debugging steps under "Debugging NetworkManager 0.8 and 0.9 3G connections" on this page and grab the --debug log from MM when the Alcatel X200 is used?

https://live.gnome.org/NetworkManager/Debugging
Comment 5 Alexander Ploumistos 2012-07-21 06:57:08 EDT
I am now on F17 (upgrade performed using preupgrade) and the problem persists. I am attaching ModemManager and NetworkManager logs.
Comment 6 Alexander Ploumistos 2012-07-21 06:57:52 EDT
Created attachment 599519 [details]
ModemManager log
Comment 7 Alexander Ploumistos 2012-07-21 06:58:27 EDT
Created attachment 599520 [details]
NetworkManager log
Comment 8 Fedora End Of Life 2013-01-16 08:08:23 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Fedora End Of Life 2013-02-13 08:49:26 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.