Bug 759907 - Aurorae KWin decoration engine causes jumping on move/resize
Aurorae KWin decoration engine causes jumping on move/resize
Status: CLOSED DUPLICATE of bug 747644
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Desktop, Reopened
: 761503 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-04 14:37 EST by ramesses21
Modified: 2011-12-22 17:47 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-14 08:09:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ramesses21 2011-12-04 14:37:17 EST
Description of problem:
Aeroambience and other window themes with transparent capabilities jump to the top left corner when moved from anywhere, but the top left corner. Half of the windows grab bar when hovered over with the mouse pointer gives a resize option when window is not in the top left corner, the resize option is left to right <-->.

Version-Release number of selected component (if applicable):
kdm-4.7.3-12.fc16.x86_64

How reproducible:


Steps to Reproduce:
1.Enable desktop effects.
2.Change theme to a transparent capable theme.
3.Move a window away from the top left corner.
4.Move the window again.
  
Actual results:
Jumpy windows.

Expected results:


Additional info:
This all began after I upgraded from F15 to F16 using pre-upgrade and removing orphaned packages.
Comment 1 Kevin Kofler 2011-12-04 17:34:30 EST
This is probably the same underlying bug as bug #747644.

Aurorae, the themable (by replacing pictures) KWin decoration engine, seems broken with Qt 4.8. Only native KWin themes written directly as C++ theme engines are working properly.
Comment 2 Kevin Kofler 2011-12-08 09:54:21 EST

*** This bug has been marked as a duplicate of bug 747644 ***
Comment 3 Kevin Kofler 2011-12-08 10:03:05 EST
Actually, this appears to be separate from bug #747644, which appears to be independent of the window decoration used (though it might be related in some way).
Comment 4 Kevin Kofler 2011-12-08 10:03:49 EST
*** Bug 761503 has been marked as a duplicate of this bug. ***
Comment 5 Kevin Kofler 2011-12-14 08:09:49 EST
It turns out that this is, in fact, caused by the same underlying Qt 4.8 RC bug as bug #747644. There's a Qt build now in testing which should fix this.

*** This bug has been marked as a duplicate of bug 747644 ***
Comment 6 Fedora Update System 2011-12-14 08:10:22 EST
qt-4.8.0-0.29.rc1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/qt-4.8.0-0.29.rc1.fc16
Comment 7 Fedora Update System 2011-12-22 17:47:30 EST
qt-4.8.0-0.29.rc1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.