Bug 747644 - title bar menu shown in wrong location
title bar menu shown in wrong location
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
16
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 748195 759907 770124 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-20 11:27 EDT by Jeff Bastian
Modified: 2011-12-23 08:38 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-23 08:38:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
title bar menu screenshot (2.70 MB, image/png)
2011-10-20 11:27 EDT, Jeff Bastian
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 284808 None None None Never
KDE Software Compilation 284876 None None None Never

  None (edit)
Description Jeff Bastian 2011-10-20 11:27:41 EDT
Created attachment 529327 [details]
title bar menu screenshot

Description of problem:
I have a dual-monitor setup (laptop monitor and external monitor).

If I right-click on the title bar or choose the window menu from the left-corner of the title bar, the menu appears on the left monitor even though the window is on the right monitor.

See the attached screenshot where I right-clicked on the Firefox titlebar and the menu appeared way over on the left.

This is new behavior with KDE 4.7.x in Fedora 16 Beta.


Version-Release number of selected component (if applicable):
kdebase-workspace-4.7.2-7.fc16.x86_64

How reproducible:
every time

Steps to Reproduce:
1. right-click on a window title bar or click on the title bar context menu
  
Actual results:
context menu appears off in the weeds

Expected results:
context menu appears next to the cursor

Additional info:
Comment 1 Jeff Bastian 2011-10-24 11:45:17 EDT
I opened upstream KDE bug 284876 for this problem.

Also, I was able to reproduce it on a single-monitor system, the problem is just more pronounced on a dual-head setup.
Comment 2 Rex Dieter 2011-10-24 11:55:13 EDT
This may be a Qt issue too, are the results the same (or different) if using:
https://admin.fedoraproject.org/updates/FEDORA-2011-14348
?
Comment 3 Kevin Kofler 2011-10-24 12:34:53 EDT
*** Bug 748195 has been marked as a duplicate of this bug. ***
Comment 4 Jeff Bastian 2011-10-24 13:16:47 EDT
I already have that Qt version installed and it's still an issue:

$ rpm -q --bydate qt
Wed 19 Oct 2011 08:34:04 AM CDT   qt-4.8.0-0.17.rc1.fc16.x86_64
Comment 5 Kevin Kofler 2011-10-24 14:02:44 EDT
I wonder if this problem might actually have been INTRODUCED by that Qt build. After all, Owen's patch touches code related to finding coordinate offsets.
Comment 6 Rex Dieter 2011-10-24 14:09:01 EDT
Personally, I think it was worse before.  I vaguely recall reproducing this before and it *always* appeared in the upper-left corner.  Now right clicking rightward on the title bar makes it move closer (right-ward) to where it should be.

If I'm annoyed too much, I may downgrade and re-upgrade and retest it all to ensure my recollection there is valid.
Comment 7 Rex Dieter 2011-10-24 14:25:17 EDT
further testing... (added comment upstream too):

left click on upper-left of window => dialog appears on upper left of screen

right click on title bar => dialog is always on top of screen, displaced somewhere between the left of the screen and where it *should* be.  Seems better the closer the left edge of the window in question is located.
Comment 8 Kevin Kofler 2011-12-08 09:54:21 EST
*** Bug 759907 has been marked as a duplicate of this bug. ***
Comment 9 Kevin Kofler 2011-12-08 09:54:34 EST
*** Bug 761503 has been marked as a duplicate of this bug. ***
Comment 10 Kevin Kofler 2011-12-08 10:01:22 EST
Hmmm, I can also reproduce this with a native window decoration (my Quarticurve one), so this doesn't look like the same issue as those 2, though related. I'm going to reopen one of them and close the other as a duplicate of that one.
Comment 11 Fedora Update System 2011-12-14 07:10:02 EST
qt-4.8.0-0.29.rc1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/qt-4.8.0-0.29.rc1.fc16
Comment 12 Kevin Kofler 2011-12-14 08:09:49 EST
*** Bug 759907 has been marked as a duplicate of this bug. ***
Comment 13 Fedora Update System 2011-12-22 17:47:18 EST
qt-4.8.0-0.29.rc1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Kevin Kofler 2011-12-23 08:38:09 EST
*** Bug 770124 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.